Page 24 of 35 FirstFirst ... 14222324252634 ... LastLast
Results 231 to 240 of 344

Thread: Testers needed for PowerPC 12.04

  1. #231
    Join Date
    Aug 2006
    Location
    Sweden
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: Testers needed for PowerPC 12.04

    http://www.everymac.com/systems/appl...ac_800_fp.html

    this imac G4 / 800

    boot with this cd too a GUI desktop the only thing was firefox , it did not start (can be a defect CD )

    boot:live nomodeset xforcenv ( was used )

    rsavage thanks for your work for ppc user

    i will try this CD on a imac G3 snow later

  2. #232
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,105

    Re: Testers needed for PowerPC 12.04

    Vesa isn't installed by default on PowePC and indeed doesn't seem to want to work on my ibook. You sure you weren't falling back to the fbdev driver? The xforcefbdev is genuinely something that could be incorportated into future lubuntu releases (not that I'm going to waste my time suggesting it).

    How bad is this green tint? Is it on everything? Have you tried putting UseFBDev to false? Nobody has reported it on 12.10, so it must be the combination of dri and exa?? Maybe try uninstalling mesa legacy and installing the old 7.11? I'm a bit diappointed by that.....I knew I should of played safe and gone with XAA on the xforceimacg3 xorg.conf.

    Does the mplayer2 without altivec package in the 'extras' directoy work? A patch had already gone in to enable CPU detection so I wasn't sure if it was necessary to provide a non-altivec package.

    Not sure why Firefox isn't working. Do you get an error when you start it from a terminal?

  3. #233
    Join Date
    Apr 2012
    Beans
    103

    Re: Testers needed for PowerPC 12.04

    Quote Originally Posted by rsavage View Post
    Vesa isn't installed by default on PowePC and indeed doesn't seem to want to work on my ibook. You sure you weren't falling back to the fbdev driver? The xforcefbdev is genuinely something that could be incorportated into future lubuntu releases (not that I'm going to waste my time suggesting it).
    Possibly was fbdev. I was playing with both with the intent of finding a way to a gui for those with really borked nouveau support at the moment. (geforce go) You have done that here. I suppose I could waste my time suggesting it.

    Quote Originally Posted by rsavage
    How bad is this green tint? Is it on everything? Have you tried putting UseFBDev to false? Nobody has reported it on 12.10, so it must be the combination of dri and exa?? Maybe try uninstalling mesa legacy and installing the old 7.11? I'm a bit diappointed by that.....I knew I should of played safe and gone with XAA on the xforceimacg3 xorg.conf.
    It is bad enough that no one would want to live with it, but one is able to navigate. It is only in the areas you would expect acceleration related -- shadows, menu bars, etc. Text is off also. Readable, but "double strike" appearance. Switching to XAA solves. All in all, I see this as a major improvement. The whole single, nano, etc. process is a bit much for new or inexperienced users. With this as is, you have a GUI and telling someone to "sudo leafpad ... and make it look like this" is more reasonable.
    UseFBDev False did nothing. Did Tormod's patch get included? I used to get a signal 7 with it?
    Will try playing around with the usual EXA options and taking mesa to 7.11. (Thanks for making that convenient.) I'm doubtful though due to the 8mb gart as mentioned earlier.

    Quote Originally Posted by rsavage
    Does the mplayer2 without altivec package in the 'extras' directoy work? A patch had already gone in to enable CPU detection so I wasn't sure if it was necessary to provide a non-altivec package.
    pending - need to grab dependencies

    Quote Originally Posted by rsavage
    Not sure why Firefox isn't working. Do you get an error when you start it from a terminal?
    no problems with FF on this one

  4. #234
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,105

    Re: Testers needed for PowerPC 12.04

    Quote Originally Posted by str8bs View Post
    Switching to XAA solves.
    I guess that confirms it is an EXA thing then. If you include a picture I'll contact Connor Behan, but the correct thing to do would be open a bug at https://bugs.freedesktop.org/ . It is silly for us to speculate when it could be a endian bug or something. Better to get the opinion of somebody who knows what they are talking about. You could try installing xserver-xorg-video-r128-lts-quantal although this will update your entire Xorg packages (EXA only).

    All in all, I see this as a major improvement. The whole single, nano, etc. process is a bit much for new or inexperienced users. With this as is, you have a GUI and telling someone to "sudo leafpad ... and make it look like this" is more reasonable.
    I could make XAA the default for xforceimacg3 no probs, but I'd prefer to see if we could get EXA working correctly. Does it work without DRI?

    UseFBDev False did nothing. Did Tormod's patch get included? I used to get a signal 7 with it?
    I included the patch.

    pending - need to grab dependencies
    The easiest thing is to install gnome-mplayer and then install my mplayer2 package.
    Last edited by rsavage; March 5th, 2013 at 07:37 PM. Reason: spelling

  5. #235
    Join Date
    Apr 2012
    Beans
    103

    Re: Testers needed for PowerPC 12.04

    Quote Originally Posted by rsavage View Post
    I guess that confirms it is an EXA thing then. If you include a picture I'll contact Connor Behan, but the correct thing to do would be open a bug at https://bugs.freedesktop.org/ . It is silly for us to speculate when it could be a endian bug or something. Better to get the opinion of somebody who knows what they are talking about. You could try installing xserver-xorg-video-r128-lts-quantal although this will update your entire Xorg packages (EXA only).
    Now don't go making sense. Work with developers upstream that have the skills/resources to help? Let upstream developers know people are still using this stuff? What a novel concept!

    Quote Originally Posted by rsavage
    Does it work without DRI?
    yes

    Also- leaving DRI enabled and adding EXANoComposite clears up text completely and just the backgrounds are bad at that point. Icons within the dock look correct.

    I'll get details in a bug report later. I expect they will want to see current as well as latest. Probably be the weekend before I get back to it.

    The attached is from iMac G3 600 with Rage 128 Ultra 16M (running in PCIMode)

    Thanks

    Side note regarding this iso and nouveau on FX5200 -- No color issues. The same well documented accel related workarounds apply. Without NoAccel or increased virtual there is no bottom panel/dock.
    Attached Images Attached Images
    Last edited by str8bs; March 6th, 2013 at 06:06 PM. Reason: Clarify no color issues on Nouveau

  6. #236
    Join Date
    Jan 2011
    Beans
    854

    Re: Testers needed for PowerPC 12.04

    @rsavage:

    Thanks for your efforts, I'll try to test it out on my iBook in a few days and post any relevant comments. Mostly posting here because I haven't gotten any notification on this thread since the recent "upgrade" or whatever, I'm subscribed supposedly to this thread but the last notification was on the aaronparr post . . . nothing on the posts from you with the link to the iso, nothing after that with the Str8 posts or the abtabt posts. Mr Str8 just happend to send me an email offlist . . . so something has been left undone by the forum overhaul?????

    Anyway, as I mentioned now several pages ago the iMac800 is krank, possibly tot or almost . . . so I'll give it a go on the iBook.

    e.e.p.

  7. #237
    Join Date
    Feb 2013
    Beans
    52

    Re: Testers needed for PowerPC 12.04

    I cannot tested at all, the installer of ubuntu 12.04 for mac ppc have the menu blank and the rest looks good, but even though I cannot install it at all.. I don't know whar are the partitions or if there is guided installation as Kubuntu, which is the one I will install if this Ubuntu thing is not resolved...someone could help me...I will install kubuntu now...

  8. #238
    Join Date
    Apr 2012
    Beans
    103

    Re: Testers needed for PowerPC 12.04

    @rsavage Maybe a separate thread for your test ISO is warranted? It could easily get buried or not distinguished from the standard ISO's.

    @gusduenas Graphics driver issues are across the board.They will exist regardless of the distribution for the most part. I found and will post in your other thread.

  9. #239
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Testers needed for PowerPC 12.04

    Quote Originally Posted by str8bs View Post
    Now don't go making sense. Work with developers upstream that have the skills/resources to help? Let upstream developers know people are still using this stuff? What a novel concept!


    yes

    Also- leaving DRI enabled and adding EXANoComposite clears up text completely and just the backgrounds are bad at that point. Icons within the dock look correct.

    I'll get details in a bug report later. I expect they will want to see current as well as latest. Probably be the weekend before I get back to it.

    The attached is from iMac G3 600 with Rage 128 Ultra 16M (running in PCIMode)

    Thanks

    Side note regarding this iso and nouveau on FX5200 -- The same well documented accel related workarounds apply. Without NoAccel or increased virtual there is no bottom panel/dock.
    I'm getting the same graphics issues with my PowerMac G5 and Lubuntu 12.10.

  10. #240
    Join Date
    Apr 2012
    Beans
    103

    Re: Testers needed for PowerPC 12.04

    @cortman
    I mixed issues in my last post. (now edited to clarify)
    Are you having color, acceleration related, or both issues? What card do you have?

Page 24 of 35 FirstFirst ... 14222324252634 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •