Hi, while following this document:
https://help.ubuntu.com/community/Ub...Infrastructure

I get to step 2 where I need to configure a yaml file

I vim it and here's my config:

Code:
juju: environments
environments:
  orchestra:
    type: orchestra
    # Specify the orchestra server's IP address
    orchestra-server: 192.168.2.41
    # Specify storage. In this case we are using webdav installed by orchestra.
    storage-url: http://192.168.2.41/webdav
    # Specify cobbler's usr/pass
    orchestra-user: cobbler
    orchestra-pass: mypasswordforcobbleidefinedinsetup
    admin-secret: arandomthingijusttypedinnow
    # Branch from where we will install ensemble
    # juju-branch: lp:juju
    # Mangement classes
    acquired-mgmt-class: orchestra-juju-acquired
    available-mgmt-class: orchestra-juju-available
then I get this message when I run juju bootstrap

Code:
error: Environments configuration error: /home/node/.juju/environments.yaml: environments.orchestra.default-series: required value not found
I checked and found this other doc on configuring juju with orchestra for local storage:
https://help.ubuntu.com/community/Orchestra/Juju

I don't think I'm following the BZR branch so I should just need to run
Code:
juju boostrap
I think

While looking at the above link, I found it also has a sample config file. There is one slight difference between the config samples - on the last link there the sample has the IP address for the configuration as

Code:
  # Specify the orchestra server's IP address
    orchestra-server: '192.168.2.41'
    # Specify storage. In this case we are using webdav installed by orchestra.
    storage-url: 'http://192.168.2.41/webdav'
while the original document I was followed doesn't have the ' marks between the IP addresses. I tried it both ways, I tried it with using localhost and 'localhost' and I tried reboots between every config change just for extra grins.

Code:
  # Specify the orchestra server's IP address
    orchestra-server: 192.168.2.41
    # Specify storage. In this case we are using webdav installed by orchestra.
    storage-url: http://192.168.2.41/webdav
I don't know what the problem here is, and the only thing I could find online that even remotely appeared to be someone else with this problem was a linked to this:
http://pastebin.com/NNqBkiNn

That link goes to someone who posted the same error message that I get (no solution is on that web link) - basically, if I read this right, there's a configuration error with my environments.yaml and based on the available documentation, I just don't see where I'm going wrong...