My machine has nVidia ION board, its connected through a gigabit cable to a gigabit switch and still it doesn't connect at 1 gigabit.

My system is Ubuntu 11.10, kernel 3.0.0-15-generic

Here are some tests I did to eliminate possible problem causes:

I checked another machine running 11.10 and connected to the same switch and its running at 1 gigabit.

I connected my windows laptop to the same cable and it does connect at 1 gigabit

I ran:
sudo ethtool eth0
and received the following output:

Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 10Mb/s
Duplex: Full
Port: MII
Transceiver: external
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Link detected: yes

sudo ethtool -i eth0


driver: forcedeth
version: 0.64
bus-info: 0000:00:0a.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: no
supports-register-dump: yes

I ran:
lspci | grep MCP

and received the following:

00:0a.0 Ethernet controller: nVidia Corporation MCP79 Ethernet (rev b1)

I tried running:
sudo ethtool -s eth0 speed 100
sudo ethtool -s eth0 speed 1000

but the system told me that it cant advertise 100/1000

when running dmesg | grep forcedeth I see:

[ 1.650676] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[ 1.651618] forcedeth 0000:00:0a.0: PCI INT A -> Link[LMAC] -> GSI 21 (level, low) -> IRQ 21
[ 1.651638] forcedeth 0000:00:0a.0: setting latency timer to 64
[ 1.718445] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x732 @ 3, addr 00:01:2e:27:0e:f9
[ 1.718461] forcedeth 0000:00:0a.0: highdma csum pwrctl gbit lnktim msi desc-v3
[ 17.150584] forcedeth 0000:00:0a.0: eth0: no link

I seem to run out of options, any suggestions how to make it work at normal speed?..

Thanks in advance