Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problems with software upgrading: aptdaemon

  1. #1
    Join Date
    May 2010
    Beans
    37

    Problems with software upgrading: aptdaemon

    When I tried to upgrade the ubuntu s/w, I received the following error messages:

    ================================================== ==============
    An unhandleable error occured

    There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

    Details:
    Traceback (most recent call last):
    File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 968, in simulate
    trans.unauthenticated = self._simulate_helper(trans)
    File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 1092, in _simulate_helper
    return depends, self._cache.required_download, \
    File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 235, in required_download
    pm.get_archives(fetcher, self._list, self._records)
    SystemError: E:The package index files are corrupted. No Filename: field for package ubufox.
    ================================================== ==============

    Any ideas what may be causing this?

    Thanks
    Menachem

  2. #2
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Problems with software upgrading: aptdaemon

    Quote Originally Posted by theKuch View Post
    When I tried to upgrade the ubuntu s/w, I received the following error messages:

    ================================================== ==============
    An unhandleable error occured

    There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

    Details:
    Traceback (most recent call last):
    File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 968, in simulate
    trans.unauthenticated = self._simulate_helper(trans)
    File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 1092, in _simulate_helper
    return depends, self._cache.required_download, \
    File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 235, in required_download
    pm.get_archives(fetcher, self._list, self._records)
    SystemError: E:The package index files are corrupted. No Filename: field for package ubufox.
    ================================================== ==============

    Any ideas what may be causing this?

    Thanks
    Apparently your packages are a bit out of whack. Try running

    Code:
    sudo apt-get install -f
    and

    Code:
    sudo apt-get update
    And post the results here, if you get an error. Good luck!

  3. #3
    Join Date
    May 2010
    Beans
    37

    Re: Problems with software upgrading: aptdaemon

    Thanks, but it didn't seem to loke that

    me@Ubuntu:~$ sudo apt-get install -f
    [sudo] password for me:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libgladeui-1-11 libhighgui2.2 linux-headers-3.0.0-12 libcvaux2.2 libunicap2
    linux-headers-3.0.0-12-generic-pae libcv2.2 oxygen-cursor-theme
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 146 not upgraded.

    me@Ubuntu:~$ sudo apt-get autoremove
    Unknown id: apt-get
    me@Ubuntu:~$
    Menachem

  4. #4
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Problems with software upgrading: aptdaemon

    Hm... It looks as though ubufox is causing trouble. Try uninstalling it and (if you want) reinstalling it-

    Code:
    sudo apt-get purge ubufox
    sudo apt-get install ubufox

  5. #5
    Join Date
    May 2010
    Beans
    37

    Re: Problems with software upgrading: aptdaemon

    Maybe more is corrupted.

    sudo apt-get purge ubufox
    [sudo] password for me:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
    ubufox*
    0 upgraded, 0 newly installed, 1 to remove and 165 not upgraded.
    After this operation, 41.0 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 226411 files and directories currently installed.)
    Removing ubufox ...
    me@Ubuntu:~$ sudo apt-get install ubufox
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    ubufox
    0 upgraded, 1 newly installed, 0 to remove and 165 not upgraded.
    E: The package index files are corrupted. No Filename: field for package ubufox.
    me@Ubuntu:~$
    Menachem

  6. #6
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Problems with software upgrading: aptdaemon

    Ok, run this, but copy/paste so you don't total your system!

    Code:
    sudo rm /var/lib/apt/lists/*
    sudo apt-get update

  7. #7
    Join Date
    May 2010
    Beans
    37

    Re: Problems with software upgrading: aptdaemon

    Didn't like that!

    sudo rm /var/lib/apt/lists/*
    rm: cannot remove `/var/lib/apt/lists/partial': Is a directory

    Menachem

  8. #8
    Join Date
    May 2010
    Beans
    37

    Re: Problems with software upgrading: aptdaemon

    me@Ubuntu:~$ sudo ls /var/lib/apt/lists/
    partial

    and partial is an empty directory
    Menachem

  9. #9
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Problems with software upgrading: aptdaemon

    Quote Originally Posted by theKuch View Post
    me@Ubuntu:~$ sudo ls /var/lib/apt/lists/
    partial

    and partial is an empty directory
    Code:
    sudo rm -r /var/lib/apt/lists/partial
    Then run the update and see if that fixes it.

  10. #10
    Join Date
    May 2010
    Beans
    37

    Re: Problems with software upgrading: aptdaemon

    Great -- seems to be working now! Thanks!!!
    Menachem

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •