Results 1 to 4 of 4

Thread: Can't compile razerd

Threaded View

  1. #1
    Join Date
    Jun 2006
    Kubuntu 12.04 Precise Pangolin

    Can't compile razerd

    Howze about a bump?


    I recently did a fresh install of kubuntu 11.10 64bit. I am using kernel:

    aprompt> uname -r 3.0.0-15-generic
    I have a razer DeathAdder gaming mouse that has given me modest success if i might say so on nexuiz a fps game. However, without being able to configure the mouse for better control, I am like a newbie. So I downloaded the latest version of Michael Bueche's razer configuration program and set about compiling it.

    $ sudo /etc/init.d/razerd start
     * Starting Razer device state daemon: razerd                                                               /usr/local/sbin/razerd: error while loading shared libraries: ../librazer/ cannot open shared object file: No such file or directory
    ~$ ldd /usr/local/sbin/razerd
   =>  (0x00007fff1d5ff000)
            ../librazer/ => not found
   => /lib/x86_64-linux-gnu/ (0x00007f9ab97b8000)
            /lib64/ (0x00007f9ab9b72000)

    I have tried following the advice in a couple of old threads from these forums without success. I have tried creating soft links to the ../librazer/ library file and it is located in:

    $ ls -l /usr/local/lib
    total 100
    drwxr-xr-x 2 root root   4096 2012-01-20 19:24 librazer
    -rwxr-xr-x 1 root root  88751 2012-01-20 20:35
    drwxrwsr-x 4 root staff  4096 2011-10-12 11:08 python2.7
    The librazer folder is where I guess this razer config files thinks its libary file is. So I created the librazer folder and created a link to it from the original. I ran:

    [CODE]sudo updatedb && sudo ldconfig[CODE]

    and attempted to start razerd again. No success. I tried adding a file to the /etc/ folder with a path to the library file called razerd.conf:

    # razer libraries

    No such luck. So now I throw out a life line to my fellow users here on the UbuntuForums. Hope you can be of some help.

    Last edited by skaramanger; January 25th, 2012 at 02:42 AM. Reason: Bumpity Bump please
    M2N-SLI with AMD Phenom II X4 940 8GB of 400Mhz 128bit DDR2 RAM, an Evga GTX560ti Video card Phoenix Bios Rev. 5001

    Kubuntu 12.10 (do-release-upgrade)

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts