Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Problem with thunderbird, firefox and flash

  1. #21
    Join Date
    Nov 2008
    Beans
    5

    Re: Problem with thunderbird, firefox and flash

    Quote Originally Posted by one-up View Post
    Perhaps the unaffected PC is x86?

    I find this problem baffling... Whether firefox is spawned by thunderbird or whether you open it manually it's the same executable right? The same code oughta run?
    Actually, my own PC is also affected, and I figured out why I did not notice before: it turns out that when I was checking the problem that my wife was experiencing, I already had Firefox open, and it had been opened *before* clicking on an URL in an email message in Thunderbird. This is the workaround that others have mentioned in this thread.

    To answer your questions -- both PCs are x86, and the Firefox binary is the same in both cases (manually run or spawned by Thunderbird).

    Based on the .xsession-errors messages I mentioned, I suspect that Thunderbird is spawning Firefox a bit differently than the way it is spawned when Firefox is run manually. This difference causes the Flash plugin initialization to fail when Firefox is spawned by Thunderbird. But this is just conjecture on my part at this time.

  2. #22
    Join Date
    Nov 2008
    Beans
    5

    Re: Problem with thunderbird, firefox and flash

    Another data point: when Thunderbird spawns Firefox to open an URL, it shows like this in ps aux's output:

    $ ps aux | grep firefox
    peloy 5006 5.5 6.1 554864 215876 ? Sl 10:54 1:01 /usr/lib/firefox-9.0.1/firefox http://www.example.com/page-with-flash/

    that Firefox instance won't show Flash objects.

    However, if I manually run Firefox like this:

    $ firefox http://www.example.com/page-with-flash/

    the Flash plugin initializes and everything works fine.

    So, I think there is an issue with the way Thunderbird is spawning Firefox.

  3. #23
    Join Date
    Nov 2008
    Beans
    5

    [SOLVED] Re: Problem with thunderbird, firefox and flash

    Thunderbird 9, now officially available in Ubuntu 11.10, seems to have fixed this issue -- today's package updates brought a Thunderbird upgrade from 8 to 9 and the issue seems to be gone.

  4. #24
    Join Date
    Dec 2007
    Beans
    19

    Re: Problem with thunderbird, firefox and flash

    I can confirm the update has indeed fixed the issue. Thanks developers!

  5. #25
    Join Date
    Jul 2007
    Beans
    30

    Re: Problem with thunderbird, firefox and flash

    Same for me. Thunderbird 9 update seems to have fixed the 'flash not working' spawned Firefox issue.

  6. #26
    Join Date
    Apr 2007
    Beans
    616
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with thunderbird, firefox and flash

    Quote Originally Posted by myoldhouse View Post
    Same for me. Thunderbird 9 update seems to have fixed the 'flash not working' spawned Firefox issue.
    I amd still having this problem I have TB9 and FF10 all from the repos.

    Any more help with this?

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •