Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Muon Software Center crashes at launch

  1. #1
    Join Date
    Sep 2007
    Beans
    587
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Arrow Muon Software Center crashes at launch

    When I start Muon Software Center, it will crash immediately after launch (segmentation fault).

    By contrast, the Muon package manager works fine.

    Any ideas on how to fix this?

  2. #2
    Join Date
    Feb 2008
    Beans
    5,636

    Re: Muon Software Center crashes at launch

    Is the message just a segmentation fault or does it provide any more info?

  3. #3
    Join Date
    Jan 2005
    Beans
    29

    Re: Muon Software Center crashes at launch

    It's kind of a mystery. It seems to affect a lot of users, though can't be confirmed very well, so there must be something else influencing it. Hardware or network related issues.

    Ubuntu bug report

    There's a KDE bug report, too but I believe the KDE team is of the general opinion that Ubuntu messed something up to cause this behavior.

    In the mean time the command line tools work fine (at least for me) and so does the muon package manager(muon vs. muon-installer)

  4. #4
    Join Date
    Sep 2007
    Beans
    587
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: Muon Software Center crashes at launch

    Here's the developer information:

    Code:
    Application: Muon Software Center (muon-installer), signal: Segmentation fault
    [Current thread is 1 (Thread 0xb48aa930 (LWP 14465))]
    
    Thread 2 (Thread 0xb0ea1b70 (LWP 14471)):
    #0  0xb73a3fd4 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #1  0xb533d88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
    #2  0xb533e637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
    #3  0xb533ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
    #4  0xb73a4b37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #5  0xb73751dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #6  0xb7375421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #7  0xb727890b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #8  0xb7355e2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #9  0xb727b7b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #10 0xb5424d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
    #11 0xb5e710ce in clone () from /lib/i386-linux-gnu/libc.so.6
    Backtrace stopped: Not enough registers or memory available to unwind further
    
    Thread 1 (Thread 0xb48aa930 (LWP 14465)):
    [KCrash Handler]
    #7  0xb72cfe11 in QtPrivate::QStringList_contains(QStringList const*, QString const&, Qt::CaseSensitivity) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
    #8  0x08066812 in _start ()

  5. #5
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Muon Software Center crashes at launch

    Quote Originally Posted by Linforcer View Post
    It's kind of a mystery. It seems to affect a lot of users, though can't be confirmed very well, so there must be something else influencing it. Hardware or network related issues.

    Ubuntu bug report

    There's a KDE bug report, too but I believe the KDE team is of the general opinion that Ubuntu messed something up to cause this behavior.

    In the mean time the command line tools work fine (at least for me) and so does the muon package manager(muon vs. muon-installer)

    well Muon is Ubuntu's dev crack at Kpackagekit. it is supposed to be a lot faster than kpackagekit. but if it's not working for osme users... i just hope they fix it until LTS. otherwsie it's better to just have kpackagekit.
    Easy to understand Ubuntu manual with lots of pics: http://ubuntu-manual.org/
    Do i need antivirus/firewall in linux?
    User friendly disk backup (suitable for older PCs): Redobackup Less friendly disk backup (works on new PC): Clonezilla

  6. #6
    Join Date
    Jul 2011
    Beans
    2

    Re: Muon Software Center crashes at launch

    Quote Originally Posted by kooldino View Post
    When I start Muon Software Center, it will crash immediately after launch (segmentation fault).

    By contrast, the Muon package manager works fine.

    Any ideas on how to fix this?

    Mine has been doing the same thing for the past week. I've went so far as to downloading a the DVD again. I've burned it to a DVD, and I've loaded it on to USB sticks with Unetbootin and Startup Disk Creator. It still crashes.

  7. #7
    Join Date
    May 2009
    Beans
    2

    Re: Muon Software Center crashes at launch

    It's the shortcut. If we set the command as just
    Code:
     muon-installer
    it works.

  8. #8
    Join Date
    Jan 2012
    Beans
    3

    Re: Muon Software Center crashes at launch

    I tried changing the command from

    muon-installer %i -caption "%c"

    to

    muon-installer

    but it didn't work for me. Still looking for a solution.

  9. #9
    Join Date
    Jan 2012
    Beans
    3

    Re: Muon Software Center crashes at launch

    Is there an alternative to Muon Software Center? I was thinking of KPackage Kit or is that the same as the standard muon package manager?

    Any help greatly appreciated.

  10. #10
    Join Date
    Nov 2011
    Beans
    Hidden!

    Re: Muon Software Center crashes at launch

    synaptic works fine if you don't care about gtk applications not looking perfect in kde.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •