Results 1 to 1 of 1

Thread: Evolution Ubuntu One Contacts - Address Book Does Not Exist

  1. #1
    Join Date
    Jan 2012

    Evolution Ubuntu One Contacts - Address Book Does Not Exist

    Hi All,
    just wanted to post a fix. After many hours of searching the web, multiple re-installs of certain apps etc this is what resolved my issue with evolution.

    Read edit at bottom of page. Not fully resolved.

    I am running:

    • Ubuntu 10.10(maverick)
    • Kernel 2.6.35-31-generic
    • Gnome 2.32.0
    • Evolution 2.30.3
    • Evolution-couchdb 0.5.0-0ubuntu1
    • Couchdb 1.0.1-0ubuntu3
    • Desktopcouch 0.6.9b-0ubuntu1.1

    I followed the procedure to copy all contacts to Ubuntu One from my Personal Contacts. Got a few errors which were normal ( could not add contact ) but most were transferred.

    Then Evo spat the dummy. Got the message, evolution address book has unexpectedly quit? Then Evo would shutdown.

    Restart Evo, then try to access Ubuntu One contacts and I would get the error message: The address book does not exist?

    I would check ./local/share/desktop-couch/couchdb.html. Open this file in Mozilla. There was data in the contacts.couch database. Tried deleting this and recreating it. No difference. Tried numerous things, reinstall couchdb, reinstall evolution-couchdb. Doing these things did not resolve the issue.

    Tried the reset contacts database as per:
    This did not work. Delete local went ok but could not delete the remote db. Error was does not exist/could not be found or need to input a URL?

    After this it did temporarily work, so I thought just add one contact at a time (maybe the mass transfer of contacts - 656 of them - is corrupting the contacts.couch or couchdb?) When I got to 10. The same thing occurred. The pressure is building by this stage.

    But then mysteriously, I find these contacts have been synced to my Ubuntu One account online? But I cannot access it locally through Evolution. Remove, reboot, re-install Evo. Still no go.

    I found the following link:
    I verified that Avahi was running in processes. There was no instance of Desktopcouch User Authentication in >System>Preferences>Passwords and Encryption Keys>Passwords.
    I did the following and the thorn in my side was finally removed(which is also contained in the link above)! (NOTE: I had no beam.smp service running, only beam)

    Killing and restarting desktopcouch

    To re-start desktopcouch from scratch, do the following, in a terminal window:

    1. killall beam.smp - this will kill any existing desktopcouch processes. (Note: do not do this with sudo!) If this says beam.smp: no process found, then do killall beam instead.
    2. rm ~/.config/desktop-couch/desktop-couchdb.ini - this will remove the desktopcouch configuration file, which will then be re-generated. (This will not lose any data stored in desktopcouch, do not worry.)
    3. dbus-send --session --dest=org.desktopcouch.CouchDB --print-reply --type=method_call / org.desktopcouch.CouchDB.getPort - this should restart desktopcouch. You can ignore messages printed by this command
    4. xdg-open file:///home/YOURUSERNAME/.local/share/desktop-couch/couchdb.html - open the bookmark file, which should then correctly take you to your desktopcouch web interface

    I hope this helps someone out there resolve their headache sooner that what it took me to resolve.

    But it now works and is stable. Go Ubuntu!

    Guys, I have come across one more thing.

    I cannot edit or delete contacts from the local Ubuntu One Contacts list.

    I can add more contacts by copying them from Personal Contacts to Ubuntu One, and they do get propogated to the online contact listing.

    Any edits/additions performed online get propogated back to the local database.

    If anyone could offer any advice to get full stable functionality would be much appreciated. Hopefully this will get resolved properly with future updates?
    Last edited by whatdoyamean; January 14th, 2012 at 09:15 AM. Reason: Still are issues but still usable

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts