Results 1 to 3 of 3

Thread: No icons in menu and menus_have_icons ineffective

  1. #1
    Join Date
    Jan 2012
    Beans
    2

    No icons in menu and menus_have_icons ineffective

    All my gtk apps (Firefox, gnome, gimp, eclipse, etc.) do not have menu icons on a fresh ocelot install. I had the same the problem one year ago, but managed to resolve it.

    The classical workaround to this issue is to set the following gconf property:
    gconftool-2 --type boolean --set /desktop/gnome/interface/menus_have_icons true

    (and optionally buttons_have_icons as well)

    Except that this time, it doesn't work... I tried everything, reset my account, created a new one, each time resettings these boolean values...The icons won't show up.

    Does anyone have an idea of what going wrong? Should I submit a bug report?
    Thanks,
    Marc

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: No icons in menu and menus_have_icons ineffective

    No need for a bug report, it's just that 11.10 has already moved from gconf to gSettings/dconf...

    Install the dconf-tools -package, then start dconf-editor and you'll find the releavant options under org.gnome.desktop.interface.

    ...or use the following commands:
    Code:
    gsettings set org.gnome.desktop.interface menus-have-icons true
    gsettings set org.gnome.desktop.interface buttons-have-icons true
    Last edited by mcduck; January 10th, 2012 at 02:03 PM.

  3. #3
    Join Date
    Jan 2012
    Beans
    2

    Re: No icons in menu and menus_have_icons ineffective

    Quote Originally Posted by mcduck View Post
    No need for a bug report, it's just that 11.10 has already moved from gconf to gSettings/dconf...

    Install the dconf-tools -package, then start dconf-editor and you'll find the releavant options under org.gnome.desktop.interface.

    ...or use the following commands:
    Code:
    gsettings set org.gnome.desktop.interface menus-have-icons true
    gsettings set org.gnome.desktop.interface buttons-have-icons true
    Thanks-a-lot It worked perfectly.

    It's the first time I hear about dconf... Glad to learn something new

    Marc

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •