Results 1 to 2 of 2

Thread: How to stop GUI from loading

  1. #1
    Join Date
    Jul 2011
    Beans
    18

    How to stop GUI from loading

    Hello,

    How do I stop the Xserver or lightdm from loading in Ubuntu 11.10. I am planning on making my computer a server, so I wouldn't need it. For the info I can't find /etc/inittab in Ubuntu. I read in my unix class that it contains the run levels which I can edit

  2. #2
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,803
    Distro
    Ubuntu Development Release

    Re: How to stop GUI from loading

    Quote Originally Posted by viswanathk View Post
    How do I stop the Xserver or lightdm from loading in Ubuntu 11.10. I am planning on making my computer a server, so I wouldn't need it. For the info I can't find /etc/inittab in Ubuntu. I read in my unix class that it contains the run levels which I can edit
    Ubuntu 10.10 and above use upstart to control runlevels, and not System V type init scripts as you are studying.

    You will have to check in the "/etc/init" directory for the correct script to disable in order to stop lightdm loading. I do not know which script will be correct for lightdm, but for gnome, you should look at /etc/init/gdm.conf.

    NOT SURE: Since upstart allows userspace controlling of init, you can also disable it with a command similar to
    Code:
    sudo service gdm disable
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •