Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: USB drive appears unformatted.

  1. #11
    Join Date
    Aug 2012

    Re: USB drive appears unformatted.

    Quote Originally Posted by wigout View Post
    I can format the drive in "Disk Utility" but I don't want to- I want to save the files that are still on there using something like testdisk or ddrescue... but for whatever reason they refuse to work on the usb device.

    Disk Utility does NOT work either ....

    I have the exact same problem (maybe even the same stick ), but i my case it would suffice to have the stick usable again. Formatting with Disk Utility simply produces "Error creating partition table: helper exited with exit code 1: cannot open /dev/sdb: No medium found"
    which somehow doesn't really surprised me


  2. #12
    Join Date
    Aug 2007

    Re: USB drive appears unformatted.

    I've had two similar type things happen. I think my problem was using my USB Flash drive in an Older Compaq Laptop,
    that had USB 1 and a newer Laptop that had USB 2. I've updated my Old Laptop with a USB PCMCIA Card to prevent that
    from happening again. I'm wondering if this is your problem?

    In Linux
    A Linux command to make the USB Flash Drive Read/Write should be hdparm. To locate the device use one of the following commands
    after inserting the device, to determine what the USB Flash Drive is detected as:
    dmesg | tail
    sudo blkid
    fdisk -l
    To turn off disk device`s write protect, use the low level system utility hdparm like this: (where x is the letter of your device [a..z])
    man hdparm
    sudo hdparm -r0 /dev/sdx
    where I assume that /dev/sdx is the Physical disk device you are working on.

    Once the device is Read/Write see if you can use Testdisk/Photorec to recover the files you need to save.
    If those packages fail, you may want to run fsck on the USB Flash Drive to see if it can be repaired.
    fsck /dev/sdx1

    In Windows:
    To test this I used Windows XP "Diskpart" as follows:

    1. Start Menu - Run Program - CMD
    2. When the command console opens, type DISKPART
    3. List the drives by typing LIS DIS
    4. Select the USB drive by typing SEL DIS 1 (if disk 1 is your USB drive)
    5. Inspect the details for that disk by typing DET DIS
    Check if the disk is marked as Read-only
    6. Type ATT DIS CLEAR READONLY to clear the ReadOnly attribute and then type DET DIS again to check it has been cleared.

    (optional - if the drive still is Readonly try this) Type CLEAN to erase all contents from the drive
    (make sure you have selected the correct drive!!!!!)

    7. Finally type EXIT to quit Diskpart

    If this process works it might be the easiest fix. I executed DISKPART on XP, and looked at the commands via HELP. But, I don't
    have a USB Flash Drive that is READ-ONLY right now.

    If that doesn't work, I've got one more suggestion. But, I'll wait until you have exhausted your ideas for that test.

    Last edited by lkraemer; August 9th, 2012 at 08:48 AM.

  3. #13
    Join Date
    Oct 2012

    Re: USB drive appears unformatted.

    Okay, I had this problem and just as I was about to give up I tried flipping the locking switch to "lock" and then trying to read it - it worked! Why? I have no idea. I was able to remove the SD card, flip the switch back to "unlocked" and reformat it as well. I was not trying to get any files off it but simply trying to be able to use it again. Extreme weirdness for me, but maybe the locking switch has something to do with the SD card-computer interface (gee, didn't expect that) that may have gotten around the problem, which then made the card accessible? dunno, but just thought I'd share.

  4. #14
    Join Date
    Jul 2010
    ozarks, Arkansas, USA
    Xubuntu Development Release

    Re: USB drive appears unformatted.

    I'll pop another thought out for nothing... do usb thumb drives also have a backup super block ? As the drive is formated in vfat, can windows re-write the super block from the maybe back up ?

    not much, but it is a thought <==BDQ

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts