Results 1 to 2 of 2

Thread: Motherboard won't boot ubuntu.

  1. #1
    Join Date
    Aug 2009

    Motherboard won't boot ubuntu.

    I got an ASUS M5A97. And i was going to dual boot windows/ubuntu, however, due to it being an UEFI bios, it brought some... "challenges".
    On a regular installation, it just ends up loading windows boot loader and going straight to windows. I tried making an UEFI partition just for the loader and reinstalling ubuntu, it did actually install the boot loader there, and the motherboard tried to load it. However it wouldn't work, the motherboard wouldn't launch the loader at all and i had to repair system in windows 7 as just fixing the windows boot loader wouldn't even fix that, which makes me think that this motherboard when not using a compatible UEFI bootloader, it will load first boot loader it finds on the hard drive. And that happens to be the windows 7 one, I tried using EasyBCD to create a link to the ubuntu bootloader, but got nowhere.

    Is there anyway to fix this? I do know this motherboard loads any linux boot loader fine, but all of the cases i seen were standalone, or at least i guess linux was first in order in partition list.

  2. #2
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Motherboard won't boot ubuntu.

    Lots of users with UEFI are having issues and some have got it working. I hope to have UEFI by summer so I have been saving links and following the issues.

    With UEFI the install works best the reverse of BIOS as grub erases the efi partition and reformats it (may be fixed as they are working on fixes). If you back up the efi partition with the Windows files you can reinstall them, but will have to back up the grub/Ubuntu files reformat back to FAT32 and restore both the Windows efi and grub efi files.

    UEFI bugs:
    Deletes Windows efi partition
    Installer should not format an existing EFI System Partition
    EFI SYSTEM PARTITION should be at least 100 MiB (200 suggested) size and formatted as FAT32, not FAT16
    ctrl-x does not work in grub-efi
    grub-update fails to detect windows bootloader on a uefi system

    grub EFI -skodabenz
    1. Most of the modern UEFI systems come with GPT instead of MBR.
    2. GRUB needs to be installed to the ESP (EFI SYSTEM PARTITION). The ESP has to be the first partition in the drive, with file system of a FAT variant, and it has to be larger then 100 MiB (200MiB or more recommended). Ubuntu mounts the ESP by default in /boot/efi .
    3. After you install grub in the ESP, you need to make a boot enrty for it using efibootmgr, or you could launch it with the UEFI shell
    EFI boot loader information - srs5694 & skodabenz
    Grub2 efi info ArchLinux - Arch but grub2 is grub2 with maybe minor differences by distribution

    Examples that worked, format in advanced with gparted, gpt with find efi output & demesg
    How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)
    efi works with Asus P8H67 with EFI bios Do not recompile note:
    So, in short: create the partitions on a non-EFI system, mkdir 2 folders and install. If I only knew from the start that it was this simple.

    dual boot efi windows and efi linux
    [SOLVED] UEFI Boot Problems
    quiet splash vt.handoff=7 rootdelay=90 reboot=a,w
    MSI UEFI bug work around A75MA-G55 UEFI boot entries disappear
    [SOLVED] Win 7, Natty dual boot on UEFI sort of working
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts