Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Installed 11.10, absolutley no internet

  1. #1
    Join Date
    Dec 2011
    Beans
    5

    Installed 11.10, absolutley no internet

    Hello, I'm new to Ubuntu (first install) and and have a small snag.

    Installed on a compaq presario v5000, wireless says it's disabled by hardware switch- however pressing the switch does not turn it on.

    Also, wired connections do not work either, it cyclically tries to connect and disconnects.

    How do I start the troubleshooting process?

    This laptop a gift I gave for Christmas, i rally need to make it work

  2. #2
    Join Date
    Feb 2006
    Beans
    5,714

    Re: Installed 11.10, absolutley no internet

    if you open a terminal and enter
    Code:
    sudo ifconfig
    what is the output?
    Debian Testing(64bit) + XFCE4 AM2 5200+ ATI Radeon HD4350, 4gig RAM,320Gig and 750gig HDs

    what's the difference between an answer and a solution? An answer is what they want to hear, a solution is what they don't want to hear

  3. #3
    Join Date
    Dec 2011
    Beans
    5

    Re: Installed 11.10, absolutley no internet

    I'm looking and retyping what I see on the laptop, so forgive me for taking so long, but here it is:

    eth0 Link encap: Ethernet HWaddr 00:16:d4:42:a4:08
    inet 6 addr: fe80::216:d4ff:fe42:a408/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RXbytes:0(0.0B) TX bytes:0(0.0B)
    Interrput:22 Base address: 0xa000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets: 96 errors:0 dropped:0 overruns:0 frame:0
    TX packets: 96 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:7584(7.5KB) TX bytes:7584(7.5KB)

  4. #4
    Join Date
    Feb 2006
    Beans
    5,714

    Re: Installed 11.10, absolutley no internet

    okay, it is seeing the network card but not the wireless.

    still in the terminal, whats the output of
    Code:
    lspci
    and
    Code:
    lsusb
    specifically anything related to network
    Debian Testing(64bit) + XFCE4 AM2 5200+ ATI Radeon HD4350, 4gig RAM,320Gig and 750gig HDs

    what's the difference between an answer and a solution? An answer is what they want to hear, a solution is what they don't want to hear

  5. #5
    Join Date
    Dec 2011
    Beans
    5

    Re: Installed 11.10, absolutley no internet

    after typing 'lspci', I found this:

    06:02.0 Network controller: Broadcom Corp BCM4318 [AirForce One 54g]802.11g Wireless LAN controller
    also see something a a modem controller if you need it..

    Code: 'lsusb' returned three root hubs, 2.0, 1.1 and another 1.1

  6. #6
    Join Date
    Feb 2006
    Beans
    5,714

    Re: Installed 11.10, absolutley no internet

    for the wireless, look here

    http://mikebeach.org/2011/05/09/bcm4...-ubuntu-natty/

    you will need to get the wired connection working first though. I wonder if you are having the same problem I'm having with an HP where it seems to see the network card but won't get an ip. I put another nic in and it worked.

    Another question, do you have any kind of MAC filtering or encryption on the router?
    Debian Testing(64bit) + XFCE4 AM2 5200+ ATI Radeon HD4350, 4gig RAM,320Gig and 750gig HDs

    what's the difference between an answer and a solution? An answer is what they want to hear, a solution is what they don't want to hear

  7. #7
    Join Date
    Dec 2011
    Beans
    2

    Re: Installed 11.10, absolutley no internet

    had this problem on a BT5 machine once,
    type

    Code:
    rfkill list
    soft and hard block should read no for the wireless

  8. #8
    Join Date
    Dec 2011
    Beans
    5

    Re: Installed 11.10, absolutley no internet

    thats no moon- you are correct, all readouts said 'no'

    halitech- I don't think so. I've tried connecting wirelessly and by ethernet cable in three locations, where in all cases the computer reacted the same way.

    And what's a nic?

  9. #9
    Join Date
    Dec 2011
    Beans
    2

    Re: Installed 11.10, absolutley no internet

    network interface card

  10. #10
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,907
    Distro
    Ubuntu Gnome Development Release

    Re: Installed 11.10, absolutley no internet

    Hi, this will allow you to install the firmware needed for your driver.

    Download the b43 zip file to a flash drive then drag and drop the file to your ubuntu desktop. Right-click it and select Extract Here. Open a terminal ctrl+alt+t and do:
    Code:
    sudo mkdir /lib/firmware/b43
    sudo cp Desktop/b43/*  /lib/firmware/b43
    sudo rmmod -f b43
    sudo rmmod -f ssb
    sudo modprobe b43
    Run those commands one line at a time, now you should have a working wireless connection.
    Thanks
    Last edited by wildmanne39; February 10th, 2013 at 06:59 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •