Results 1 to 5 of 5

Thread: multiple versions of Firefox/Thunderbird required -- howto install ?

  1. #1
    Join Date
    Feb 2008
    Beans
    20

    Question multiple versions of Firefox/Thunderbird required -- howto install ?

    For Mozilla extension dev/verification I need to work with different versions of FX/TB etc.
    That's also because I need to check with nightly builds -- before a new version is released.

    Those app version can be found at ftp.mozilla, eg.:
    http://ftp.mozilla.org/pub/mozilla.o...x-i686.tar.bz2

    Normally I unpack and move it to /usr/lib/mozilla/.
    AFAIK a launcher with /usr/lib/mozilla/thunderbird/thunderbird.sh should start it.
    But it doesn't.

    Any suggestion?


    Xubuntu 11.10, Dell Vostro 3550/64bit

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: multiple versions of Firefox/Thunderbird required -- howto install ?

    I develop FoxTester extension. It allows to easily install and launch multiple versions of Firefox, Thunderbird, SeaMonkey and Fennec. Install FoxTester in your main profile only.

  3. #3
    Join Date
    Feb 2008
    Beans
    20

    Re: multiple versions of Firefox/Thunderbird required -- howto install ?

    Thanks for yr help.

    Tried to see how it works with adding that extension to SM 2.4.1.
    Unfortunatelly it doesn't install at all!

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: multiple versions of Firefox/Thunderbird required -- howto install ?

    Quote Originally Posted by neandr View Post
    Thanks for yr help.

    Tried to see how it works with adding that extension to SM 2.4.1.
    Unfortunatelly it doesn't install at all!
    It only works/install on Firefox. However, it can be used to install/launch SeaMonkey as well.

  5. #5
    Join Date
    Feb 2008
    Beans
    20

    Question Re: multiple versions of Firefox/Thunderbird required -- howto install ?

    Only yesterday I was able to install with only limited sucess.
    After reading the docu pages (a link to it on the installed extension would be very helpful and saves time for the newbie) I got a setup which downloads the install packages.
    Also they are recognized by the extension with install/launch/delete buttons. But using them seems a bit unexpected:

    - install will directly prompt with the "installed" buble
    - lauch does nothing at all -- beside opening and showing the 'installed' packages with it's icons

    Also after today reboot the FoxTester 1.1.7 was disabled, reinstalling the downloaded XPI enabled it again, but how after a new reboot/recheck for extension update?

    Basically the idea behind your extension sounds great, but how to get it working smoothly?

    Günter

    Xubuntu 11.10 / Xfce 4.8
    Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
    FoxTester1.1.7 foxtester@lovinglinux.megabyet.net

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •