Results 1 to 2 of 2

Thread: 10.10 kernel 3.1.5 needs apparmor 2.4 compatibilty patch

Hybrid View

  1. #1
    Join Date
    Jul 2011
    Beans
    90

    10.10 kernel 3.1.5 needs apparmor 2.4 compatibilty patch

    Just a second ago I was all proud that I compiled and installed a new linux kernel (3.1.5), when I got a load of "kernel needs apparmor 2.4 compatibility patch", and, coincidence or not, wlan0 isn't listed in ifconfig, iwconfig, or ip addr. There are two solutions:

    1. Fine. Patch the kernel and compile it again. EXCEPT... I can't find those patches anywhere. All the links to them give a 404 not found, and the links on the apparmor site point to empty folders on kernel.org

    2. I'm not sure this would work, but update apparmor on my 10.10 64 bit install so it's the same version as in my 3.1.5 kernel source.

    Also, on a possibly related note, when I tried the additional drivers program, these were the following unactivated drivers:
    intel TCO watchdog timer
    input driver event debug module
    I801 SMBus driver
    PC Speaker beeper driver (say that ten times fast)
    Intelligent power sharing driver
    When I try to install them, additional drivers doesn't work and says to check /var/log/jockey.log for details. Here is a sample:
    Code:
    2011-12-21 22:01:02,995 DEBUG: querying driver db <jockey.detection.OpenPrintingDriverDB instance at 0x14c7680> about HardwareID('modalias', 'pci:v00008086d00002C62sv00001025sd00000487bc06sc00i00')
    2011-12-21 22:01:02,995 DEBUG: querying driver db <jockey.detection.OpenPrintingDriverDB instance at 0x14c7680> about HardwareID('modalias', 'wmi:A5AC3B57-CC31-4238-B0FE-AD3B07EC1213')
    2011-12-21 22:01:02,995 DEBUG: querying driver db <jockey.detection.OpenPrintingDriverDB instance at 0x14c7680> about HardwareID('modalias', 'wmi:92714CC4-BEC7-48EE-9907-5B6AB2954FD0')
    2011-12-21 22:01:02,995 DEBUG: querying driver db <jockey.detection.OpenPrintingDriverDB instance at 0x14c7680> about HardwareID('modalias', 'input:b0000v0000p0000e0000-e0,5,kramlsfw8,')
    2011-12-21 22:01:02,995 DEBUG: querying driver db <jockey.detection.OpenPrintingDriverDB instance at 0x14c7680> about HardwareID('modalias', 'pci:v00008086d00003B32sv00001025sd00000487bc11sc80i00')

  2. #2
    Join Date
    Nov 2010
    Location
    Jakarta, ID
    Beans
    1
    Distro
    Ubuntu

    Re: 10.10 kernel 3.1.5 needs apparmor 2.4 compatibilty patch

    *bump*

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •