Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: wireless light on keyboard keeps blinking

  1. #1
    Join Date
    Dec 2011
    Beans
    4

    wireless light on keyboard keeps blinking

    Just installed Ubuntu and the wireless LED keeps blinking when I have a connection but if I disable it turns red like it should.
    Laptop- HP Pavilion DV6 1355dx
    Wireless card- WIFI LINK 1000 BGN

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,890
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless light on keyboard keeps blinking

    I believe your wireless card uses the driver module iwlagn. Check with:
    Code:
    lsmod | grep iwl
    If it is indeed iwlagn, let's try a temporary fix:
    Code:
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn led_mode=1
    Now does the LED behave as expected? If so, let's write a simple file to make it permanent:
    Code:
    sudo gedit /etc/modprobe.d/iwlagn.conf
    Add one line:
    Code:
    options iwlagn led_mode=1
    Proofread carefully, save and close gedit.

    You should be all set.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Oct 2008
    Location
    Austin, TX
    Beans
    492
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: wireless light on keyboard keeps blinking

    The LED blinks to show send-receive activity in addition to wireless on-off.

    What do you mean by "work as it should?" Isn't that what you want, Doc?

    ~~~ 0;-Dan
    "All government spending, regardless of the motives, uses YOUR money."

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,890
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless light on keyboard keeps blinking

    Quote Originally Posted by SaintDanBert View Post
    The LED blinks to show send-receive activity in addition to wireless on-off.

    What do you mean by "work as it should?" Isn't that what you want, Doc?

    ~~~ 0;-Dan
    I do, and many of us do, but many others are offput by the incessant blinking (nagging? sorta like my ex??) and would prefer a simple ON if the wireless is connected and OFF if it's not. The developers of iwlagn and a few other wireless drivers give us the option to select.

    If he were using most other drivers, I would have said, "I can do nuthin' fer ya, son."
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Dec 2011
    Beans
    4

    Re: wireless light on keyboard keeps blinking

    Quote Originally Posted by chili555 View Post
    I believe your wireless card uses the driver module iwlagn. Check with:
    Code:
    lsmod | grep iwl
    If it is indeed iwlagn, let's try a temporary fix:
    Code:
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn led_mode=1
    Now does the LED behave as expected? If so, let's write a simple file to make it permanent:
    Code:
    sudo gedit /etc/modprobe.d/iwlagn.conf
    Add one line:
    Code:
    options iwlagn led_mode=1
    Proofread carefully, save and close gedit.

    You should be all set.
    Worked like a charm. Thank you for the help.

  6. #6
    Join Date
    Oct 2008
    Location
    Austin, TX
    Beans
    492
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: wireless light on keyboard keeps blinking

    Quote Originally Posted by chili555 View Post
    ...
    The developers of iwlagn and a few other wireless drivers give us the option to select.

    If he were using most other drivers, I would have said, "I can do nuthin' fer ya, son."
    Well! (grin, blush) I learn something new every day.

    Cheers,
    ~~~ 0;-Dan
    "All government spending, regardless of the motives, uses YOUR money."

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,890
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless light on keyboard keeps blinking

    Quote Originally Posted by SaintDanBert View Post
    Well! (grin, blush) I learn something new every day.

    Cheers,
    ~~~ 0;-Dan
    A great place to start with driver issues is:
    Code:
    modinfo <your_driver>
    In this case:
    Code:
    $ modinfo iwlagn
    filename:       /lib/modules/3.0.0-14-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
    license:        GPL
    author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
    version:        in-tree:
    description:    Intel(R) Wireless WiFi Link AGN driver for Linux
    firmware:       iwlwifi-5150-2.ucode
    <snip>
    srcversion:     8BCB911ABE7887D81943F53
    alias:          pci:v00008086d00000892sv*sd00000466bc*sc*i*
    <snip>
    depends:        mac80211,cfg80211
    vermagic:       3.0.0-14-generic SMP mod_unload modversions 686 
    parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking (int)
    parm:           no_sleep_autoadjust:don't automatically adjust sleep level according to maximum network latency (bool)
    parm:           bt_coex_active:enable wifi/bluetooth co-exist (bool)
    parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
    parm:           queues_num:number of hw queues. (int)
    parm:           11n_disable:disable 11n functionality (int)
    parm:           amsdu_size_8K:enable 8K amsdu size (int)
    parm:           fw_restart:restart firmware in case of error (int)
    parm:           ucode_alternative:specify ucode alternative to use from ucode file (int)
    parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
    parm:           bt_ch_inhibition:Disable BT channel inhibition (default: enable) (bool)
    parm:           plcp_check:Check plcp health (default: 1 [enabled]) (bool)
    parm:           ack_check:Check ack health (default: 0 [disabled]) (bool)
    Have fun and keep learning!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Oct 2008
    Location
    Austin, TX
    Beans
    492
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: wireless light on keyboard keeps blinking

    Where does one find details to help understand [aka, decode] the details one learns from modinfo?

    If I need to set led_mode with each system startup, which script or job or whatever-they-get-called-this-week do I use to hold the proper commands that run during system start?

    Cheers,
    ~~~ 0;-Dan
    "All government spending, regardless of the motives, uses YOUR money."

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,890
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless light on keyboard keeps blinking

    Quote Originally Posted by SaintDanBert View Post
    Where does one find details to help understand [aka, decode] the details one learns from modinfo?

    If I need to set led_mode with each system startup, which script or job or whatever-they-get-called-this-week do I use to hold the proper commands that run during system start?

    Cheers,
    ~~~ 0;-Dan
    You write a .conf file as above so that the driver name is here:
    sudo gedit /etc/modprobe.d/iwlagn.conf
    And here:
    options iwlagn led_mode=1
    That means, roughly, 'when you load iwlagn, as you would automatically based on the pci.id, load it using an available parameter led_mode and set it to 1.'

    You can also find parameters in the driver's dependencies:
    Code:
    $ modinfo iwlagn
    filename:       /lib/modules/3.0.0-14-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
    license:        GPL
    author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
    version:        in-tree:
    description:    Intel(R) Wireless WiFi Link AGN driver for Linux
    <snip>
    depends:        mac80211,cfg80211
    <snip>
    Code:
    $ modinfo mac80211
    filename:       /lib/modules/3.0.0-14-generic/kernel/net/mac80211/mac80211.ko
    license:        GPL
    description:    IEEE 802.11 subsystem
    srcversion:     64349C3033DDDABE80DEBE4
    depends:        cfg80211
    vermagic:       3.0.0-14-generic SMP mod_unload modversions 686 
    parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)
    parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
    parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
    parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
    Code:
    $ modinfo cfg80211
    filename:       /lib/modules/3.0.0-14-generic/kernel/net/wireless/cfg80211.ko
    description:    wireless configuration support
    license:        GPL
    author:         Johannes Berg
    srcversion:     DBED8A055F9C0F3E8E07D54
    depends:        
    vermagic:       3.0.0-14-generic SMP mod_unload modversions 686 
    parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
    parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)
    Finding documentation on how all these work is difficult. It's also tough if you don't have a device using the driver in question so you can experiment. Often, I ask the poster to try it and cross my fingers!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Aug 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: wireless light on keyboard keeps blinking

    Quote Originally Posted by chili555 View Post
    I believe your wireless card uses the driver module iwlagn. Check with:
    Code:
    lsmod | grep iwl
    If it is indeed iwlagn, let's try a temporary fix:
    Code:
    sudo modprobe -r iwlagn
    sudo modprobe iwlagn led_mode=1
    Now does the LED behave as expected? If so, let's write a simple file to make it permanent:
    Code:
    sudo gedit /etc/modprobe.d/iwlagn.conf
    Add one line:
    Code:
    options iwlagn led_mode=1
    Proofread carefully, save and close gedit.

    You should be all set.
    Thanks man! One more "feature" of 11.10 that is no longer bugging me.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •