My desktop PC's wireless card seems to be having trouble with Linux. I've tried openSUSE 12.1 and Fedora 16 and they all gave me the same problem. (Here's the thead I opened in Fedora forums
Now, I'm back on Ubuntu 10.04 and I've gotta say it works better than it did on other distros but still, the problem persists. My PC specs are as follows.

Motherboard -- Asrock N68-S3 UCC
CPU -- AMD Phenom 2 X4 AM3 3.3 GHz
GPU -- MSI ATI Radeon HD 5450 1GB
RAM -- 8GB DDR3 1333
HDD -- 750GB SATA2 7200RPM, 80GB IDE 7200RPM
PCI Wireless card -- TP-LINK TL-WN851ND (Atheros AR9287 chipset)
I've searched on Google and Ubuntu forums for AR9287 related problems and found a few threads but none of them are on Ubuntu 10.04. Besides, I want more of a "direct help" so I decided to open my own thread.

I've installed and tried Ubuntu 11.10 and the moment it got connected to my home wireless connection, it froze. Then, I went on trying other distros like I mentioned above (because I was quite put off by 11.10's interface and unity) but more or less encountered the same problem. So, now I'm back to home; Ubuntu 10.04

Lucid seems to handle the wireless connection quite well.
I tried the live CD first and then installed while connected to the wireless connection but hung up at 76%. So, I had to try it again but without being connected to the wireless.
(I didn't mind this because it's the same on my laptop; not being able to install Ubuntu when connected to the Internet. My laptop uses ath9k driver as well but has been running 10.04 for ages without any trouble.)

The installation was successful. I logged into the system for first time and connected to the home wireless connection. It was fine, freezing or hungups. I even ran Update Manager to download and install all the updates. Everything went well.

However, the problem started when I tried to install apps from Synaptics. The PC completely freezes and I had to hold down power button to shut it down. I did this twice and it gave me the same problem.

So, this is tedious wireless problem. Is there solutions for this? Anything to make Ubuntu runs smoothly like it used to my laptop.

If you need any further information from me, please let me know but do elaborate on technical details. Although I've been using Ubuntu for some time, I'm still not that technical savvy.

Many thanks and regards.