Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Java broke after latest Ubuntu update

  1. #1
    Join Date
    Apr 2008
    Location
    Philippines
    Beans
    55

    Angry Java broke after latest Ubuntu update

    Today Ubuntu updated Sun Java on my lucid 10.04, but there is something wrong.

    java -version gives:
    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing)

    However when I test Java on ://java.com/en/download/testjava.jsp I get "Something is wrong. Java is not working". Besides when I check about : plugins the Java plugin is now not installed anymore in Firefox 8.0.

    What happened and what can I do?
    Prediction is very difficult, especially of the future

  2. #2
    Join Date
    May 2008
    Location
    Center of England
    Beans
    219
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Java broke after latest Ubuntu update

    Running 10.04 Desktop - I looked at the link you posted. My Firefox 8.0 is told it is working fine but then I am using Java SE 6 Update 20 (it does tell me an update is available).

    Looking in the Firefox addons there is no Java addon in Extensions or Plugins, so I don't think that is your problem.

    I'd be tempted to remove Java and re-install. Not sure how else you might track the problem.

    atb k
    vim Java PHP Perl and C a long time ago :/
    ssh_user to ssh in then su to sudo_user. They have to guess 'name' and 'password' X 2 - sudo is good

  3. #3
    Join Date
    Apr 2008
    Beans
    451
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Java broke after latest Ubuntu update

    confirmed in kubuntu lucid 32bit and

    - firefox 3.6.24
    - chrome 16.0.912.63
    - opera 11.60 Build 1185

    None of them does list java in aboutlugins anymore

    I guess one of those 3 packages messed it up:
    Code:
    sun-java6-bin_6.26-2lucid1_i386.deb
    sun-java6-jre_6.26-2lucid1_all.deb
    sun-java6-plugin_6.26-2lucid1_i386.deb
    Edit: Bugreport: https://bugs.launchpad.net/ubuntu/+s...a6/+bug/905026

    Bug is confirmed, workaround is the jre binary from the oracle site, or the usual java ubuntu ppas ...

    I prefer to wait until they fix it @canonical
    Last edited by Lampi; December 16th, 2011 at 02:47 PM. Reason: Found Bugreport

  4. #4
    Join Date
    Aug 2010
    Beans
    161

    Re: Java broke after latest Ubuntu update

    After updating to java 6 update 30 it does not work.
    Is there a way I can get java 6 update 29 back?
    Thanks.

  5. #5
    Join Date
    Apr 2008
    Beans
    451
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Java broke after latest Ubuntu update

    @ubto66: here's how I downgraded to the last working version @canoncial, now java is working again

    Will only work on Lucid and Canonical packages
    Edit 2: canonical removed last working version, so this won't work anymore, sorry

    Code:
    sudo aptitude install sun-java6-bin=6.26-1lucid1 sun-java6-plugin=6.26-1lucid1
    apt-cache policy sun-java6-bin
    Code:
    sun-java6-bin:
      Installed: 6.26-1lucid1
      Candidate: 6.26-2lucid1
      Version table:
         6.26-2lucid1 0
            500 http://archive.canonical.com/ lucid/partner Packages
     *** 6.26-1lucid1 0
            100 /var/lib/dpkg/status
    Edit: Optional: Set java packages on hold until they fix it:

    Code:
    sudo aptitude hold sun-java6-bin sun-java6-jre sun-java6-plugin
    once they fixed it it's aptitude unhold ...
    Last edited by Lampi; December 21st, 2011 at 11:52 AM. Reason: Added unhold + canoncial remove last working version

  6. #6
    Join Date
    Aug 2010
    Beans
    161

    Re: Java broke after latest Ubuntu update

    Thank you lampi.
    I'm not that skilled on ubuntu, so all this
    #!/bin/bash

    OLDPWD=$PWD

    mkdir /tmp/revert-java
    cd /tmp/revert-java

    wget http://archive.canonical.com/pool/pa...ucid1_i386.deb
    wget http://archive.canonical.com/pool/pa...lucid1_all.deb
    wget http://archive.canonical.com/pool/pa...ucid1_i386.deb

    dpkg -i sun-java6-bin_6.26-1lucid1_i386.deb sun-java6-jre_6.26-1lucid1_all.deb sun-java6-plugin_6.26-1lucid1_i386.deb

    apt-cache policy sun-java6-bin

    cd $OLDPWD


    ~$ apt-cache policy sun-java6-bin
    sun-java6-bin:
    Installed: 6.26-1lucid1
    Candiate: 6.26-2lucid1
    History:
    6.26-2lucid1 0
    500 http://archive.canonical.com/ lucid/partner Packages
    *** 6.26-1lucid1 0
    100 /var/lib/dpkg/status
    is to be run in terminal?

  7. #7
    Join Date
    Apr 2008
    Beans
    451
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Java broke after latest Ubuntu update

    @ubto66: found an easier way - try the aptitude line from terminal

    btw: if you are not using lucid this will not work for you -> you'll have to change the line to natty or whatever ubuntu you are using
    Last edited by Lampi; December 16th, 2011 at 04:33 PM.

  8. #8
    Join Date
    Nov 2009
    Beans
    76
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Java broke after latest Ubuntu update

    Quote Originally Posted by captain_rob View Post
    Today Ubuntu updated Sun Java on my lucid 10.04, but there is something wrong.

    java -version gives:
    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing)

    However when I test Java on ://java.com/en/download/testjava.jsp I get "Something is wrong. Java is not working". Besides when I check about : plugins the Java plugin is now not installed anymore in Firefox 8.0.

    What happened and what can I do?
    Once you upgrade the firefox to firefox 8.0 there is one issue. The plugins location
    is change to /usr/lib/firefox-8.0/plugins/ from /usr/lib/firefox/plugins/

    and hence you need to move files from /usr/lib/firefox/plugins/ to /usr/lib/firefox-8.0/plugins/ especially your link to libnpjp2.so

    You can also create a new link in the /usr/lib/firefox-8.0/plugins/

    To understand the above you may also refer:

    http://www.java.com/en/download/help/linux_install.xml

    I could solve my issue in this way hope you can too.

  9. #9
    Join Date
    Apr 2008
    Location
    Philippines
    Beans
    55

    Re: Java broke after latest Ubuntu update

    Thanks Yndesal, you pointed me in the right direction.

    However my firefox plugins are in:
    cd /usr/lib/mozilla/plugins
    and my Java (from canonical partners repositories) in:
    /usr/lib/jvm/java-6-sun/jre/lib/i386

    So I could solve my problem with:

    cd /usr/lib/mozilla/plugins
    sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so
    Prediction is very difficult, especially of the future

  10. #10
    Join Date
    Apr 2008
    Location
    Philippines
    Beans
    55

    Re: Java broke after latest Ubuntu update (SOLVED)

    Thanks Yndesai, you pointed me in the right direction.

    However my firefox plugins are in:
    cd /usr/lib/mozilla/plugins
    and java (from canonical partners repositories) in:
    /usr/lib/jvm/java-6-sun/jre/lib/i386

    So I could solve my problem with:

    cd /usr/lib/mozilla/plugins
    sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

    Prediction is very difficult, especially of the future

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •