hey I tried to see if DMA was enabled, because my cd drive is acting screwy so far in dapper, but I don't even have a dev/hdc

is this weird?

Here is the wiki I tried to use:

HTML Code:
To enable DMA, you need to use the hdparm command and the configuration file hdparm.conf.

These instructions assume that you are trying to enable DMA on hdc, usually the CD-rom drive.


      See the what the settings are on /dev/hdc

               sudo hdparm /dev/hdc


      If you get a line like  using_dma    =  1 (on), DMA is already enabled. Skip to step 4 to see if it has been enabled at boot time.

      Enable DMA on /dev/hdc

               sudo hdparm -d1 /dev/hdc


      You have now enabled DMA for the drive. However, in order for the settings to be automatically applied at boot there you need to edit the /etc/hdparm.conf script. To do this use this command: sudo gedit /etc/hdparm.conf

Add the following to the end of your hdparm.conf

/dev/hdc {
dma = on

(another way of avoiding editing of the hdparm.conf file is to simply run sudo hdparm -d1 -k1 /dev/hdc to keep the DMA flag).