Page 28 of 28 FirstFirst ... 18262728
Results 271 to 273 of 273

Thread: Sound troubleshooting

  1. #271
    Join Date
    Apr 2010
    Cape Breton, Nova Scotia
    Ubuntu 22.04 Jammy Jellyfish

    Re: Sound troubleshooting

    I seem to have fixed it. On this page

    the poster found that they had multiple copies of snd-hda-codec.ko and of snd-hda-intel.ko and that manually loading some worked while others did not. The issue seemed to be that the ones from the ubuntu-audio-dev ppa didn't work and those were what was being loaded. On that theory I removed the ubuntu-audio-dev package. This seems to have fixed my sound (. That still leaves me confused since I *think* I installed those in the process of trying to fix this. But it's possible I had already installed them during some earlier round of sound problems and a recent update rendered them broken for my system. Anyway, the problem seems to have been the incorrect snd-hda-codec which caused modprobe to fail to load snd-hda-intel.

    My microphone jack and my internal microphone don't work, but they haven't worked for a long time. I think I just need to fiddle with my pin assignments using hdajackretask until I find a setup that works.


  2. #272
    Join Date
    Mar 2014

    Re: Sound troubleshooting how to output sound from a daemon

    I'm running a MQTT app that I would like to be able to play .mp3 files. I attempted to simply run mpg321 but that fails with

    Playing MPEG stream from ...MPEG 1.0 layer III, 56 kbit/s, 44100 Hz stereo
    Error opening unknown libao pulse driver. (Is device in use?)

    Running mpg321 from the console works fine. And no, the device isn't in use. There isn't anyone logged into the console normally but I did try it both ways.

    Running 20.04

     cat /proc/asound/cards
     0 [NVidia_1       ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xdeef4000 irq 22
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                        HDA NVidia at 0xdef7c000 irq 18

  3. #273
    Join Date
    Feb 2008

    Kubuntu 21.04 Hirsute no sound

    I have an AMD X570 mobo, 5600X CPU, Kubuntu 21.04 development latest with all updates, kernel 5.10.0-14-generic, and Nvidia GTX 1650 graphics card. Generally working well, but no sound.

    Card 0 is NVidia HDA HDMI (I've turned off NVIDIA HDMI in System Settings audio settings)
    Card 1 is Generic [HD-Audio Generic], device 0: Realtek ALCS1200A Analog

    The ACLS1200A uses snd_hda_intel and snd_hda_codec_realtek, the correct sound modules seem to be loaded, and both sound device show up in System Settings

    The sound works using my Windows 10 "Win2go" (live image) USB stick, and the NVIDIA HDA HDMI using an audio splitter, but not on hirsute 21.04 thru mobo audio output jacks.

    I've set the volumes in alsamixer and I've tried "lots of things" to fix, no joy.

    My alsa-info script output is at

    Appreciate help - Gus

Page 28 of 28 FirstFirst ... 18262728

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts