Hello everyone,

Thanks so much for reading. I using Ubuntu 10.04 LTS Server edition to run a file server for my lab. I was trying to install matlab and had the folder /mathworks_downloads/MathworksDownloads/ and I wanted the contents of MathworksDownloads to be moved up one level since I had copied that folder from somewhere else. I tried to use the command:

$/mathworks_downloads/MathworksDownloads/ sudo mv * ../

but I think I either had a space between the .. and the /, so maybe I did sudo mv *.. / or perhaps I somehow typed sudo mv /* .. I'm really not sure what I did.

The result is that somehow I moved the root directory to who knows where. I couldn't use the command line anymore, because there were no directories to cd to or look into. I restarted and I am not able to boot into the machine. I tried to use the live CD to see if my data was still okay, but I couldn't find any of the right folders.

About my server configuration: I'm very new to all of this, so my apologies if something doesn't make sense. I have three drives, sda(250GB), sdb(2TB), sdc (2TB). I created md0 and md1 so I could make sdb and sdc raid partitions. I had sdb0 and sdc0 as swap which pointed to part of sda0 and sdb1 and sdc1 as the file system, mount point was /-root and I pointed that somehow to sda1. I had sda1 as bootable. I really hope that makes sense. I thought everything made sense a few months ago I created it, but my documentation is terrible and now I don't remember.

Any help/advice you might have would be greatly appreciated. I'm new to ubuntu and very new to the command line interface for the server edition.

Thanks so much!