Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Extremely slow 3D in Ubuntu guest on VBox

  1. #11
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,744

    Re: Extremely slow 3D in Ubuntu guest on VBox

    Quote Originally Posted by orrorin View Post
    True. If VirtualBox didn't support 3D acceleration for Linux guest, it would warn just like it does for 2D acceleration.

    It's just that in my case, by enabling 3D acceleration, I'm getting Total Deceleration.

    Can you please post your host details? i.e. what (graphics) hardware and OS you are running on the host machine?
    Think pad R61 with 4GB Ram
    Nvidia Quadro NVS 140M 512Mb Ram

    Running Debian Testing (wheezy) x64

    I have a 11.10 VM running all the time minimised so i can troubleshoot the usual unity blah blah rants on here, the VM has 768Mb ram and runs with no worries at all with Unity 3D.

    I also currently have a centOS server VM running with 512, and a XP VM with 512. I never assign more than 24 MB video memory to my VM's. i am not a game player but i do use Adobe alot in my XP and i also use skype video conferencing

    Also clementine is running playing music and signed in to Xchat.

    All running seemlessly and i have over 2 gb spare ram, no swap being used and CPU % is low on both.

    Why run google earth in a VM anyways ? why dont you run it natively, it works as well on Linux and Windows why virtualise it ?

    Peace
    Last edited by haqking; November 16th, 2011 at 08:26 PM.
    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

  2. #12
    Join Date
    May 2007
    Beans
    71
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Extremely slow 3D in Ubuntu guest on VBox

    Quote Originally Posted by haqking View Post
    Think pad R61 with 4GB Ram
    Nvidia Quadro NVS 140M 512Mb Ram

    Running Debian Testing (wheezy) x64

    I have a 11.10 VM running all the time minimised so i can troubleshoot the usual unity blah blah rants on here, the VM has 768Mb ram and runs with no worries at all with Unity 3D.

    I also currently have a centOS server VM running with 512, and a XP VM with 512. I never assign more than 24 MB video memory to my VM's. i am not a game player but i do use Adobe alot in my XP and i also use skype video conferencing

    Also clementine is running playing music and signed in to Xchat.

    All running seemlessly and i have over 2 gb spare ram, no swap being used and CPU % is low on both.

    Why run google earth in a VM anyways ? why dont you run it natively, it works as well on Linux and Windows why virtualise it ?

    Peace
    Thanks for the host/hardware information. Looks like you are getting a lot of juice out of your hardware. (Professional software engineer??)

    In my non-3D-accelerated VM, it falls back to Unity 2D. However, it does show some the 3D effects. e.g. When I run glxgears in this VM, I get a frame rate of around 650FPS.

    But, when I enable 3D acceleration in my VM, the entire system seems to slow down. After increasing the video RAM from 128MB to 256MB, I was able to get marginally better performance but could barely open websites. When I run glxgears in this VM, I get a frame rate of about 900FPS. Still the system performance is abysmal.

    No particular reason for running google-earth in VM. Some people like to play computer games, I like to see software work.
    Last edited by orrorin; November 16th, 2011 at 09:58 PM.
    Ubuntu 15.04 Vivid Vervet
    VirtualBox 4.3.30 Guest: 2GB RAM + 2 CPUs

  3. #13
    Join Date
    Feb 2011
    Location
    not in Slovenia anymore
    Beans
    1,137
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Extremely slow 3D in Ubuntu guest on VBox

    Quote Originally Posted by orrorin View Post
    True. If VirtualBox didn't support 3D acceleration for Linux guest, it would warn just like it does for 2D acceleration.

    It's just that in my case, by enabling 3D acceleration, I'm getting Total Deceleration.

    Can you please post your host details? i.e. what (graphics) hardware and OS you are running on the host machine?
    My host machine info:
    Proc: i5 750 (quad @ 2.67 GHz)
    Ram: 4 * 2Gb dual channel @ 1333MHz
    GPU: ATI Radeon 4300/4500 (4350 if I'm not mistaking), 512MB passive
    Main disk: SSD 64GB
    uname: Linux drak 2.6.35-30-generic #61-Ubuntu SMP Tue Oct 11 17:52:57 UTC 2011 x86_64 GNU/Linux

    So the GPU is really the lamest one I could buy, but cuts the mustard for me, very well actually. As a developer and a non-gamer its enough, altho I must say, that I played Trine, the Linux version and the Wine version and both acted pretty good.
    Don't ask what your company can do for you.
    Ask what you can do for
    your company!

  4. #14
    Join Date
    May 2007
    Beans
    71
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Extremely slow 3D in Ubuntu guest on VBox

    Thank you everyone for your tips and info; I was able to fix/get a work around for the problem.

    The problem was there 2 graphics cards on my HP laptop, one from Intel (which is used for power save mode) and another from AMD/ATI (for performance mode) and the laptop supports dynamic graphics switching. Ideally, a user should be able to specify (through the Catalyst app from AMD) what graphics card should be used for a named Windows application. In my case, after some googling around, I set VirtualBox to use the performance mode. For some reason, this was not working. So, I had to disable the Dynamic Graphic Switching feature from the BIOS and now it works fine.

    Here's the original thread from HP's support forum...

    http://h30434.www3.hp.com/t5/Noteboo.../327018/page/2

    Thanks again everyone for sharing your CPU cycles on this.
    Ubuntu 15.04 Vivid Vervet
    VirtualBox 4.3.30 Guest: 2GB RAM + 2 CPUs

  5. #15
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,744

    Re: Extremely slow 3D in Ubuntu guest on VBox

    Quote Originally Posted by orrorin View Post
    Thank you everyone for your tips and info; I was able to fix/get a work around for the problem.

    The problem was there 2 graphics cards on my HP laptop, one from Intel (which is used for power save mode) and another from AMD/ATI (for performance mode) and the laptop supports dynamic graphics switching. Ideally, a user should be able to specify (through the Catalyst app from AMD) what graphics card should be used for a named Windows application. In my case, after some googling around, I set VirtualBox to use the performance mode. For some reason, this was not working. So, I had to disable the Dynamic Graphic Switching feature from the BIOS and now it works fine.

    Here's the original thread from HP's support forum...

    http://h30434.www3.hp.com/t5/Noteboo.../327018/page/2

    Thanks again everyone for sharing your CPU cycles on this.
    Cool, glad you got it sorted.

    remember to use thread tools to mark the thread as solved.

    Cheers
    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •