Results 1 to 5 of 5

Thread: 10.04 - libavcodec incomplete/outdated ... How Do I Upgrade?

  1. #1
    Join Date
    Aug 2007
    Beans
    63

    10.04 - libavcodec incomplete/outdated ... How Do I Upgrade?

    Hello all,
    I am having issues compiling a program that makes use of ffmpeg's libavcodec and libavutil libraries. More specifically, my libraries are either outdated or incomplete. Examination of ffmpeg.org shows that the newest libraries have the definitions I need (which are making my compile fail.) What's more irritating is that the avcodec.h library I have makes a reference to a struct I need (AVPacket) in the comments and doesn't defines it.

    Why do I have incomplete libraries? Updating them achieved nothing. How do I update them without removing them and installing them from source. (I have ROS installed, and removing libavcodec forces an entire uninstallation of ROS.) Thank you for your time.

    Constantin

  2. #2
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 24.04 Noble Numbat

    Re: 10.04 - libavcodec incomplete/outdated ... How Do I Upgrade?

    I wonder if you need the unstripped packages available from the multiverse medibuntu repositories.

    I have several libav*-extra packages installed in place of the usual ones, but I have never needed to compile anything of this sort, so I may be quite wrong.
    They are:-
    libavcodec-extra-52
    libavdevice-extra-52
    libavfilter-extra-0
    libavformat-extra-5
    libavutil-extra-49

  3. #3
    Join Date
    Jun 2007
    Beans
    17,337

    Re: 10.04 - libavcodec incomplete/outdated ... How Do I Upgrade?

    If the source you're compiling can statically link to ffmpeg then you can build a current ffmpeg source as static & use that. This will not interfere with the current 10.04 apps that use ffmpeg's shared libs

    I'd give that a try first -
    http://ubuntuforums.org/showpost.php...postcount=1289

  4. #4
    Join Date
    Aug 2007
    Beans
    63

    Re: 10.04 - libavcodec incomplete/outdated ... How Do I Upgrade?

    ajgreeny - I tried your suggestion, unfortunately it did not work.

    mc4man - I was hoping to avoid this, but I understand it's a possibility. I am just confused as to why 10.04 ships with incomplete packages? I am still learning linux, why did the ffmpeg upgrades not get passed to the 10.04 repos? Is there a way to force it?

  5. #5
    Join Date
    Jun 2007
    Beans
    17,337

    Re: 10.04 - libavcodec incomplete/outdated ... How Do I Upgrade?

    Quote Originally Posted by Spaceman Spiff View Post
    mc4man - I was hoping to avoid this, but I understand it's a possibility. I am just confused as to why 10.04 ships with incomplete packages? I am still learning linux, why did the ffmpeg upgrades not get passed to the 10.04 repos? Is there a way to force it?
    It's not shipping with "incomplete", just the ffmpeg source it, (10.04), released with.
    There is no way that 10.04 will ever 'officially' get a new FFmpeg source, - (I'm sure there may be a ppa or 2 that has newer FFmpeg or Libav source builds - though see below..

    It is possible to rebuild a more current FFmpeg or Libav as shared in 10.04 though that could require rebuilding packages that dep on the shared libs or they can break on starting or functioning
    (it can get a little messy & or time consuming to get it right

    Edit: just to note - Libav is a fork of FFmpeg, ubuntu is now using Libav even though some of the names are the same - more nonsense to keep track of

    http://libav.org/
    http://ffmpeg.org/
    Last edited by mc4man; November 7th, 2011 at 07:34 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •