Results 1 to 5 of 5

Thread: Enabling WiFi management

  1. #1
    Join Date
    Nov 2011

    Enabling WiFi management

    Hi all !!
    I just installed Kubuntu 11.10 on my Toshiba Satellite C-650D.
    The problem is that I am not able to connect to a WiFi access point. I looked through the forum but none had the same problem since when I type

    lshw -C network
    WARNING: you should run this program as super-user.
    *-network DISABLED
    description: Wireless interface
    product: RTL8188CE 802.11b/g/n WiFi Adapter
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wlan0
    version: 01
    serial: b4:74:9f:e0:dd:20
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=rtl8192ce driverversion=3.0.0-12-generic firmware=N/A latency=0 multicast=yes wireless=IEEE 802.11bgn
    resources: irq:16 ioport:3000(size=256) memory:d0200000-d0203fff
    description: Ethernet interface
    product: AR8152 v1.1 Fast Ethernet
    vendor: Atheros Communications
    physical id: 0
    bus info: pci@0000:06:00.0
    logical name: eth0
    version: c1
    serial: 00:26:6c:c2:aa:f3
    size: 100Mbit/s
    capacity: 100Mbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion= duplex=full firmware=N/A ip= latency=0 multicast=yes port=twisted pair speed=100Mbit/s
    resources: irq:41 memory:d0100000-d013ffff ioport:2000(size=12
    WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

    This is what I get (*-network DISABLED for wifi). So I guess I just have to enable WiFi management... but as you can easily guess, I am a begginer
    Note that Kubuntu (nor Ubuntu) is not 100% compatible with my laptop (maybe the new AMD shipsets are the problem), but WiFi should work since it worked on Ubuntu 11.04...
    Thank you all.

    EDIT : sorry I don't know how to emphasize the command text as other users do
    Last edited by mebss; November 5th, 2011 at 12:50 AM.

  2. #2
    Join Date
    Nov 2011

    Re: Enabling WiFi management

    70 views and no reply... thank you anyway.

  3. #3
    Join Date
    Aug 2011

    Re: Enabling WiFi management

    Sorry I cannot help, but this is a real problem. I have dual-boot Asus running Ubuntu 10.04. The problems seem common with the Atheros device. I installed and reinstalled so many versions of Linux and Atheros drivers, I finally had to give up, too much time wasted. It did work for as long time after removing 11.04 and installing 10.04, but the first time a 'system kernel update' occurred, right back where you are, with same symptoms. I will keep trying whenever I have time, and if I get any success, I'll post you a message. Good luck

  4. #4
    Join Date
    Apr 2005

    Re: Enabling WiFi management

    if one googles on your device

    you get hits such as this

    he suggests

    The machine has rtl8188ce chipset, and the Realtek drivers available from Realtek’s website don’t work well. You just need to blacklist acer_wmi module

    Edit /etc/modprobe.d/blacklist.conf and add

    blacklist acer_wmi

    Save and reboot. This won’t work if you’ve compiled Realtek drivers and installed them. It’ll work only in the default install. Here’s more detailed link -
    if you look at the debian info on this device

    it appears

    rtl8192ce (supported devices)

    Supports PCI-E devices based on the RTL8188CE and RTL8192CE chipsets.

    Introduced in Linux 2.6.38,7 enabled at linux-2.6 2.6.38-2.
    .......but that doesn't give you a specific action to take; it just seems to me the driver is built into the kernel

    the clearest is to do the blacklist specified in teh first post

    if the above doesn't work

    go here

    and supply as much of this information as you can; this forum runs on information; (others just run on love............)
    Last edited by pdc; November 7th, 2011 at 06:43 AM.

  5. #5
    Join Date
    Nov 2011

    Re: Enabling WiFi management

    Thanks to both of you
    It apears that when I shutdown Windows with WiFi turned on, it works under linux, but when I leave Windows with WiFi off, it doesn't. So it takes the last state on Windows.
    pdc, what you showed me is good to know, I'll mark the thread as solved.
    Once again thank you and sorry for the late feedback.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts