Results 1 to 6 of 6

Thread: LKL Keylgger rc.local autostart problem

  1. #1
    Join Date
    Nov 2010
    Beans
    9

    Exclamation LKL Keylgger rc.local autostart problem

    Hello. I try to setup LKL Keylogger on one of my eeepc laptop with Lubuntu on board. Problem is that i cannot setup autostart from /etc/rc.local

    I try to add:

    Code:
    lkl -l -k /my/lkl/keymaps/cat/us_km -o my/folder/with/log.txt
    exit 0
    after system reboot - nothing .. don't start, don't work - syslog clean. When i try to run rc.local from terminal, everything work's like a charm !!

    Please assist ..

  2. #2
    Join Date
    Oct 2009
    Location
    apt-get
    Beans
    4,278
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: LKL Keylgger rc.local autostart problem

    Hi there,

    Have a look at my signature (Lubuntu One Stop Thread) - Section C


  3. #3
    Join Date
    Nov 2010
    Beans
    9

    Exclamation Re: LKL Keylgger rc.local autostart problem

    Quote Originally Posted by amjjawad View Post
    Hi there,

    Have a look at my signature (Lubuntu One Stop Thread) - Section C

    Thanks. Still nothing.
    I make a file (lkl.desktop) and copy it to ~/.config/autostart/

    Code:
    [Desktop Entry]
    Name=URxvt
    Comment=Opens a terminal with UTF-8 and 256 colors support
    Encoding=UTF-8
    Exec=lkl -l -k /my/folder/with/keymaps/us_km -o /myfolder/with/file/log.txt
    Icon=gksu-root-terminal
    StartupNotify=true
    Terminal=false
    X-MultipleArgs=false
    Type=Application
    Categories=Application;System;
    NoDisplay=true
    Then i go to Session Manager and autostart URxvt
    Reboot
    Nothing ...

  4. #4
    Join Date
    Oct 2009
    Location
    apt-get
    Beans
    4,278
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: LKL Keylgger rc.local autostart problem

    What release of Lubuntu are you using?

  5. #5
    Join Date
    Nov 2010
    Beans
    9

    Re: LKL Keylgger rc.local autostart problem

    Quote Originally Posted by amjjawad View Post
    What release of Lubuntu are you using?
    Latest release.

  6. #6
    Join Date
    Oct 2009
    Location
    apt-get
    Beans
    4,278
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: LKL Keylgger rc.local autostart problem

    Quote Originally Posted by syngress View Post
    Thanks. Still nothing.
    I make a file (lkl.desktop) and copy it to ~/.config/autostart/

    Code:
    [Desktop Entry]
    Name=URxvt
    Comment=Opens a terminal with UTF-8 and 256 colors support
    Encoding=UTF-8
    Exec=lkl -l -k /my/folder/with/keymaps/us_km -o /myfolder/with/file/log.txt
    Icon=gksu-root-terminal
    StartupNotify=true
    Terminal=false
    X-MultipleArgs=false
    Type=Application
    Categories=Application;System;
    NoDisplay=true
    Then i go to Session Manager and autostart URxvt
    Reboot
    Nothing ...
    Does your application show up on the Menu?
    If yes, under what category?

    If not, edit your file:

    Code:
    [Desktop Entry]
    Name=URxvt
    Comment=Opens a terminal with UTF-8 and 256 colors support
    Encoding=UTF-8
    Exec=lkl -l -k /my/folder/with/keymaps/us_km -o /myfolder/with/file/log.txt
    Icon=gksu-root-terminal
    StartupNotify=true
    Terminal=false
    X-MultipleArgs=false
    Type=Application
    Categories=Application;System;
    #NoDisplay=true
    The lines in BLUE = I'm not sure about that specially Exec. It should be a command not a path as far as I know. Perhaps I'm wrong though.
    For Categories, try to use "Settings".

    The one in red, I'm sure about.

    After you make sure your application does show up on the Menu, try to open it and see if it works. Then, we can set it to autostart.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •