Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

  1. #11
    Join Date
    Nov 2009
    Beans
    6

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by haqking View Post
    it is gdm not gmd.

    However i presume you both did a

    Code:
    sudo update-grub
    after editing the grub ?

    and its the gdm.override there after a reboot ?
    Yeah I meant gdm. I did sudo update-grub and gdm.override is also still there after a reboot.

  2. #12
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,770

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    mmmm the answer is i dont know....LOL

    I am guessing it is LDM related as 11.10 now uses LDM.

    I will play in a Virtual machine in a little while and get back to ya unless someone else chimes in.

    cheers
    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

  3. #13
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by haqking View Post
    I am guessing it is LDM related as 11.10 now uses LDM.
    D'oh! Of course, 11.10 defaults to LightDM. So we have to disable LightDM, not GDM...

    Code:
    echo 'manual' | sudo tee /etc/init/lightdm.override

  4. #14
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Regarding the original post:

    Are you sure "text" is a valid kernel option? I've not seen that used in a Grub 'linux' line before, but I learn something new every day. If it can be used as a kernel option I'd appreciate seeing the link.

    I use the following as my kernel options page, but it could be outdated:
    http://www.kernel.org/doc/Documentat...parameters.txt
    Back to Xorg...

    Retired.

  5. #15
    Join Date
    Nov 2009
    Beans
    6

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by sisco311 View Post
    D'oh! Of course, 11.10 defaults to LightDM. So we have to disable LightDM, not GDM...

    Code:
    echo 'manual' | sudo tee /etc/init/lightdm.override
    Thank you for your response, but im still booting in GUI. The file lightdm.override is there. Is there anything else I can do?

    And text is a valid boot option. I used to boot into text mode with it on 11.04

  6. #16
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by devos50 View Post
    And text is a valid boot option. I used to boot into text mode with it on 11.04
    Thanks for that!

    I can't reboot my real system for the moment but the 'text' option did work in my VM's. For what it's worth, it worked in both Natty and Oneiric without any modifications of system files.
    Back to Xorg...

    Retired.

  7. #17
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by drs305 View Post
    Regarding the original post:

    Are you sure "text" is a valid kernel option? I've not seen that used in a Grub 'linux' line before, but I learn something new every day. If it can be used as a kernel option I'd appreciate seeing the link.

    I use the following as my kernel options page, but it could be outdated:
    http://www.kernel.org/doc/Documentat...parameters.txt
    Well, not a real kernel option, because it wasn't interpreted by the kernel.

    It was a dirty hack used by GDM's Upstart job to prevent GDM from running if the text parameter is present. Here is the relevant part of the code:
    Code:
    cat /etc/init/gdm.conf
    
    # gdm - GNOME Display Manager
    ...
        # Check kernel command-line for inhibitors
         for ARG in $(cat /proc/cmdline)
         do
             case "${ARG}" in
                 text|-s|s|S|single)
                     exit 0
                     ;;
             esac
         done
    ...

  8. #18
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    That makes perfect sense now. Thanks sisco311.
    Back to Xorg...

    Retired.

  9. #19
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,770

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by sisco311 View Post
    D'oh! Of course, 11.10 defaults to LightDM. So we have to disable LightDM, not GDM...

    Code:
    echo 'manual' | sudo tee /etc/init/lightdm.override
    ahh cool, i tried with a ldm.override and it wasnt working......i never thought to try lightdm.override

    LOL

    I was only playing in a VM for the purposes of helping out in this thread, but glad i got it sorted for future reference

    cheers
    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

  10. #20
    Join Date
    Sep 2009
    Beans
    7

    Re: GRUB_CMDLINE_LINUX_DEFAULT=“text” is not working

    Quote Originally Posted by sisco311 View Post
    D'oh! Of course, 11.10 defaults to LightDM. So we have to disable LightDM, not GDM...

    Code:
    echo 'manual' | sudo tee /etc/init/lightdm.override
    Thanks Sisco311, that works for me

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •