I recently upgraded my desktop to 11.10 from 11.04. Upgrade went smoothly until time to reboot. When booting it got stuck at “kernel_thread_helper+0x6/0x10” just after GRUB. From reading other threads I learned that this could be fixed by using the acpi=off boot option, and that other people were having the same problem. This allowed me to boot, but the side effects of using acpi=off are not acceptable, for two main reasons:

1. No Hyperthreading support (i.e. only one CPU core available)
2. The system does not actually turn off when using the shutdown command. (I often use a remote or delayed shutdown command, acpi=off prevents this)

I tried various other boot options, such as acpi=ht, pci=noapci, acpi=oldboot, acpi_osi=linux, but these all still cause the system to hang at kernel_thread_helper. I tried booting from USB stick with a fresh copy of Ubuntu, same problem. I tried toggling the PnP OS setting in by BIOS, no luck. My hardware is not brand new, but not that old either (Pentium 4 2.8GHz dual core, Nvidia GeForce FX 5700).

I can, however, boot into an older kernel (2.6.38-11-generic) and everything seems to work. So, a few questions:

1. Has anyone found any other boot options that fix the problem without being as severe as acpi=off?

2. Is there any hope of having this problem fixed in an update or later version, or am I doomed to be stuck forever with 11.04 (or 11.10 using older kernel) on this machine?

3. What are the consequences of booting into an earlier kernel version? So far, I have not found any issues with this, but I wonder if some software will complain or break or if there are unfixed security issues. Should I just set the older kernel as my default and forget about it?

Thanks for the help.