Page 5 of 5 FirstFirst ... 345
Results 41 to 48 of 48

Thread: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

  1. #41
    Join Date
    Jun 2005

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    Something has definitely gone wrong with Ubuntu and Macs. A 2011 MacBook Pro in my case. I have just spent a frustrating two days trying to boot from the CDs that I downloaded. I've followed all the instructions and I have partial success but it always fails with the message 'Unable to find medium containing live file system.' I've also tried making bootable flash drives as per instructions but my Mac won't even look at the results.

    I've successfully installed earlier versions of Ubuntu without any problems on Macs a few years ago but this latest version has me stumped. Judging from this thread it seems that I am not the only one having this problem. Maybe it's time that the wise men tried to fix it.

  2. #42
    Join Date
    Jun 2008

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    As wisemen, the first thing they need to do is acknowledge there is an issue with Mac OS X and the Ubuntu iso files

  3. #43
    Join Date
    Jan 2012

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    Quote Originally Posted by aaren_s View Post
    Hi, I faced the same problem with ubuntu-11.10-desktop-amd64.iso

    This is not a straightforward iso -the real directory structures are embedded within a "Partition inside this .iso file", but managed to create a mountable iso from it. Listed below are the steps:

    1. convert the downloaded ubuntu .iso to UDRW image to burn it into a thumb drive.

    $ hdiutil convert -format UDRW -o ubuntu-11.10-desktop-amd64.img ubuntu-11.10-desktop-amd64.iso
    You will get a ubuntu-11.10-desktop-amd64.img.dmg file. You can either rename it as a .dmg or as a .img, no problems ...

    2. Insert the thumb drive and do a diskutil list. you should get the disk number for your thumb drive. Let's suppose it to be diskN

    3. Dump the .img or .dmg file you got above into the thumb drive

    dd if=ubuntu-11.10-desktop-amd64.img of=/dev/rdiskN bs=1m.

    4. You should now see a strange unmountable partition diskNs1 (N=drive number for the thumb drive.) if not remove and re inser the thumb drive. This the actual .iso partition that contains the ubuntu installation/live CD stuff. To extract this, simply dump back the partition into a .iso file

    dd if=/dev/rdisk1s1 of=./MyUbuntu-11-x86_64.iso bs=1m

    Here rdisk1s1 is the partition inside the thumb drive I got after dumping the converted .img/.dmg in step 2.

    Now MyUbuntu-11-x86_64.iso is the actual .iso image you get that you *can* open/mount in your mac by just double clicking on it or opening using diskutil.

    You can now convert *this* MyUbuntu-11-x86_64.iso into a UDRW .img for a thumb drive or just burn it into a CD. Hope it works ...

    Cheers !!
    Thanks, this was very helpful. I found that you can reduce the steps a bit and save some time:

    1. Open the Disk Utility gui application. (Easy way to find it: Search using spotlight.)
    2. Drag the original .iso from Finder into the images section of Disk Utility (on the left side underneath the mounted drive list), and then double click on it there. A faded "diskNs1" should appear underneath it, and a dialog box will say the disk is not mountable. The "diskNs1" is the embedded .iso.
    3. Run "dd if=/disk/rdiskNs1 of=./ubuntu-extracted.iso bs=1m" to copy out the working .iso image.

    I found that the "hdiutil convert" step seemed to do nothing to either .iso. The output file was exactly identical to the input file (the file sizes and md5s match) except for the name.

  4. #44
    Join Date
    Feb 2012

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    Hey mypalmike, thanks for the suggestion this worked great for me.

    Although on my machine (OS X 10.7.2) the disk device is at:




    This is my first time trying out ubuntu on a Mac box. When I couldn't get the ISO to mount I didn't know what to think, since I've never had problems with ISOs with other distros before. I guess I just got unlucky picking this release to start with.

  5. #45
    Join Date
    Feb 2012

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    I created a bootable USB key just as instructed at I can't mount it on my iMac, but it WILL boot on a Windows machine. I haven't tried to boot with it on my Mac. I DID try to boot a VMWare VM from it, but couldn't get the volume to appear in VMWare. Always got the message from OS X that "the disk you inserted was not readable by this computer".

    The ISO file, as downloaded from, works fine in a VMWare VM, if I mount it as a CD-ROM.

    Fortunately, booting a Windows laptop is my intention, so no problem.

  6. #46
    Join Date
    Jun 2011
    Ubuntu 10.04 Lucid Lynx

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    I have the same problem. I have just format it. and it gone (in my ubuntu 11.10). try it.

  7. #47
    Join Date
    Sep 2012

    Smile Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    thanks mypalmike and pshapiro!

    the filenames were i little different for me too:
    dd if=/dev/disk1s1 of=./ubuntu-12.04.1-desktop-i386.iso bs=1m
    entered it in the os x Terminal
    took 90 seconds... then a file copied file popped up in my documents folder
    there was no loading/work indicator, so just wait for it to finish

    thanks again! +1

    So, anyone know why the .iso didn´t work?

    EDT: Restore Failure
    Could not validate source - Invalid argument

    Could not burn/restore it to a USB... probably this has happened to some of you others... will try again later

    EDT: reason .iso not working:

    ...Recently, Ubuntu started making Hybrid ISOs. It's an ISO that can be burned onto a CD as usual, but also can be copied to a USB key and used as a LiveUSB without the help of Startup Disk Creator. It's just in so currently only the daily images are built that way....

    EDIT: Guide on how to create a bootable USB in OS X
    it´s a bit tricky if the commands are all new to you

    EDIT: Most of you have probably figured this out, most of the activity is from July, but I add some links if anyone stumbles upon this...
    Last edited by bipedaljoe; September 21st, 2012 at 05:01 AM.

  8. #48
    Join Date
    Jan 2011

    Re: ubuntu-11.10-desktop-i386.iso has 'no mountable file systems'?

    Thank you mypalmike, #43 solved the problem in a ubuntu 12. (I was having the same issues in the newer versions).


Page 5 of 5 FirstFirst ... 345


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts