Results 1 to 3 of 3

Thread: disable gnome-keyring for ssh in 11.10

  1. #1
    Join Date
    Oct 2011
    Beans
    2

    disable gnome-keyring for ssh in 11.10

    Greetings,

    Does anyone know how to remove the "unlock private key" message for ssh in 11.10?

    In previous versions it could be removed from the "Startup Applications" menu and / or gnome configuration.

    I find it annoying to have this message popup when trying to ssh from a terminal. I don't mind that the gnome / graphical environment is hooked into ssh-agent, but I don't want ssh to be interfered by gnome with the keyring otherwise.

    Any help is appreciated. Also I'm using gnome-shell if it matters.

    neoubu

  2. #2
    Join Date
    Apr 2009
    Location
    Paris, France
    Beans
    1
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: disable gnome-keyring for ssh in 11.10

    Hi,

    starting programs are now under /etc/xdg/autostart/, I think you could disable startup scripts from here.

    On my side, I miss this feature that I was loving under 11.04 and disappeared when I installed 11.10... If somebody have an idea to enable it back...

    Greetings.

  3. #3
    Join Date
    Oct 2011
    Beans
    2

    Re: disable gnome-keyring for ssh in 11.10

    Thanks. That solved it. I renamed the gnome-keyring-ssh.desktop in that directory and now there's no interference from keyring.

    I agree, it would be nice if there was a way to do it from a GUI as there was before, but at least it was simple and clean from the CLI as well.

    nU

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •