Page 4 of 11 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 105

Thread: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

  1. #31
    Join Date
    Jun 2009
    Beans
    45

    Re: How to install Ubuntu 11.10 x64 on a Lenovo (U)EFI system (tested on S205, B570)

    Quote Originally Posted by Pay87 View Post
    Contents:
    Code:
    sudo mkdir /mnt/sda1
    sudo mount /dev/sda1 /mnt/sda1
    cd /mnt/sda1
    sudo mount --bind /sys ./sys
    sudo mount --bind /proc ./proc
    sudo mount --bind /dev ./dev
    sudo chroot .
    
    #We are now in our fresh installed Ubuntu
    
    sudo apt-get update
    sudo apt-get install grub
    sudo update-grub #say yes when generating menu.lst
    sudo grub-install /dev/sda
    sudo grub-install /dev/sda1
    Hello!

    I have a s205 and I would like to install the x64 version. I created the bootable usb key with pendrivelinux and later with unetbootin using winxp. The download, usb check and iso file are ok.

    Every time I have tried to install and after to boot from the disk, it ended in a infinite rebooting loop. Like there is no disk nor system to boot from. As I expect it could be grub2 and I decided to use this method.

    My wlan is ok. I am stuck on step 5. My partition table is:
    Code:
    /dev/sda1/boot
    /dev/sda5/linux-swap
    /dev/sda6/
    /dev/sda7/home
    Executing the command
    Code:
    sudo mount --bind /sys ./sys
    gives me the error
    Code:
    mount: mount point ./sys does not exist
    What should a beginner like me do next?

  2. #32
    Join Date
    Jan 2007
    Beans
    48

    Re: How to install Ubuntu 11.10 x64 on a Lenovo (U)EFI system (tested on S205, B570)

    You also have to mount /boot. I have a similar set up from yours and I had a similar issue.

  3. #33
    Join Date
    Dec 2011
    Beans
    9

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    After upgrading BIOS I managed to install and boot Kubuntu with fully automatic installation process in GPT on Lenovo Z570. I'm at work so I couldn't provide more accurate data for now. The installer split my 7650GB drive to the following partitions:

    Yes, it's GPT!
    1. 20mb fat16 (flagged as boot)
    2. ~700GB ext4 (this is root partition)
    3. 6GB (this is swap partition)

    As I noted before, the system is able to boot. But I don't like default partitioning because filesystems starts from sector 34, so 4k alignment isn't respected. Also, I want to separate /home . So I installed gparted, wiped out all partitions and made new ones:
    1. 20MB fat16 partition, marked as boot and started from sector 2048
    2. 50GB ext4 root partition
    3. 8GB linux-swap
    4. about 640GB left for /home , which is ext4 either

    In graphical installer I chose device /dev/sda to install GRUB. AFAIK installer downloaded grub-efi package via internet and installed it.

    After reboot there was 'ubuntu' in uefi boot menu (i'm not sure, maybe it left from previous correct installation of kubuntu). But system doesn't boot, it just get skipped to next boot device in list. I tried to manualy select ubuntu or ATA HDD, but it didn't help.

    The question is: what I did wrong? I have two opinions on it:
    1. probably, I should have left bootable partition as is, started from 34 sector and adjust alignmnent of the following it partitions?
    2. which device should i choose for grub installation? /dev/sda1 (which is bootable partition and marked as 'efi') or /dev/sda in GUI installer?


    --Edited:
    According to this post the EFI partition should have at least 100mb (maybe default installer made it 200mb instead of 20, as I mentioned before?) and GRUB should be installed into EFI partition. Is this accurate?
    Last edited by evil_hog; December 8th, 2011 at 10:23 AM.

  4. #34
    Join Date
    Dec 2011
    Beans
    9

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    I managed to succesfully install Kubuntu x86_64 on Lenovo z570 on the GPT partition table using EFI. Will post details later

  5. #35
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    Someone actually got UEFI to work.

    Post this just to see what you have:

    If UEFI include this also:
    dmesg | grep EFI
    find /boot/efi -name "*efi"

    There are several bugs which may relate to your install.
    UEFI bugs:
    Deletes Windows efi partition
    Installer should not format an existing EFI System Partition
    https://bugs.launchpad.net/ubuntu/+s...fi/+bug/769669
    EFI SYSTEM PARTITION should be atleast 100 MiB size and formatted as FAT32, not FAT16
    https://bugs.launchpad.net/ubuntu/+s...fi/+bug/811485
    ctrl-x does not work in grub-efi
    https://bugs.launchpad.net/ubuntu/+s...b2/+bug/722950
    grub-update fails to detect windows bootloader on a uefi system
    https://bugs.launchpad.net/ubuntu/+s...b2/+bug/807801
    MSI UEFI bug work around A75MA-G55 UEFI boot entries disappear
    http://forum-en.msi.com/index.php?topic=153411.0
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #36
    Join Date
    Dec 2011
    Beans
    9

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    Quote Originally Posted by oldfred View Post
    Someone actually got UEFI to work.

    Post this just to see what you have:

    If UEFI include this also:
    dmesg | grep EFI
    find /boot/efi -name "*efi"
    It was semi-automatic installation.

    Step 1: prepare hardware.
    • Z570 has buggy "BIOS" so you want to upgrade it at least to 1st November 2011 version (see the very 1st post for details)
    • Prepare media (11.10 for semi-automatic install). I was using standard DVD with Kubuntu x86-64 (had some problems with apt on USB stick, probably damaged ISO or the drive itself)
    • AFAIK the standard distributions doesn't include grub-efi, so you will need an internet connection, otherwise installed system wont boot.


    Step 2. Prepare installation.
    (If you are happy with default partitioning and don't want to align filesystems to 4k sectors just press Install and let it use the whole drive. Skip next steps)
    • Chose "Try Kubuntu" in installers prompt
    • When system loads, open terminal (konsole) and update packages tree
      Code:
      sudo apt-get update
    • Install gparted (ofcourse, if you don't mind calculating you could just use parted instead)
      Code:
      sudo apt-get install gparted
    • Run gparted and prepare partitions
      Code:
      sudo gparted
      I'm not planning to have dual boot, so in my case I created new GPT table and added following partitions on it:
      1. 200MB fat16, flagged as "boot" (even if you create fat32, installer is going to format it back to fat16)
      2. ext4 root partition
      3. swap partition
      4. ext4 for /home

      Now we have properly aligned partitions due to gparted.
    • Quit parted and launch installer from your desktop
    • Choose "Manual" in drive partitioning window and let the installer know which partitions you'd like to use. In my case:
      1. /dev/sda1: efi partition (IMPORTANT)
      2. /dev/sda2: root
      3. /dev/sda3: swap
      4. /dev/sda4: /home


      Below this windows you'll see an option to choose target for GRUB. The default value should be the drive itself (like /dev/sda, not /dev/sda1 or something like this)
    • I advice you to select "Auto login" option in user configuration window. Most likely you will see black screen after installation. Actually its not black, its very dark (like at minimal brightness). Its still possible to see login window at some angles, but I prefer auto login untill we find the solution. Its impossible to change brightness at login screen with functinal keys, but after login the brightness returns to normal level and functional keys works.
    • Follow the instructions to finish installation and reboot your PC. You should see 'ubuntu' in boot order menu in bios or by hitting F12. The installer puts ubuntu at the top of this list, so after reboot you will get to newly installed system.


    Manual grub installation.
    I think it should be done in following steps:
    1. Boot from livecd/usbstick
    2. Install grub-efi package
    3. Mount the neccesary partitions (like root, boot and efi)
    4. Issue grub-install with aproriate flags
    5. Run grub-update or efibootmgr to add ubuntu to EFI menu list.

    I'll post dmesg and parted output bit later, have to go for now

    PS: sorry for misspells! This touchpad is killing me. Sometimes it triggers when I hover a finger over touchpad without actually touching it.


    Code:
    $ dmesg |grep EFI
    [    0.000000] EFI v2.00 by Phoenix Technologies Ltd.
    [    0.000000] Kernel-defined memdesc doesn't match the one from EFI!
    [    0.000000] EFI: mem00: type=3, attr=0xf, range=[0x0000000000000000-0x0000000000001000) (0MB)
    [    0.000000] EFI: mem01: type=7, attr=0xf, range=[0x0000000000001000-0x0000000000054000) (0MB)
    [    0.000000] EFI: mem02: type=4, attr=0xf, range=[0x0000000000054000-0x0000000000055000) (0MB)
    [    0.000000] EFI: mem03: type=3, attr=0xf, range=[0x0000000000055000-0x000000000008f000) (0MB)
    [    0.000000] EFI: mem04: type=10, attr=0xf, range=[0x000000000008f000-0x0000000000090000) (0MB)
    [    0.000000] EFI: mem05: type=3, attr=0xf, range=[0x0000000000090000-0x00000000000a0000) (0MB)
    [    0.000000] EFI: mem06: type=2, attr=0xf, range=[0x0000000000100000-0x000000000056d000) (4MB)
    [    0.000000] EFI: mem07: type=7, attr=0xf, range=[0x000000000056d000-0x0000000000c00000) (6MB)
    [    0.000000] EFI: mem08: type=3, attr=0xf, range=[0x0000000000c00000-0x0000000001000000) (4MB)
    [    0.000000] EFI: mem09: type=7, attr=0xf, range=[0x0000000001000000-0x00000000359f6000) (841MB)
    [    0.000000] EFI: mem10: type=2, attr=0xf, range=[0x00000000359f6000-0x0000000036cf3000) (18MB)
    [    0.000000] EFI: mem11: type=7, attr=0xf, range=[0x0000000036cf3000-0x000000008632e000) (1270MB)
    [    0.000000] EFI: mem12: type=2, attr=0xf, range=[0x000000008632e000-0x00000000b3e58000) (731MB)
    [    0.000000] EFI: mem13: type=4, attr=0xf, range=[0x00000000b3e58000-0x00000000b3e78000) (0MB)
    [    0.000000] EFI: mem14: type=7, attr=0xf, range=[0x00000000b3e78000-0x00000000b6305000) (36MB)
    [    0.000000] EFI: mem15: type=4, attr=0xf, range=[0x00000000b6305000-0x00000000b6e48000) (11MB)
    [    0.000000] EFI: mem16: type=7, attr=0xf, range=[0x00000000b6e48000-0x00000000b6f27000) (0MB)
    [    0.000000] EFI: mem17: type=1, attr=0xf, range=[0x00000000b6f27000-0x00000000b6f47000) (0MB)
    [    0.000000] EFI: mem18: type=7, attr=0xf, range=[0x00000000b6f47000-0x00000000b784c000) (9MB)
    [    0.000000] EFI: mem19: type=4, attr=0xf, range=[0x00000000b784c000-0x00000000b8685000) (14MB)
    [    0.000000] EFI: mem20: type=7, attr=0xf, range=[0x00000000b8685000-0x00000000b8688000) (0MB)
    [    0.000000] EFI: mem21: type=4, attr=0xf, range=[0x00000000b8688000-0x00000000b9255000) (11MB)
    [    0.000000] EFI: mem22: type=7, attr=0xf, range=[0x00000000b9255000-0x00000000b92d7000) (0MB)
    [    0.000000] EFI: mem23: type=4, attr=0xf, range=[0x00000000b92d7000-0x00000000b92db000) (0MB)
    [    0.000000] EFI: mem24: type=7, attr=0xf, range=[0x00000000b92db000-0x00000000b92dc000) (0MB)
    [    0.000000] EFI: mem25: type=4, attr=0xf, range=[0x00000000b92dc000-0x00000000b92dd000) (0MB)
    [    0.000000] EFI: mem26: type=7, attr=0xf, range=[0x00000000b92dd000-0x00000000b92de000) (0MB)
    [    0.000000] EFI: mem27: type=4, attr=0xf, range=[0x00000000b92de000-0x00000000b92df000) (0MB)
    [    0.000000] EFI: mem28: type=7, attr=0xf, range=[0x00000000b92df000-0x00000000b92e0000) (0MB)
    [    0.000000] EFI: mem29: type=4, attr=0xf, range=[0x00000000b92e0000-0x00000000b956f000) (2MB)
    [    0.000000] EFI: mem30: type=7, attr=0xf, range=[0x00000000b956f000-0x00000000b9570000) (0MB)
    [    0.000000] EFI: mem31: type=4, attr=0xf, range=[0x00000000b9570000-0x00000000b958a000) (0MB)
    [    0.000000] EFI: mem32: type=7, attr=0xf, range=[0x00000000b958a000-0x00000000b9598000) (0MB)
    [    0.000000] EFI: mem33: type=4, attr=0xf, range=[0x00000000b9598000-0x00000000ba5a7000) (16MB)
    [    0.000000] EFI: mem34: type=7, attr=0xf, range=[0x00000000ba5a7000-0x00000000ba9f2000) (4MB)
    [    0.000000] EFI: mem35: type=2, attr=0xf, range=[0x00000000ba9f2000-0x00000000ba9f8000) (0MB)
    [    0.000000] EFI: mem36: type=3, attr=0xf, range=[0x00000000ba9f8000-0x00000000bac87000) (2MB)
    [    0.000000] EFI: mem37: type=5, attr=0x800000000000000f, range=[0x00000000bac87000-0x00000000bace7000) (0MB)
    [    0.000000] EFI: mem38: type=5, attr=0x800000000000000f, range=[0x00000000bace7000-0x00000000bad87000) (0MB)
    [    0.000000] EFI: mem39: type=6, attr=0x800000000000000f, range=[0x00000000bad87000-0x00000000badc0000) (0MB)
    [    0.000000] EFI: mem40: type=10, attr=0xf, range=[0x00000000badc0000-0x00000000badc9000) (0MB)
    [    0.000000] EFI: mem41: type=6, attr=0x800000000000000f, range=[0x00000000badc9000-0x00000000bae87000) (0MB)
    [    0.000000] EFI: mem42: type=0, attr=0xf, range=[0x00000000bae87000-0x00000000baeff000) (0MB)
    [    0.000000] EFI: mem43: type=10, attr=0xf, range=[0x00000000baeff000-0x00000000baf9f000) (0MB)
    [    0.000000] EFI: mem44: type=9, attr=0xf, range=[0x00000000baf9f000-0x00000000bafe5000) (0MB)
    [    0.000000] EFI: mem45: type=9, attr=0xf, range=[0x00000000bafe5000-0x00000000bafff000) (0MB)
    [    0.000000] EFI: mem46: type=4, attr=0xf, range=[0x00000000bafff000-0x00000000bb000000) (0MB)
    [    0.000000] EFI: mem47: type=7, attr=0xf, range=[0x0000000100000000-0x00000001bfe00000) (3070MB)
    [    0.000000] EFI: mem48: type=11, attr=0x8000000000000001, range=[0x00000000f80f8000-0x00000000f80f9000) (0MB)
    [    0.000000] EFI: mem49: type=11, attr=0x8000000000000001, range=[0x00000000fed1c000-0x00000000fed20000) (0MB)
    [    0.000000] ACPI: UEFI 00000000bafe7000 0003E (v01 LENOVO CB-01    00000001 PTL  00000001)
    [    0.000000] ACPI: UEFI 00000000bafe6000 00042 (v01 PTL      COMBUF 00000001 PTL  00000001)
    [    0.000000] ACPI: UEFI 00000000bafe5000 00256 (v01 LENOVO CB-01    00000001 PTL  00000001)
    [    0.515353] fb0: EFI VGA frame buffer device
    [    0.741544] EFI Variables Facility v0.08 2004-May-17
    [    1.873307] fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver
    Code:
    $ find /boot/efi -iname "*efi*"
    /boot/efi
    /boot/efi/EFI
    /boot/efi/EFI/ubuntu/grubx64.efi
    Code:
    $ sudo efibootmgr 
    [sudo] password for user: 
    BootCurrent: 0008
    Timeout: 1 seconds
    BootOrder: 0008,0003,0004,0005,0006,0002,0007
    Boot0000  Setup
    Boot0001  Boot Menu
    Boot0002* USB FDD:
    Boot0003* ATA HDD: WDC WD7500BPVT-24HXZT1                  
    Boot0004* ATAPI CD: MATSHITADVD-RAM UJ8B1AS                 
    Boot0005* USB HDD:
    Boot0006* USB CD:
    Boot0007* PCI LAN: Realtek PXE B04 D00
    Boot0008* ubuntu
    Last edited by evil_hog; December 10th, 2011 at 09:09 AM. Reason: added dmesg output

  7. #37
    Join Date
    Dec 2009
    Beans
    12

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    You rule dude. i haven't been sleeping because of this.
    Hat's off to you. Thanks a million!

    It seems that, in my case (11.10 x64) grub-efi is already installed. The only weird thing is that I can't access the bios settings or boot manager and ubuntu starts loading almost instantly (I only see the lenovo screen for 2-3 seconds).

    I've fixed the wifi too, by blacklisting the acer module and installed ironhide for optimus functionality (I can't really tell if it's working or not, since I haven't used this for too many things, yet).

    All and all it looks cool, but incomplete (since i can't access bios settings & stuff).
    Last edited by hornedfiend; December 20th, 2011 at 01:14 PM.

  8. #38
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    To any with a working or almost working grub efi system.

    We are testing a newer version of bootinfoscript that should also parse the efi partitions and show the grub files.

    From terminal command line download & run script then copy & paste results.txt to here, please put in code tags (# in edit panel) to make it easier to read:

    Code:
    wget -O bootinfoscript 'http://bootinfoscript.git.sourceforge.net/git/gitweb.cgi?p=bootinfoscript/bootinfoscript;a=blob_plain;f=bootinfoscript;hb=HEAD'
    
    chmod a+x bootinfoscript
    
    sudo bash bootinfoscript
    
     gksu gedit results.txt
    If it is your first run of bootinfoscript, it will be results.txt or else it adds a digit for each additional run. result1.txt etc.

    When I down loaded the script it did not appear in Nautilus immediately? but terminal shows files ok.

    Thank you.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #39
    Join Date
    Dec 2009
    Beans
    12

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    @oldfred: I will run this today and post the results.txt here.

    1. Does anyone know how to solve the monitor turn off feature? Whenever the power management module turns off my monitor, I end up with a laptop unable to resume its previous state.
    The only workaround for this is to close the lid, so that the system goes into sleep mode and just re-open the lid again for it to resume correctly.

    2. Ironhide is a nasty workaround but at least it works. Still needs a lot of work and it seems that the performance isn't that great. I'm just curious: how can I force certain applications to use the nvidia card and how do I check which card is in usage (when needed)?

  10. #40
    Join Date
    Dec 2011
    Beans
    1

    Re: How to install Ubuntu 11.10 on a Lenovo (U)EFI system (tested on S205, B570)

    Wow, well I followed these instructions on the b570--which, by the way, I picked up for a screamin' $240 with a display coupon at best buy!

    But, I had the following problems:

    1) grub legacy loaded ubuntu fine, but didn't load windows 7
    2) chroot couldn't find an internet connection

    Luckily, it turns out grub2 works fine, so long as you convince is to form a master boot record.

    First, you connect to the net just as OP suggests, but add

    Code:
    cp /etc/resolv.conf /mnt/sda#/etc/resolv.conf
    so that chroot jail has a line out. Then after

    Code:
    sudo chroot .
    you should be root and you purge the old stuff with (no 'sudo' needed!)

    Code:
    apt-get purge grub grub-pc grub-common
    and then reset the list with

    Code:
    apt-get install grub-common grub-pc
    update-grub
    You have to pick the boot partition with space, bizarrely...

    Eureka! Win 7, Ubuntu, and the repair partition all pop up--and I suspect that grub2 will do a better job of resisting being written over by win7 updates. Remains to be seen...

Page 4 of 11 FirstFirst ... 23456 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •