Results 1 to 2 of 2

Thread: Only FTP or Nginx work (permissions)

  1. #1
    Join Date
    Feb 2014

    Only FTP or Nginx work (permissions)

    Hello guys,

    I've for too long used to work with windows web server and now im migrating to linux.

    I've created a new server running Ubuntu 12.10 x64.

    Installed Nginx, tested, it is ok.

    Installed vsFTPd, tested, it is ok.

    But only when each one have permissions set to it.

    I have a user manga. its home directory is /var/www/manga

    I've created a public_html folder, which is the root of the ServerBlock.

    When i apply chown of that folder to manga, the VSFTPD upload work, but the NGINX gives me 403 error.

    When i apply chown of that folder to www-data, the NGINX work, but VSFTPD denies me uploads.

    I've tried to set the chmod to 755 of /var/www
    I've tried to make manga user of the group www-data (using $sudo usermod -aG www-data manga)

    Even thought, i cant make all work normally.

    Please someone take this headache of my head haha

    Thank you

    sorry my english.

  2. #2
    Join Date
    Mar 2006
    Williams Lake
    Ubuntu Development Release

    Re: Only FTP or Nginx work (permissions)

    This is more a question about servers, than a security question. Moved.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts