Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Wireless does not work after 11.10 install on Dell Latitide D630

  1. #11
    Join Date
    May 2010
    Beans
    3

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    It did not work for me
    Here the results of the three commands:
    titia@Dell-D630:~$ cat /etc/lsb-release; uname -a
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=oneiric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"
    Linux Dell-D630 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
    titia@Dell-D630:~$ lspci -nnk | grep -iA2 net
    09:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5755M Gigabit Ethernet PCI Express [14e4:1673] (rev 02)
    Subsystem: Dell Device [1028:01f9]
    Kernel driver in use: tg3
    --
    0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
    Subsystem: Intel Corporation Device [8086:1021]
    Kernel driver in use: iwl3945
    titia@Dell-D630:~$ lsmod
    Module Size Used by
    rndis_wlan 28472 0
    rndis_host 13560 1 rndis_wlan
    cdc_ether 13312 1 rndis_host
    usbnet 25214 3 rndis_wlan,rndis_host,cdc_ether
    usb_storage 44173 0
    cdc_acm 22305 0
    uas 17699 0
    parport_pc 32114 0
    ppdev 12849 0
    snd_hda_codec_idt 60049 1
    bnep 17923 2
    rfcomm 38408 0
    bluetooth 148839 10 bnep,rfcomm
    dell_wmi 12601 0
    sparse_keymap 13658 1 dell_wmi
    joydev 17393 0
    snd_hda_intel 24262 2
    snd_hda_codec 91754 2 snd_hda_codec_idt,snd_hda_intel
    snd_hwdep 13276 1 snd_hda_codec
    snd_pcm 80468 2 snd_hda_intel,snd_hda_codec
    pcmcia 39822 0
    dell_laptop 13519 0
    dcdbas 14098 1 dell_laptop
    binfmt_misc 17292 1
    snd_seq_midi 13132 0
    snd_rawmidi 25241 1 snd_seq_midi
    psmouse 73673 0
    snd_seq_midi_event 14475 1 snd_seq_midi
    serio_raw 12990 0
    snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
    arc4 12473 2
    yenta_socket 27428 0
    pcmcia_rsrc 18367 1 yenta_socket
    pcmcia_core 21511 3 pcmcia,yenta_socket,pcmcia_rsrc
    iwl3945 73329 0
    iwl_legacy 71499 1 iwl3945
    mac80211 272785 2 iwl3945,iwl_legacy
    snd_timer 28932 2 snd_pcm,snd_seq
    snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
    i915 505108 3
    snd 55902 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
    drm_kms_helper 32889 1 i915
    cfg80211 172392 4 rndis_wlan,iwl3945,iwl_legacy,mac80211
    wmi 18744 1 dell_wmi
    drm 192226 4 i915,drm_kms_helper
    soundcore 12600 1 snd
    snd_page_alloc 14115 2 snd_hda_intel,snd_pcm
    i2c_algo_bit 13199 1 i915
    video 18908 1 i915
    lp 17455 0
    parport 40930 3 parport_pc,ppdev,lp
    firewire_ohci 35854 0
    firewire_core 56937 1 firewire_ohci
    crc_itu_t 12627 1 firewire_core
    usbhid 41905 0
    hid 77367 1 usbhid
    tg3 132972 0

    Can you help me?? Thnx

  2. #12
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,929
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Hi, it did not work because you do not have the right wireless card for that driver.

    It also looks like you installed ndiswrapper if so we need to remove that.

    Please run this command one line at a time:
    Code:
    sudo modprobe -rf ndiswrapper
    sudo apt-get remove --purge ndiswrapper-common ndiswrapper-utils-1.9 ndisgtk
    sudo rm /etc/modprobe.d/ndiswrapper.conf
    sudo rm -r /etc/ndiswrapper/* 
    sudo depmod -a
    After you run the commands above then post the results of:
    Code:
    nm-tool
    Code:
    iwconfig
    Code:
    rfkill list all
    Code:
    sudo iwlist scan
    Code:
    lsmod | grep iwl
    Then unplug wired connection and run the following command.
    Code:
    sudo cat /var/log/syslog | grep -e iwl -e firmware -e wlan -e etwork | tail -n45
    Thank you

  3. #13
    Join Date
    May 2010
    Beans
    3

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Thank you for helping me!

    titia@Dell-D630:~$ nm-tool

    NetworkManager Tool

    State: connected (global)

    - Device: wlan0 ----------------------------------------------------------------
    Type: 802.11 WiFi
    Driver: iwl3945
    State: unavailable
    Default: no
    HW Address: 00:1F:3C:4E:5D:E6

    Capabilities:

    Wireless Properties
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

    Wireless Access Points


    - Device: eth0 -----------------------------------------------------------------
    Type: Wired
    Driver: tg3
    State: unavailable
    Default: no
    HW Address: 00:1C:23:45:19:FD

    Capabilities:
    Carrier Detect: yes

    Wired Properties
    Carrier: off


    - Device: usb0 [Wired connection 2] -------------------------------------------
    Type: Wired
    Driver: rndis_host
    State: connected
    Default: yes
    HW Address: CE:3C:D8:4D:EA:1F

    Capabilities:
    Carrier Detect: yes

    Wired Properties
    Carrier: on

    IPv4 Settings:
    Address: 192.168.42.88
    Prefix: 24 (255.255.255.0)
    Gateway: 192.168.42.129

    DNS: 192.168.42.129


    titia@Dell-D630:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11abg ESSID:off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=off
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:on

    usb0 no wireless extensions.

    titia@Dell-D630:~$ rfkill list all
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    1: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    2: dell-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
    titia@Dell-D630:~$ sudo iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    wlan0 Interface doesn't support scanning : Network is down

    usb0 Interface doesn't support scanning.

    titia@Dell-D630:~$ lsmod | grep iwl
    iwl3945 73329 0
    iwl_legacy 71499 1 iwl3945
    mac80211 272785 2 iwl3945,iwl_legacy
    cfg80211 172392 4 rndis_wlan,iwl3945,iwl_legacy,mac80211
    titia@Dell-D630:~$ sudo cat /var/log/syslog | grep -e iwl -e firmware -e wlan -e etwork | tail -n45
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: SCPlugin-Ifupdown: devices added (path: /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-4/2-4:1.0/net/usb0, iface: usb0)
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: SCPlugin-Ifupdown: device added (path: /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-4/2-4:1.0/net/usb0, iface: usb0): no ifupdown configuration found.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): carrier is OFF
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): new Ethernet device (driver: 'rndis_host' ifindex: 4)
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): exported as /org/freedesktop/NetworkManager/Devices/3
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): now managed
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): bringing up device.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): preparing device.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): deactivating device (reason 'managed') [2]
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Added default wired connection 'Wired connection 2' for /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-4/2-4:1.0/net/usb0
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): carrier now ON (device state 20)
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Auto-activating connection 'Wired connection 2'.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) starting connection 'Wired connection 2'
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 1 of 5 (Device Prepare) scheduled...
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 1 of 5 (Device Prepare) started...
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 2 of 5 (Device Configure) scheduled...
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 1 of 5 (Device Prepare) complete.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 2 of 5 (Device Configure) starting...
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): device state change: prepare -> config (reason 'none') [40 50 0]
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 2 of 5 (Device Configure) successful.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 3 of 5 (IP Configure Start) scheduled.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 2 of 5 (Device Configure) complete.
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 3 of 5 (IP Configure Start) started...
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> (usb0): device state change: config -> ip-config (reason 'none') [50 70 0]
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Beginning DHCPv4 transaction (timeout in 45 seconds)
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> dhclient started with pid 1586
    Nov 1 00:02:21 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 3 of 5 (IP Configure Start) complete.
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> (usb0): DHCPv4 state changed nbi -> preinit
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> (usb0): DHCPv4 state changed preinit -> bound
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 4 of 5 (IP4 Configure Get) scheduled...
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 4 of 5 (IP4 Configure Get) started...
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> address 192.168.42.88
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> prefix 24 (255.255.255.0)
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> gateway 192.168.42.129
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> hostname 'Dell-D630'
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> nameserver '192.168.42.129'
    Nov 1 00:02:22 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 5 of 5 (IP Configure Commit) started...
    Nov 1 00:02:23 Dell-D630 NetworkManager[862]: <info> (usb0): device state change: ip-config -> activated (reason 'none') [70 100 0]
    Nov 1 00:02:23 Dell-D630 NetworkManager[862]: <info> Policy set 'Wired connection 2' (usb0) as default for IPv4 routing and DNS.
    Nov 1 00:02:23 Dell-D630 NetworkManager[862]: <info> Activation (usb0) successful, device activated.
    Nov 1 00:02:23 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 5 of 5 (IP Configure Commit) complete.
    Nov 1 00:02:23 Dell-D630 NetworkManager[862]: <info> Activation (usb0) Stage 4 of 5 (IP4 Configure Get) complete.
    Last edited by thijsE; November 1st, 2011 at 12:09 AM.

  4. #14
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,929
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Hi, I think you have several issues going on.

    First your wireless is soft and hard blocked, please run this command:
    Code:
    sudo rmmod -f dell-laptop
    Then you should have a switch that turns the wireless on and off find it then turn it on, and run these commands again so I can tell where to go from here.
    Code:
    rfkill list all
    Code:
    sudo cat /var/log/syslog | grep -e iwl -e firmware -e wlan -e etwork | tail -n45
    Thank you

  5. #15
    Join Date
    May 2010
    Beans
    3

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    How stupid!!
    It now works. The laptop has a wireless switch. I thought it was a switch to unlock the laptop's battery. Thank you very much for helping me out

  6. #16
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,929
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Your welcome! glad to help.
    Enjoy

  7. #17
    Join Date
    Jun 2006
    Beans
    1

    Talking Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Your a God send man. Found this post in Google. After 2 hours of playing around, your solution worked!

  8. #18
    Join Date
    Jun 2012
    Beans
    2

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    hey could you guys please tell me where i have to put the code in. I will appreciate your help

    THANK YOU!

  9. #19
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,929
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Hi, welcome to the forum! Please open a terminal ctrl+alt+t copy and paste the following commands into it one line at a time, then paste the results here:

    Code:
    cat /etc/lsb-release; uname -a
    lspci -nnk | grep -iA2 net
    lsusb
    iwconfig
    rfkill list all
    lsmod
    by clicking on new reply and click # then paste the information between the brackets.
    Thank you

  10. #20
    Join Date
    Aug 2012
    Beans
    1

    Re: Wireless does not work after 11.10 install on Dell Latitide D630

    Wildemanne39 - i've got a Dell Inspiron 1525 and wireless didn't work until I found your post. You made my day. Thank you!

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •