Page 1 of 8 123 ... LastLast
Results 1 to 10 of 79

Thread: 11.10 wired network problem

  1. #1
    Join Date
    Oct 2011
    Beans
    3

    11.10 wired network problem

    Hi, Im new to the forum.

    Been using Ubuntu on various PC's laptops for few years. Im user rather than a developer and am capable of general maintenance.

    The Problem:
    Installed Ubuntu 11.10 64bit on my new Asus ET2410INTS in a dual boot with Win7 64 bit.

    Install was a problem as the option to install alongside was not provided -after some partition work the install was ok.

    The problem seems to be that 11.10 is unable to access my full broadband speed and the network connection is not working or being throttled by the 11.10 instal. Im using wired ethernet connection through netgear powerline adaptors and not using the wifi at all.

    Used speedtest.net to check - Win 7 boot gives 14-16Mbits/s down and 1.5 up - 11.10 boot gives 2.3Mbit/s down and 0.02 up. Have tried a complete reinstall and the same occurs.

    Connection is fine for my Laptop running Xubuntu 11.10 via wifi.

    Running software updates is hard due to connection often timing out.

    Any suggestions or pointers getting the network connection working are much appreciated

    Have seen people request the findings of sudo lshw -c network so here they are:
    ---------------------------------------------------------------

    *-network
    description: Wireless interface
    product: AR9285 Wireless Network Adapter (PCI-Express)
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:04:00.0
    logical name: wlan0
    version: 01
    serial: 74:2f:68:1d:51:07
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
    resources: irq:18 memory:fb200000-fb20ffff
    *-network
    description: Ethernet interface
    product: RTL8111/8168B PCI Express Gigabit Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:06:00.0
    logical name: eth0
    version: 06
    serial: 1c:75:08:6c:86:6f
    size: 100Mbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.1.65 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
    resources: irq:52 ioport:d000(size=256) memory:d2104000-d2104fff memory:d2100000-d2103fff
    peter@peter-ET2410:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 1c:75:08:6c:86:6f
    inet addr:192.168.1.65 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::1e75:8ff:fe6c:866f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:57911 errors:0 dropped:57911 overruns:0 frame:57911
    TX packets:38736 errors:0 dropped:128 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:80115279 (80.1 MB) TX bytes:4076872 (4.0 MB)
    Interrupt:52 Base address:0xe000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:130 errors:0 dropped:0 overruns:0 frame:0
    TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:14915 (14.9 KB) TX bytes:14915 (14.9 KB)

    wlan0 Link encap:Ethernet HWaddr 74:2f:68:1d:51:07
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    peter@peter-ET2410:~$ ^C

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,901
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 11.10 wired network problem

    Hi, please show the results of:
    Code:
    lspci -nnk | grep -iA2 net
    I suspect running these commands one at a time will fix your problem but I want to make sure of the ethernet adapter first.
    Code:
    sudo apt-get install --reinstall linux-headers-generic build-essential dkms
    wget http://r8168.googlecode.com/files/r8168-8.025.00.tar.bz2
    tar xvf r8168-8.025.00.tar.bz2
    cd r8168-8.025.00
    sudo modprobe -rf r8169
    sudo ./autorun.sh
    echo 'blacklist r8169' | sudo tee -a /etc/modprobe.d/blacklist.conf
    sudo modprobe -v r8168
    sudo depmod -a
    sudo update-initramfs -u
    Thank you

  3. #3
    Join Date
    Mar 2011
    Beans
    14

    Re: 11.10 wired network problem

    Hi,

    I have a similar problem. My computer is also ASUS, F50-sf ( having ubuntu 11.10 64 bit & windows 7 64 bit)
    wired connection works fine on windows 7 but, there is a weird problem on ubuntu. It only connects some certain websites like google. I cannot use any update tool of ubuntu due to connection problem. I think I use the below driver. thank you in advance.


    Ethernet controller [0200]: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter [1039:0191] (rev 02)
    Subsystem: ASUSTeK Computer Inc. Device [1043:1815]
    Kernel driver in use: sis190



    P.S. :If you need any specific inf. about the computer, ask me pls.

  4. #4
    Join Date
    Mar 2011
    Beans
    14

    Re: 11.10 wired network problem

    update: http://ubuntuforums.org/showthread.php?t=1726477

    I think my problem is related with this unsolved problem..

  5. #5
    Join Date
    Nov 2011
    Beans
    5

    Re: 11.10 wired network problem

    Hi, I'm brand new to the forums, but I've been using Ubuntu since 2007. I'm having the exact same problem with my Windows 7/Ubuntu 11.10 dual-boot: Windows can connect to the internet just fine, but Linux is throttling download speeds, erroring out on page loads, and timing out when I try to download new packages through the software center.

    I tried the solution wildmanne39 suggested above, and now it isn't connecting to the network at all. I've copied the terminal output below. I'd appreciate any help getting my network connect back (or even better, working right)-- I'm still a bit shaky on using the command line for this kind of thing, and I'm pretty much stuck with windows (yuck) until I get this fixed.

    annalee@Reynardine:~$ sudo apt-get install --reinstall linux-headers-generic build-essential dkms
    [sudo] password for annalee:
    annalee@Reynardine:~$ sudo apt-get install --reinstall linux-headers-generic build-essential dkms
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libqt4-declarative:i386 liblcms1:i386 libqt4-qt3support:i386 libcupsimage2:i386
    libqt4-test:i386 libqt4-script:i386 libqt4-designer:i386 libqt4-network:i386
    libqt4-dbus:i386 libxxf86vm1:i386 libglapi-mesa:i386 libqt4-xmlpatterns:i386 libgdbm3:i386
    libqt4-svg:i386 libqt4-xml:i386 libxss1:i386 libqtgui4:i386 libqt4-scripttools:i386
    libaudio2:i386 libmng1:i386 libllvm2.9:i386
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    dpkg-dev g++ g++-4.6 libalgorithm-diff-perl libalgorithm-diff-xs-perl
    libalgorithm-merge-perl libdpkg-perl libstdc++6-4.6-dev
    Suggested packages:
    debian-keyring g++-multilib g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg
    libstdc++6-4.6-doc
    The following NEW packages will be installed:
    build-essential dpkg-dev g++ g++-4.6 libalgorithm-diff-perl libalgorithm-diff-xs-perl
    libalgorithm-merge-perl libdpkg-perl libstdc++6-4.6-dev
    0 upgraded, 9 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
    Need to get 9,418 kB of archives.
    After this operation, 30.1 MB of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Get:1 http://us.archive.ubuntu.com/ubuntu/ oneiric/main libstdc++6-4.6-dev amd64 4.6.1-9ubuntu3 [1,644 kB]
    Get:2 http://us.archive.ubuntu.com/ubuntu/ oneiric/main g++-4.6 amd64 4.6.1-9ubuntu3 [6,970 kB]
    Get:3 http://us.archive.ubuntu.com/ubuntu/ oneiric/main g++ amd64 4:4.6.1-2ubuntu5 [1,444 B]
    Get:4 http://us.archive.ubuntu.com/ubuntu/ oneiric/main libdpkg-perl all 1.16.0.3ubuntu5 [171 kB]
    Get:5 http://us.archive.ubuntu.com/ubuntu/ oneiric/main dpkg-dev all 1.16.0.3ubuntu5 [473 kB]
    Get:6 http://us.archive.ubuntu.com/ubuntu/ oneiric/main build-essential amd64 11.5ubuntu1 [5,928 B]
    Get:7 http://us.archive.ubuntu.com/ubuntu/ oneiric/main dkms all 2.2.0.2-1ubuntu4 [72.3 kB]
    Get:8 http://us.archive.ubuntu.com/ubuntu/ oneiric/main libalgorithm-diff-perl all 1.19.02-2 [50.7 kB]
    Get:9 http://us.archive.ubuntu.com/ubuntu/ oneiric/main libalgorithm-diff-xs-perl amd64 0.04-1build1 [13.4 kB]
    Get:10 http://us.archive.ubuntu.com/ubuntu/ oneiric/main libalgorithm-merge-perl all 0.08-2 [12.7 kB]
    Get:11 http://us.archive.ubuntu.com/ubuntu/ oneiric/main linux-headers-generic amd64 3.0.0.12.14 [2,354 B]
    Fetched 9,418 kB in 2min 16s (68.9 kB/s)
    Selecting previously deselected package libstdc++6-4.6-dev.
    (Reading database ... 102879 files and directories currently installed.)
    Unpacking libstdc++6-4.6-dev (from .../libstdc++6-4.6-dev_4.6.1-9ubuntu3_amd64.deb) ...
    Selecting previously deselected package g++-4.6.
    Unpacking g++-4.6 (from .../g++-4.6_4.6.1-9ubuntu3_amd64.deb) ...
    Selecting previously deselected package g++.
    Unpacking g++ (from .../g++_4%3a4.6.1-2ubuntu5_amd64.deb) ...
    Selecting previously deselected package libdpkg-perl.
    Unpacking libdpkg-perl (from .../libdpkg-perl_1.16.0.3ubuntu5_all.deb) ...
    Selecting previously deselected package dpkg-dev.
    Unpacking dpkg-dev (from .../dpkg-dev_1.16.0.3ubuntu5_all.deb) ...
    Selecting previously deselected package build-essential.
    Unpacking build-essential (from .../build-essential_11.5ubuntu1_amd64.deb) ...
    Preparing to replace dkms 2.2.0.2-1ubuntu4 (using .../dkms_2.2.0.2-1ubuntu4_all.deb) ...
    Unpacking replacement dkms ...
    Selecting previously deselected package libalgorithm-diff-perl.
    Unpacking libalgorithm-diff-perl (from .../libalgorithm-diff-perl_1.19.02-2_all.deb) ...
    Selecting previously deselected package libalgorithm-diff-xs-perl.
    Unpacking libalgorithm-diff-xs-perl (from .../libalgorithm-diff-xs-perl_0.04-1build1_amd64.deb) ...
    Selecting previously deselected package libalgorithm-merge-perl.
    Unpacking libalgorithm-merge-perl (from .../libalgorithm-merge-perl_0.08-2_all.deb) ...
    Preparing to replace linux-headers-generic 3.0.0.12.14 (using .../linux-headers-generic_3.0.0.12.14_amd64.deb) ...
    Unpacking replacement linux-headers-generic ...
    Processing triggers for man-db ...
    Setting up libdpkg-perl (1.16.0.3ubuntu5) ...
    Setting up dpkg-dev (1.16.0.3ubuntu5) ...
    Setting up dkms (2.2.0.2-1ubuntu4) ...
    Setting up libalgorithm-diff-perl (1.19.02-2) ...
    Setting up libalgorithm-diff-xs-perl (0.04-1build1) ...
    Setting up libalgorithm-merge-perl (0.08-2) ...
    Setting up linux-headers-generic (3.0.0.12.14) ...
    Setting up libstdc++6-4.6-dev (4.6.1-9ubuntu3) ...
    Setting up g++-4.6 (4.6.1-9ubuntu3) ...
    Setting up g++ (4:4.6.1-2ubuntu5) ...
    update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mode.
    Setting up build-essential (11.5ubuntu1) ...
    annalee@Reynardine:~$ apt-get autoremove
    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
    annalee@Reynardine:~$ sudo apt-get autoremove
    E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
    annalee@Reynardine:~$ wget http://r8168.googlecode.com/files/r8...025.00.tar.bz2
    --2011-11-05 21:27:06-- http://r8168.googlecode.com/files/r8...025.00.tar.bz2
    Resolving r8168.googlecode.com... 74.125.113.82
    Connecting to r8168.googlecode.com|74.125.113.82|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 61491 (60K) [application/x-bzip2]
    Saving to: `r8168-8.025.00.tar.bz2'

    100%[================================================== ==>] 61,491 341K/s in 0.2s

    2011-11-05 21:27:06 (341 KB/s) - `r8168-8.025.00.tar.bz2' saved [61491/61491]

    annalee@Reynardine:~$ tar xvf r8168-8.025.00.tar.bz2
    r8168-8.025.00/
    r8168-8.025.00/Makefile
    r8168-8.025.00/src/
    r8168-8.025.00/src/rtl_eeprom.h
    r8168-8.025.00/src/r8168_asf.h
    r8168-8.025.00/src/rtltool.h
    r8168-8.025.00/src/r8168_asf.c
    r8168-8.025.00/src/r8168_n.c
    r8168-8.025.00/src/rtl_eeprom.c
    r8168-8.025.00/src/rtltool.c
    r8168-8.025.00/src/Makefile
    r8168-8.025.00/src/r8168.h
    r8168-8.025.00/src/Makefile_linux24x
    r8168-8.025.00/README
    r8168-8.025.00/autorun.sh
    annalee@Reynardine:~$ cd r8168-8.025.00
    annalee@Reynardine:~/r8168-8.025.00$ sudo modprobe -rf r8169
    annalee@Reynardine:~/r8168-8.025.00$ sudo ./autorun.sh

    Check old driver and unload it.
    Build the module and install
    [: 48: r8168: unexpected operator
    Backup r8169.ko
    rename r8169.ko to r8169.bak
    Depending module. Please wait.
    load module r8168
    FATAL: Module r8168 not found.
    Completed.
    annalee@Reynardine:~/r8168-8.025.00$ echo 'blacklist r8169' | sudo tee -a /etc/modprobe.d/blacklist.conf
    blacklist r8169
    annalee@Reynardine:~/r8168-8.025.00$ sudo modprobe -v r8168
    FATAL: Module r8168 not found.
    annalee@Reynardine:~/r8168-8.025.00$ sudo depmod -a
    annalee@Reynardine:~/r8168-8.025.00$ sudo update-initramfs -u
    update-initramfs: Generating /boot/initrd.img-3.0.0-12-generic

  6. #6
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,901
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 11.10 wired network problem

    Hi, first we do not know if you have the right ethernet card for this procedure, as the previous post stated please post the results of this command to determine if it might help.
    Code:
    lspci -nnk | grep -iA2 net
    It looks like you have two install programs running at the same time and you can only have one, you need to close software center while you are working with the terminal and vice versa.

    When you enter a command with sudo in front of it you need to enter your user password, and it will not show the password as you type it for security reasons so when you are done hit enter and the command should run and it may not show anything on the screen many commands do not.

    Unblacklist the driver, you can use a very basic method. Just open the blacklist.conf file in super-user mode:
    Code:
    gksu gedit /etc/modprobe.d/blacklist.conf
    and add the hash (#) mark in the beginning of any line which you want to enable. So in your case, after opening that file with above command, look for the line that says blacklist r8169 (it would most probably be in the last) and add the '#' mark in its beginning. So now it should look like this:
    Code:
    # blacklist r8169
    Only do this if that driver is in the blacklist file, if not post the results of the command before you do anything please.
    Save and Exit.

    Then
    Code:
    sudo modprobe r8169
    and your connection should work hopefully.
    Thank you

  7. #7
    Join Date
    Nov 2011
    Beans
    5

    Re: 11.10 wired network problem

    wildmanne39, thanks so much for the help!

    Networking is still down on the Linux side. I pasted the results of the commands you suggested below. The reason you saw the first command twice last time (with password prompt between) is that the first time it failed because another process had dibs. Which should have been my clue to close the package manager. If I wasn't daft, that is.

    Speaking of being a bit daft, it looks like I failed to mention that I'm running Kubuntu. Not sure if that affects anything aside from the changes I made to the commands you posted (kdesudo and kate instead of gksu and gedit).

    Also, the reason I've never made an account to ask for help before is that I'm good friends with an Ubuntu member and Kubuntu developer who's usually around to clean up after my mess-ups. She's getting back from UDS today (it's possible I shouldn't have tried to set up my new machine while she was gone, but it was all fun and games until I tried to fix the network), so if you're not up for doing Kubuntu support, I can own up and tell her I broke it when I see her this afternoon.

    Thanks again for the help! Here's what happened in terminal:

    annalee@Reynardine:~$ lspci -nnk | grep -iA2 net
    07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
    Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard [1458:e000]
    08:00.0 IDE interface [0101]: Marvell Technology Group Ltd. Device [1b4b:917a] (rev 11)
    annalee@Reynardine:~$ kdesudo kate /etc/modprobe.d/blacklist.conf
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QStr ing,QString,QString)
    kbuildsycoca4 running...
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
    QFileSystemWatcher: failed to add paths: /root/.config/ibus/bus
    X Error: BadWindow (invalid Window parameter) 3
    Major opcode: 20 (X_GetProperty)
    Resource id: 0x5a00152
    [[note: the filed opened, and I commented out blacklist r8196]]
    annalee@Reynardine:~$ sudo modprobe r8169
    [sudo] password for annalee:
    FATAL: Module r8169 not found.
    annalee@Reynardine:~$

  8. #8
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,038
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: 11.10 wired network problem

    Hi,

    you can move the module by hand:

    Code:
    cd r8168-8.026.00/
    sudo make
    sudo cp src/r8168.ko /lib/modules/$(uname -r)/kernel/drivers/net/
    sudo depmod -a
    sudo modprobe -v r8168
    sudo update-initramfs -u

  9. #9
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    22,901
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 11.10 wired network problem

    Hi annalee, praseodym is very good with this ethernet card so you can follow his directions and get it working with the new driver and your speed should be good too, you can use the new driver that you tried to install.
    Thank you

  10. #10
    Join Date
    Nov 2011
    Beans
    5

    Re: 11.10 wired network problem

    Thanks for the help.

    cd r8168-8.026.00/ is giving me "No such file or directory."

    Is there somewhere else I should be looking for it?

    Thanks again.

Page 1 of 8 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •