Hello fellow Ubuntu users!

I am hoping you can help me. Since I let the upgrade manager upgrade my Ubuntu system to 11.10 (I think I was previously at 10.06 or so), I find that the GLSlideShow (xscreensaver) that was working before is no longer working - with the same images that were working previously.

Basically when I start xscreensaver in verbose mode, i see these types of errors when it attempts to access each JPG file. Note - these files worked prior to the upgrade to 11.10.

xscreensaver-getimage: unable to load "/usr/share/backgrounds/cosmos/venusmoon_eder.jpg"
xscreensaver-getimage: reason: Couldn't recognize the image file format for file '/usr/share/backgrounds/cosmos/venusmoon_eder.jpg'
<match value="mimetype" type="string" offset="30">

Also, I should mention that I saw the very old comments in another post about editing the MIME types in freedesktop.org.xml to remove the line that looks like this:
<match value="mimetype" type="string" offset="30">
and then reload the mimetypes. I tried that.
Unfortunately that did not fix the problem.

The xscreensaver still complains that it doesn't recognize the image file format.

Any ideas? I very much appreciate your kind help and thank you in advance for any tips!