Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: USB printer and scanner not working with Ubuntu 11.10

  1. #11
    Join Date
    Sep 2012

    Re: USB printer and scanner not working with Ubuntu 11.10

    The trick was to plug in the USB AFTER linux booted and the scanner had fully warmed up which seems to take ages to do (it has a cold fluorescent lamp)

    Scans fine now under Ubuntu and better options than Win XP. All is forgiven Linux.

  2. #12
    Join Date
    Aug 2006
    S.F. Bay Area

    Re: USB printer and scanner not working with Ubuntu 11.10

    Great! Glad you got it working!


  3. #13
    Join Date
    Apr 2011
    Southern California
    Ubuntu 11.10 Oneiric Ocelot

    Re: USB scanner not working with Ubuntu 11.10

    In my case, just the scanner is a problem.

    I have a Toshiba Satellite A650 laptop (Intel I5). All worked fine in Natty, 11.04. Last month (Oct '12) I upgraded to Oneiric 11.10 and after some diddling, got everything going. I've been doing updates weekly.

    A week ago, the printer stopped being "seen." I reinstalled CUPS and the HP driver and now have two drivers, but one works and I'm stickin' with that.

    I've changed nothing else except updates, but a few days ago, the Scanner stopped being seen as connected.

    I normally use Simple Scan. I tried XSANE, same problem. lsusb does see the scanner:

    Bus 003 Device 004:
    ID 04b8:0118 Seiko Epson Corp. Perfection 4180 (GF-F600)

    I rebooted multiple times. No change. I tried uninstalling and reinstalling Simple Scan. No change.

    The laptop is dual boot, and Windows 7 operates the scanner through the same USB hub etc.

    I'd appreciate all ideas and suggestions!


    PS I tried unplugging the USB as above, no change. I also checked the kernel: it's
    Last edited by KutWrite; November 4th, 2012 at 06:25 AM. Reason: Addendum

  4. #14
    Join Date
    Apr 2005

    Epson 4180 perfection scanner: use Epson drivers?

    can I suggest you install the Epson scanner drivers that they supply

    .........I started at the core page .....

    and typed in 4180 .........and got the top search result

    it comes down as a .tar.gz file iscan_2.10.0-1.tar.gz

    ....if you save to your Downloads directory.....

    I would envisage the commands

    cd Downloads
    tar -zxvf iscan_2.10.0-1.tar.gz
    cd iscan_2.10.0-1
    sudo make install
    I get that from the Epson instructions in their README

    4-2 Installing a tar file

    Execute the following command to complete the installation.

    # tar -zxvf iscan-${version}-${release}.tar.gz
    # cd iscan-${version}
    # ./configure
    # make
    # make install

    Note that the installation of Image Scan! for Linux from tar requires
    that sane has been installed from tar as well.

  5. #15
    Join Date
    Apr 2011
    Southern California
    Ubuntu 11.10 Oneiric Ocelot

    Re: USB scanner not working with Ubuntu 11.10

    I tried SANE before, and the output said to use XSANE instead, which I did.

    I will try reinstalling as you so carefully outlined. But I'm wondering why it worked before and not now.

    I'll let you know how it goes.


    OK... It worked at first. When I did the "tar... "command a whole bunch of iscan things happened. When I got to "cd iscan_2.10.0-1" There is no such directory, at least not visible from Downloads. I'll look further.

    OK... there IS a folder called iscan_2.10.0 without the hyphen and 1 at the end...

    OK... Now I'm at a standstill. I ran the ./configure command. It ended with this:

    "checking for GTK... no
    checking for GTK... configure: error: Package requirements (gtk+) were not met:

    No package 'gtk+' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GTK_CFLAGS
    and GTK_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details."

    I assume this has something to do with Gnome, which is what I run under (classic, no animation)

    I tried "make" anyway, and got this:

    "daniel@daniel-toshiba:~/Downloads/iscan-2.10.0$ make
    make: *** No targets specified and no makefile found. Stop."

    Any further instructions? I hope so!
    Last edited by KutWrite; November 5th, 2012 at 12:43 AM. Reason: Further info

  6. #16
    Join Date
    Apr 2005

    Re: USB printer and scanner not working with Ubuntu 11.10

    No package 'gtk+' found me, that means it is likely you do not have gtk installed;

    if you google on

    No package 'gtk+' found
    you get things like this

    .....looks like adding

    libgtk-3-0 and libgtk-3-dev would the commands again after installing these two packages......

    .......when you couldn't find the iscan directory, if you use the command

    .....inside any LISTS what is there so you can identify the name of the directory you are looking for ..

    ........also if you type the first two or three letters of a word such as iscan

    cd isc
    ........... and then hit the TAB key,

    ...................the system should type out the rest of what you want..if there is only one directory starting with ...........isc
    Last edited by pdc; November 5th, 2012 at 01:20 AM.

  7. #17
    Join Date
    Apr 2011
    Southern California
    Ubuntu 11.10 Oneiric Ocelot

    Re: USB scanner not working with Ubuntu 11.10

    Got the same error again...

    Thanks, PDC, for the help. You've been very quick and patient, explaining these things.

    The problem I have is, I seem to fall down newer rabbit holes each time I try to fix something, even after 1 1/2 years of "trying out" Linux.

    I did try using the Ubuntu Software Center to find GTK. All I found were apps which run UNDER GTK, which just made me want to walk away for a bit.

    Here's what happened:

    I installed the Dev pkg per the post you linked:

    sudo apt-get install libgtk-3-dev

    I then looked for libgtk using Ubuntu Software center & it said I already had it:

    "Installed - GTK+ is a multi-platform toolkit for creating graphical user interfaces. Offering a complete set of widgets, GTK+ is suitable for projects ranging from small one-off tools to complete application suites.
    This package contains the shared libraries.
    Version libgtk-3-0 3.2.0-0ubuntu6"

    I ran ./config and the same GTK+ error occurred as before.

    I did a Google search and saw some admonishments as to using non-standard packages, but so far, not what to do if you have the package and something can't find it. Perhaps a clue is in the config files mentioned in the error message, but I don't know where those are.

    I searched for an hour or so, but seem to have hit another dead end.

    I'd again greatly appreciate your help.

    - - - - -

    A few hours later:

    I found and tried this suggestion:

    I used

    locate pkgconfig

    to find that path. Well, there were two, but this one looked more like
    the example in the post I saw, so I entered:

    export PKG_CONFIG_PATH

    But that didn't change anything. I don't know why it's looking for GTK+ instead of GTK3.

    Later... I found a folder at /usr/include/gtk-3.0. there were a bunch of similarly named GTK folders
    which seem linked to GUIs, Python, etc.

    Do I need to point something to that?

    There was also a folder named GTK-2.0 and similarly named ones, as above.
    Last edited by KutWrite; November 5th, 2012 at 03:39 PM. Reason: New info

  8. #18
    Join Date
    Apr 2011
    Southern California
    Ubuntu 11.10 Oneiric Ocelot

    Re: USB scanner not working with Ubuntu 11.10

    This AM I tried a few more things:

    $ sane-find-scanner

    # sane-find-scanner will now attempt to detect your scanner. If the
    # result is different from what you expected, first make sure your
    # scanner is powered up and properly connected to your computer.

    # No SCSI scanners found. If you expected something different, make sure that
    # you have loaded a kernel SCSI driver for your SCSI adapter.

    found USB scanner (vendor=0x04b8, product=0x0118 ) at libusb:003:007
    found USB scanner (vendor=0x8086, product=0x0186) at libusb:001:003
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    I'm not sure why it found two scanners I only have one. It matches the ID of the first found device, ending in 0118. The scanner was powered on but my other USB devices were powered off (e.g. printer).

    Then I tried:

    $ sudo scanimage -L
    [sudo] password for daniel:

    No scanners were identified. If you were expecting something different,
    check that the scanner is plugged in, turned on and detected by the
    sane-find-scanner tool (if appropriate). Please read the documentation
    which came with this software (README, FAQ, manpages).

    Some of these posts go back to 2005. I guess this is a long-standing problem.
    Last edited by KutWrite; November 5th, 2012 at 03:54 PM. Reason: More info

  9. #19
    Join Date
    Apr 2005

    Re: USB printer and scanner not working with Ubuntu 11.10

    how about one more go at installing iscan .......

    if we use alien, to convert rpm packages to .deb packages

    but first have a read at this Mint post..Mint is derived from Ubuntu..

    ....I don't know if it is relevant .......

    as advised from here

    sudo apt-get install alien
    get the Epson rpm package from here

    download into your Downloads directory; save

    so first command is

    cd Downloads
    ..hit enter.....

    check the package is there ......ask the directory to list its contents.....

    and convert and install with alien

    sudo alien -i iscan-2.10.0-1.i386.rpm
    and let's install the plugin (making sure we are still INSIDE the Downloads directory........)

    sudo alien -i iscan-plugin-gt-f600-1.0.0-1.i386.rpm
    ... I wonder if all that gets you anywhere........

    to get it running..............

    and apparently it should open from within GIMP as well..............
    Last edited by pdc; November 5th, 2012 at 09:55 PM.

  10. #20
    Join Date
    Apr 2011
    Southern California
    Ubuntu 11.10 Oneiric Ocelot

    Re: USB scanner not working with Ubuntu 11.10

    Thanks PDC... Here goes. I'll enter events step by step, as I don't think I can do this in one go.

    I looked at the Mint thread. It was for Isadora; they are now on Maya. It says the Epson won't work with SimpleScan, but I've been happily using SimpleScan until 11.10 (oh, how much trouble I've had since I left 11.04).

    OK here goes the rest...

    1. I already had installed Alien using the Ubuntu Software center.

    2. RPM files... one mental bookmark: You linked to gcc 3.2/3.3. I have gcc 4.6.1. So I looked for a higher version. I found one and may later try the ones for gcc 3.4 and later. But they're from Avasys, not Epson, so I'll hold off unless the file you linked doesn't work.

    Well... I cut & pasted your Alien command and checked; it was the same as the rpm file name I downloaded. But... it didn't work.

    I got a whole bunch of error messages like this:

    error: db5 error(-30969) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
    error: cannot open Packages index using db5 - (-30969)
    error: cannot open Packages database in /home/daniel/.rpmdb
    Warning: Skipping conversion of scripts in package iscan: postinst postrm preinst prerm
    Warning: Use the --scripts parameter to include the scripts.
    mkdir: cannot create directory `iscan-2.10.0': File exists
    unable to mkdir iscan-2.10.0: at /usr/share/perl5/Alien/ line 257.

    Should I try again, using the "--scripts" parameter? I'm nervous to try it w/o an OK from someone who knows what's what.
    Last edited by KutWrite; November 6th, 2012 at 07:26 AM. Reason: Dead end for now

Page 2 of 4 FirstFirst 1234 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts