Results 1 to 4 of 4

Thread: switchable gpu

  1. #1
    Join Date
    Oct 2011

    switchable gpu

    I have a lenovo y560 which have two gpu one is of intel and other is of ati.
    In windows 7 i have driver to control and switch between these two. But in ubunto even ati drivers doesnt worked. It also make my compiz stop working.
    Please help me....
    Last edited by ankitbhardwaj; October 16th, 2011 at 05:38 PM.

  2. #2
    Join Date
    Dec 2009
    Goor, Netherlands
    Ubuntu 10.10 Maverick Meerkat

    Re: switchable gpu

    You are not the only one with this problem, switchable graphics and linux (or better say, xserver) is still not very nice.

    And according to this bugreport: it is not a very high priority issue so if you want to use an ATI/Intel switchable graphics solution you have to stick to the opensource drivers and use the vgaswitcheroo command to disable the ATI and use the Intel. The opensource AMD/ATI drivers are not to fast but at least they are stable.

    For the switcheroo commands look here:

  3. #3
    Join Date
    Oct 2008

    Re: switchable gpu

    I also have a switchable GPU laptop (HP Envy 14 beats) but I'm not even able to run ANY openGL applications.

    As soon as I attempt to open an application that uses openGL it just instantly closes on me. (This includes even basic games like gl-117)

    Any help on this?

    edit: Here is where gl-117 dies, I think this is probably useful info
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  155 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  13
      Current serial number in output stream:  13
    Segmentation fault
    Last edited by nlion; October 16th, 2011 at 10:37 PM.

  4. #4
    Join Date
    Oct 2011

    Re: switchable gpu

    its not only I can't switch between the two gpus.
    after installing the ATI drivers my compiz stop working.
    did anyone know about this problem...?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts