Results 1 to 4 of 4

Thread: (K)Ubuntu 11.10 - No sound in Neverwinter Nights

Threaded View

  1. #1
    Join Date
    Oct 2011

    (K)Ubuntu 11.10 - No sound in Neverwinter Nights


    Under Kubuntu 11.04, my NWN worked perfectly. Now I have a new installation (no upgrade) of 11.10 and NWN has no sound anymore. I kept the old, working NWN installation, so I doubt the problem's located there (since nothing has been changed). Other applications (both ALSA and OSS) work fine. As do other SDL games (tested sdl-ball and biniax2 as 64bit apps and Rune as 32bit app).

    I get no error messages in the terminal emulator (not even with SDL_DEBUG set). I just have no sound and in the advanced sound options in the game, the list of sound providers is empty.

    Here's what I've tried so far:

    • Activate/deactivate PulseAudio
    • Deinstall PulseAudio
    • Set SDL_AUDIODRIVER in the nwn script to 'alsa' and 'dsp' (with export)
    • Removed the './lib' from the LD_LIBRARY_PATH in the nwn script
    • Switched between libsdl1.2debian-all and libsdl1.2debian-alsa and back
    • Ran NWN without KDE/Gnome from a clean X-Session (only evilwm and one xterm)
    • Made sure that the outputs of 'fuser /dev/snd/*' and 'fuser /dev/dsp' are empty
    • Set/unset SDL_DSP_NOSELECT

    Made strace log of nwn and checked for obvious problems. Due to large size (35 MB), I could only skim through it, of course. The only thing I noticed is that it never actually loads 'ldd', when used on the nwmain binary also shows no reference to libasound. But I'm not sure if that's how it's supposed to be. Perhaps someone with a working NWN can cross-check that for me.

    I googled a lot and think I've tried all the usual hints that are mentioned here and elsewhere. If I missed something, please point me to it. Other than that, I'm open for ideas.

    I am using the amd64 version of Kubuntu, kernel 3.0.4 (self compiled with OSS compatibility). Soundcard is Asus Xonar D2X. ia32-libs are installed.

    I'll attach a few shell snippets for further information (especially the outputs of 'ldd' and 'ldconfig -p' - though don't know how helpful they'll be).
    Attached Files Attached Files


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts