Hi All,

I'm having some problems with (re-)installing drivers for my nVidia Geforce GT550M. I have an ASUS laptop with dual graphics cards, and was trying to get them working properly with Unity (but that's another story). I followed a suggestion and upgraded to a newer version of the nVidia drivers. That was when everything died, and I have tried to return to the standard (nvidia-current) drivers by uninstalling the drivers which I installed, and installing nvidia-current drivers.

But now when I try to install nvidia-current I get the series of error messages bellow. I have tried uninstalling and purging nvidia-current (as it seems to be partially installed badly), and installing with apt-get -f install, all without any headway.

Does anyone have any suggestions?



PS I'm running 11.04, trying to get this sorted before I upgrade.

$ sudo apt-get install nvidia-current
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 56.8 MB of archives.
After this operation, 179 MB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ natty/main nvidia-current amd64 285.05.09-0ubuntu1~natty~xup1 [56.8 MB]
Fetched 56.8 MB in 6min 48s (139 kB/s)                                         
Selecting previously deselected package nvidia-current.
(Reading database ... 337913 files and directories currently installed.)
Unpacking nvidia-current (from .../nvidia-current_285.05.09-0ubuntu1~natty~xup1_amd64.deb) ...
Processing triggers for man-db ...
Setting up nvidia-current (285.05.09-0ubuntu1~natty~xup1) ...
update-alternatives: error: alternative link /usr/share/man/man1/nvidia-xconfig.1.gz is already managed by x86_64-linux-gnu_gl_conf.
dpkg: error processing nvidia-current (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)