Results 1 to 2 of 2

Thread: No sound on Resume in 11.10 -"In Monitor" Switches Off

  1. #1
    Join Date
    Oct 2008
    Beans
    10

    Angry No sound on Resume in 11.10 -"In Monitor" Switches Off

    Okay. I have a Turtle Beach RIVIERA PCI Sound Card. After resuming from Suspend or Hibernate "S/PDIF In Monitor" is switched off. This causes the speakers on my computer desk to stop working, but the surround sound system for the TV does still work.

    I also had this problem in 11.04, but it was easier to fix with gnome-alsa-mixer. Now I have to open up alsamixer in terminal to turn my speakers back on.

    Any solution to this or work around would be much appreciated.

    Also, I should say that in 11.04 the sound would be muted on resume as well.
    Last edited by enseyn; October 15th, 2011 at 05:10 PM.

  2. #2
    Join Date
    Oct 2008
    Beans
    10

    Re: No sound on Resume in 11.10 -"In Monitor" Switches Off

    FIXED IT!!!
    Okay, I used This guide and combined a couple parts to get it working.

    I used this part:
    Getting ALSA to work after suspend / hibernate

    Some soundcards does not work after the computer has been suspended or hibernated. Files in /etc/pm/sleep.d/ are read when the system is entering or leaving suspend mode. Create a file telling the system to restart alsa when the computer is being brought up from suspended mode to make the audio work again.

    The command /sbin/alsa force-reload will kill all running programs using the sound driver so the driver itself is able to be restarted.

    sudo nano /etc/pm/sleep.d/50alsa

    case "$1" in
    hibernate|suspend)
    # Stopping is not required
    ;;
    thaw|resume)
    /sbin/alsa force-reload
    ;;
    *) exit $NA
    ;;
    esac

    Make the newly created script to be executable with the following command:

    sudo chmod +x /etc/pm/sleep.d/50alsa
    At first it didnt work, but then I thought, Why am I not just reloading the settings with alsactl? So I changed /etc/pm/sleep.d/50alsa to this:

    case "$1" in
    hibernate|suspend)
    # Stopping is not required
    ;;
    thaw|resume)
    /sbin/alsactl -F -f /var/lib/alsa/asound.state restore
    ;;
    *) exit $NA
    ;;
    esac
    And Voilà! Working sound on resume.
    Last edited by enseyn; October 16th, 2011 at 10:44 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •