Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Scheduled shutdown via gshutdown not doing it

  1. #1
    Join Date
    May 2011
    Location
    Tbilisi, Georgia
    Beans
    198
    Distro
    Ubuntu 14.04 Trusty Tahr

    Scheduled shutdown via gshutdown not doing it

    Hello,

    I searched for a shutdown scheduler soft for Ubuntu via the Software Center and found gshutdown, which seems to have all the necessary options for doing it, although every time the countdown set by me to shutting the Ubuntu down reaches 0, it logs off to the log in screen, instead of shutting down.
    Is there any other similar software, or how can I correct this in gshutdown?

    Thanks in advance.

  2. #2
    Join Date
    May 2011
    Location
    Tbilisi, Georgia
    Beans
    198
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Scheduled shutdown via gshutdown not doing it

    Anything?

  3. #3
    Join Date
    Nov 2005
    Location
    Portugal, Baixo Alentejo
    Beans
    381
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Scheduled shutdown via gshutdown not doing it

    Quote Originally Posted by Tornikee View Post
    Hello,

    I searched for a shutdown scheduler soft for Ubuntu via the Software Center and found gshutdown, which seems to have all the necessary options for doing it, although every time the countdown set by me to shutting the Ubuntu down reaches 0, it logs off to the log in screen, instead of shutting down.
    Is there any other similar software, or how can I correct this in gshutdown?

    Thanks in advance.
    Hi, I hope I am still on time to help.
    You must change the settings of gshutdown as follows:
    Edit-Preferences
    Select customized command and under shutdown you should have the following:
    shutdown -h now

    to reboot:
    reboot

    to logoff:
    /usr/bin/gnome-session-save --kill --silent

    Also, select "execute a command before the action" and type:
    nautilus -q

    That should work.
    Yoram David
    __________________________________________
    We must be the change we want for the world (Ghandi)

  4. #4
    Join Date
    May 2011
    Location
    Tbilisi, Georgia
    Beans
    198
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Scheduled shutdown via gshutdown not doing it

    Thanks a lot for the reply. Will reinstall gshutdown and follow your tips.

  5. #5
    Join Date
    Nov 2005
    Location
    Portugal, Baixo Alentejo
    Beans
    381
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Scheduled shutdown via gshutdown not doing it

    Quote Originally Posted by Tornikee View Post
    Thanks a lot for the reply. Will reinstall gshutdown and follow your tips.
    You are welcome.

    I had the same problem a couple of years ago with Ubuntu 8 or 9, it got solved with the above solution.
    I found that after upgrading to ubuntu 11.10, it did not even work with the above solution, it would just do nothing at all, so I solved the problem running gshutdwon as root by adding
    gksu
    before the shortcut to the application, using alacarte. It asks for you password to run the program.
    Yoram David
    __________________________________________
    We must be the change we want for the world (Ghandi)

  6. #6
    Join Date
    May 2011
    Location
    Tbilisi, Georgia
    Beans
    198
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Scheduled shutdown via gshutdown not doing it

    I just tested this solution and it didn't work - the system didn't even log off after countdown ended. I guess I have a newer version of Gshutdown as some of the preferences are a bit different to those described by you, so I might have entered the commands in incorrect fields.
    I've taken some screens:

    http://bit.ly/rzOAsf
    http://bit.ly/vqUDJz

    Is this all correct?

  7. #7
    Join Date
    Nov 2005
    Location
    Portugal, Baixo Alentejo
    Beans
    381
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Scheduled shutdown via gshutdown not doing it

    Quote Originally Posted by Tornikee View Post
    I just tested this solution and it didn't work - the system didn't even log off after countdown ended. I guess I have a newer version of Gshutdown as some of the preferences are a bit different to those described by you, so I might have entered the commands in incorrect fields.
    I've taken some screens:

    http://bit.ly/rzOAsf
    http://bit.ly/vqUDJz

    Is this all correct?
    Your settings are correct. The screen-shots look the same as my program (version 0.2).

    Please also run the following commands so the commands should not aks for a password:
    Code:
    sudo chmod +s /sbin/shutdown
    and
    Code:
    sudo chmod +s /sbin/reboot
    I had the same issue you have, it would do nothing even running these two commands as shutdown and reboot needs sudo.
    That is why I added the
    Code:
    gsku
    in front of the link to the program to start it with sudo privileges.
    My link to the program is like this now:
    Code:
    gksu /usr/bin/gshutdown
    Do you know how to do this?

    Yoram
    Yoram David
    __________________________________________
    We must be the change we want for the world (Ghandi)

  8. #8
    Join Date
    May 2011
    Location
    Tbilisi, Georgia
    Beans
    198
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Scheduled shutdown via gshutdown not doing it

    Thanks for the reply.

    I forgot how to make that adjustment, so a hint would be great.

  9. #9
    Join Date
    Nov 2005
    Location
    Portugal, Baixo Alentejo
    Beans
    381
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Scheduled shutdown via gshutdown not doing it

    Quote Originally Posted by Tornikee View Post
    Thanks for the reply.

    I forgot how to make that adjustment, so a hint would be great.
    So, I am assuming it still did not work even running the two above commands?

    I use a program you find in the ppa: "alacarte" which is a menu editor.
    Code:
    sudo apt-get install alacarte
    So, install alacarte (you can reorganize all your menus the way you like with it) and browse for the shortcut to gshutdown, edit it and add the "gsku" bit to that menu entry.
    Yoram David
    __________________________________________
    We must be the change we want for the world (Ghandi)

  10. #10
    Join Date
    May 2011
    Location
    Tbilisi, Georgia
    Beans
    198
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Scheduled shutdown via gshutdown not doing it

    Haven't tried those two commands yet. Should I just add them to 'nautilus -q' line?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •