Results 1 to 10 of 10

Thread: disable recent documents in ubuntu 11.10?

  1. #1
    Join Date
    Sep 2009
    Beans
    107

    Question disable recent documents in ubuntu 11.10?

    Hello everyone,

    the title says it all, anyone has any idea how to do this?

    thanks in advance!

  2. #2
    Join Date
    Sep 2009
    Beans
    107

    Re: disable recent documents in ubuntu 11.10?

    anyone?

  3. #3
    Join Date
    May 2011
    Beans
    3

    Lightbulb Re: disable recent documents in ubuntu 11.10?

    Delete history:

    cd ~/.local/share
    rm recently-used.xbel
    touch recently-used.xbel

    Disable:
    cd ~/.local/share
    sudo chattr +i recently-used.xbel

    Re-Enable:
    cd ~/.local/share
    sudo chattr -i recently-used.xbel

    http://www.linux-survival-blog.de/20...-recent-files/

  4. #4
    Join Date
    Jan 2009
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: disable recent documents in ubuntu 11.10?

    I have recently switched to LMDE because I hate unity, but this (or a modified version) should work. I wrote a shell script. it requires inotify-tools, but here is the code:

    Code:
    #!/bin/bash
    recentFile="$HOME/.local/share/recently-used.xbel";
    hasInotifyTools=$(type -P inotifywait);
    if [ ! -z $hasInotifyTools ]; then
    	echo "$recentFile";
    	while true; do
    		while inotifywait $recentFile; do
    			if [ -s "$recentFile" ]; then echo "clearing file $recentFile"; cat /dev/null > $recentFile; fi
    		done
    	done
    else
    	echo "Please install inotify-tools...";
    fi
    I intend to add it to my session startup.

    Hope it helps...

  5. #5
    Join Date
    Nov 2004
    Location
    Austin, TX... for now
    Beans
    117
    Distro
    Ubuntu

    Re: disable recent documents in ubuntu 11.10?

    Install "Activity Log Monitor" from the Zeitgeist PPA.

    Then turn logging off.

  6. #6
    Join Date
    Sep 2009
    Beans
    107

    Re: disable recent documents in ubuntu 11.10?

    thank you very much everyone I will try your suggestions.

  7. #7
    Join Date
    Sep 2009
    Beans
    107

    Re: disable recent documents in ubuntu 11.10?

    I was not able to use "Activity Log Monitor" because I could not find any GUI that would allow me to modify settings, etc.. I also could not find enough documentation to learn how to use this program. Besides the "recent documents" issues, I was having other problems with 11.10 (computer was freezing at random times, etc..) and so I decided to uninstall it.

    thank you all for your help!

  8. #8
    Join Date
    Nov 2005
    Beans
    13

    Re: disable recent documents in ubuntu 11.10?

    Finaly!!

    sudo apt-get install activity-log-manager

  9. #9
    Join Date
    May 2011
    Location
    India
    Beans
    2
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: disable recent documents in ubuntu 11.10?

    If you are using unity, you can make unity not to show your history by deleting the file used to show your history.
    sudo rm /usr/share/unity/lenses/files/files.lens
    Now unity cannot show your history in your dash home.
    Hope this helps someone .

  10. #10
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: disable recent documents in ubuntu 11.10?

    delete ~/.local/share/recently-used.xbel and make a folder with the same name
    Code:
    rm ~/.local/share/recently-used.xbel
    mkdir ~/.local/share/recently-used.xbel

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •