Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: X11VNC on 11.10 (was working with 11.04)

  1. #11
    Join Date
    Nov 2007
    Beans
    187

    Re: X11VNC on 11.10 (was working with 11.04)

    ok,

    can you post /tmp/x11vnc.log after you run the command?

    it is correct that it doesn't say anything on command line.

  2. #12
    Join Date
    Nov 2007
    Beans
    187

    Re: X11VNC on 11.10 (was working with 11.04)

    also please post the output of the command:

    Code:
    ps wwwwaux | grep auth
    in which state is the computer when you try to run the command I suggested? I mean: is lightDM login screen shown on the screen?

    are you doing it over ssh from a remote machine or in front of the machine itself? This command only works remotely, via ssh. If you login in front of the computer to run this command, it cannot work.

    In this situation, the command consistently works for me.

  3. #13
    Join Date
    Oct 2011
    Beans
    12

    Re: X11VNC on 11.10 (was working with 11.04)

    Quote Originally Posted by alfonso78 View Post
    please post the output of the command:

    Code:
    ps wwwwaux | grep auth
    See Post #5

    Quote Originally Posted by alfonso78 View Post
    I mean: is lightDM login screen shown on the screen?
    Yes (on local screen not on VNC which won't even connect)

    Quote Originally Posted by alfonso78 View Post
    are you doing it over ssh from a remote machine
    Yes (see post #1 )

    Quote Originally Posted by alfonso78 View Post
    it is correct that it doesn't say anything on command line.
    Well, that put's my mind at ease, I assume I'd get an error then if it weren't taking the command.

    Quote Originally Posted by alfonso78 View Post
    ok,

    can you post /tmp/x11vnc.log after you run the command?
    Exact Log (entire file cleaned out before running the command exactly as you had it)

    Code:
    19/10/2011 18:54:50 passing arg to libvncserver: -rfbauth
    19/10/2011 18:54:50 passing arg to libvncserver: /etc/x11vnc.pass
    19/10/2011 18:54:50 passing arg to libvncserver: -rfbport
    19/10/2011 18:54:50 passing arg to libvncserver: 5900
    19/10/2011 18:54:50 x11vnc version: 0.9.12 lastmod: 2010-09-09 pid: 2172
    19/10/2011 18:54:50
    19/10/2011 18:54:50 WARNING: DISPLAY starts with localhost: 'localhost:10.0'
    19/10/2011 18:54:50 WARNING: Is this an SSH X11 port forwarding? You most
    19/10/2011 18:54:50 WARNING: likely don't want x11vnc to use that DISPLAY.
    19/10/2011 18:54:50 WARNING: You probably should supply something
    19/10/2011 18:54:50 WARNING: like: -display :0 to access the physical
    19/10/2011 18:54:50 WARNING: X display on the machine where x11vnc is running.
    19/10/2011 18:54:50
    PuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong a$
    19/10/2011 18:54:50 Trying again with XAUTHLOCALHOSTNAME=localhost ...
    PuTTY X11 proxy: wrong authorisation protocol attemptedPuTTY X11 proxy: wrong a$
    19/10/2011 18:54:50 ***************************************
    19/10/2011 18:54:50 *** XOpenDisplay failed (localhost:10.0)
    __________________________________________________ _____________________
    GOT IT!!!!
    needed to add -display :0 to your command (per line 10 above)
    when the command works it'll spit out the words "Port 5900" before bouncing to the new prompt

    I also added -localhost (after a reboot) which was approved (same "Port 5900") but stopped me from being able to connect.

    Rebooted again, placed your command with only -display :0 added and was able to localhost:1
    __________________________________________________ _____________________

    While at startup would be nice, at least now I can reboot the computer ssh into it past the command (or maybe we can make a .sh (I've never done that am a linux Ubern00b, so I'd need your aid in crafting it ) which I could type "go.sh" have it run
    Code:
     sudo /usr/bin/x11vnc -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -bg -rfbport 5900 -o /tmp/x11vnc.log -display :0
    and I'd be good to go

    __________________________________________________ __________________________________________________ _________________________________________
    EDIT3
    Ok so once you log out of GUI, it closes the vnc and you have to run the command again so -forever is looking like it is not functional.
    Running the command again lets you in
    Last edited by nergaldicuthah; October 20th, 2011 at 02:15 AM.

  4. #14
    Join Date
    Nov 2007
    Beans
    187

    Re: X11VNC on 11.10 (was working with 11.04)

    cheers!

    it's the first time I help an other user. I guess I graduated.

    And let's keep trying to find the way to start it automatically, even if I admit it's not a priority.

  5. #15
    Join Date
    Oct 2011
    Beans
    12

    Re: X11VNC on 11.10 (was working with 11.04)

    Quote Originally Posted by alfonso78 View Post
    cheers!

    it's the first time I help an other user. I guess I graduated.

    And let's keep trying to find the way to start it automatically, even if I admit it's not a priority.
    Congrats and Yes I agree

    (I currently have keypass (for windows) 1.x typing the command in )

  6. #16
    Join Date
    Jun 2007
    Beans
    14

    Smile Re: X11VNC on 11.10 (was working with 11.04)

    Here is what I do:

    I have xinetd super server installed.
    In the file /etc/xinetd.d/x11vnc:
    Code:
    service x11vnc
    {
          disable       = no
          type          = UNLISTED
          port          = 5900
          socket_type   = stream
          protocol      = tcp
          wait          = no
          user          = root
          only_from     = 127.0.0.1
          server        = /usr/bin/x11vnc
          server_args   = -inetd -o /var/log/x11vnc.log -xkb -noxdamage -display :0 -auth /var/run/lightdm/root/:0 -rfbauth /home/jim/.vnc/passwd -localhost
    }
    Restart or reload xinetd after creating this file.

    I access it via an ssh tunnel and it works whether already logged in on the console or waiting at the login window.

    Command from a linux system is like:
    Code:
    vncviewer -via host.example.com localhost:0
    jim
    Last edited by jimbudler; October 20th, 2011 at 11:25 PM. Reason: add command line for accessing

  7. #17
    Join Date
    Oct 2011
    Beans
    12

    Re: X11VNC on 11.10 (was working with 11.04)

    Quote Originally Posted by jimbudler View Post
    Here is what I do:

    I have xinetd super server installed.
    What is the package name so I can APT-GET

    Others in the vino thread have gotten tightVNC working via /etc/lightdm/lightdm but I don't know if that is a pre login like Alfonso and myself are looking for.

    Jim's solution seems pretty good, but I'm unclear on if that's allowing x11vnc to start at boot or if we'd still have to initiate xinetd? if the former it's exactly what we're looking for, I assume root doesn't have to be "user" is that correct, If I wanted the user to be PStar could I use
    Code:
    service x11vnc
    {
          disable       = no
          type          = UNLISTED
          port          = 5900
          socket_type   = stream
          protocol      = tcp
          wait          = no
          user          = pstar
          only_from     = 127.0.0.1
          server        = /usr/bin/x11vnc
          server_args   = -inetd -o /var/log/x11vnc.log -xkb -noxdamage -display :0 -auth /var/run/lightdm/root/:0 -rfbauth /etc/x11vnc.pass  -localhost
    }
    or is user=root replacing the SUDO in alfonso's command?
    Last edited by nergaldicuthah; October 21st, 2011 at 01:16 AM.

  8. #18
    Join Date
    Nov 2007
    Beans
    187

    Re: X11VNC on 11.10 (was working with 11.04)

    Quote Originally Posted by nergaldicuthah View Post
    Others in the vino thread have gotten tightVNC working via /etc/lightdm/lightdm but I don't know if that is a pre login like Alfonso and myself are looking for.
    Hi,

    tightVNC is not so hard to start with lightDM (I managed during my tests) and I'm sure it would work pre-login.

    The problem (in my case) is that I need vnc to SHARE the same desktop with the machine, not to have an other virtual desktop. I mean, when I connect, I can see the pointer of my screen moving. I use this as a kind of remote control.

    if it's enough for you to connect and you don't need desktop sharing, I really suggest you look into lightDM support for tightVNC rather then adding xinetd.

    I'm not really happy installing that myself. It's an additional server running on the box and I try to install the least possible number of servers for security reasons.

    I'm trying to remember by heart, so please allow for some mistake, but to test tightvnc it's quite simple:

    Code:
    sudo apt-get install tightvncserver
    then add this section at the end of /etc/lightdm/lightdm.conf:

    Code:
    [VNCServer]
    enabled=true
    port=5900
    and then

    Code:
    sudo service lightdm restart
    to check if it works.

    be careful to NOT have x11vnc running otherwise they will both try to listen to port 5900.

    Or maybe change the port during your experiments (also remeber to change it in the windows client when you try to connect, they have to match)

    normally, you need a good configuration file for tightvnc to work properly, but I didn't get to that stage cause it wasn't my need. Without a nice config file you'll just test that it works and you can login.

    hope it helps!

  9. #19
    Join Date
    Oct 2011
    Beans
    12

    Re: X11VNC on 11.10 (was working with 11.04)

    lol I think you misunderstood me I also have needs specific to x11vnc
    I was more wondering if we could leverage /etc/lightdm/lightdm.conf

    as well (note my last post seems to have removed the .conf I apologize to anyone who reads that incorrectly) for ease this is the post to which I refer http://ubuntuforums.org/showpost.php...6&postcount=12

  10. #20
    Join Date
    Sep 2006
    Beans
    2

    Re: X11VNC on 11.10 (was working with 11.04)

    Instead of using xinetd you can start x11vnc right after lightdm using upstart events. Just create /etc/init/x11vnc.conf file with content:
    start on login-session-start
    script
    x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :0 -auth /var/run/lightdm/root/:0 -forever -bg -o /var/log/x11vnc.log
    end script

    see my blog post for details!

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •