Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 79

Thread: 11.10 fresh install, wireless is very slow.

  1. #31
    Join Date
    Feb 2008
    Beans
    5

    Re: 11.10 fresh install, wireless is very slow.

    Disabling n on the adapter instead of the routeur solved it for me. Well, until a solution is found to use wifi n.

    Thanks a lot wildmanne39

    Now that I remember, in Ubuntu 10.10 I had to enable n manually because it was said to be unstable but it worked fine for me. Then on 11.04 it was enabled by default and worked fine too. I don't know what happened on 11.10 now...

  2. #32
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    25,230
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: 11.10 fresh install, wireless is very slow.

    Hi nerderello, it is a driver issue, the place you want to change the speed to b,g,n, is in your router and not just n.

    Try this please and see if it helps it is only good until you reboot, if it helps we will have to make it permanent.
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f rt2800usb
    sudo modprobe rt2800usb nohwcrypt=1
    sudo ifconfig wlan0 up
    Thank you

  3. #33
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    25,230
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: 11.10 fresh install, wireless is very slow.

    Hi Flashman2003, your welcome!

  4. #34
    Join Date
    Apr 2006
    Beans
    35

    Re: 11.10 fresh install, wireless is very slow.

    Hi wildmanne39,
    thanks for the reply. Sadly it had no effect.

    I've spliced together the commands with the dmesg output:

    sudo ifconfig wlan0 down
    sudo rmmod -f rt2800usb

    [ 524.536533] usbcore: deregistering interface driver rt2800usb

    sudo modprobe rt2800usb nohwcrypt=1

    [ 547.987353] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987364] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987371] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987378] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987383] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987390] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987395] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987402] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987407] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987413] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987419] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987425] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987430] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987437] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987442] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987448] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987454] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987460] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987465] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987472] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987477] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987484] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987489] cfg80211: Updating information on frequency 2467 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987496] cfg80211: 2457000 KHz - 2482000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987501] cfg80211: Updating information on frequency 2472 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987507] cfg80211: 2457000 KHz - 2482000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987513] cfg80211: Updating information on frequency 2484 MHz for a 20 MHz width channel with regulatory rule:
    [ 547.987519] cfg80211: 2474000 KHz - 2494000 KHz @ KHz), (300 mBi, 2000 mBm)
    [ 547.987742] ieee80211 phy2: Selected rate control algorithm 'minstrel_ht'
    [ 547.994990] Registered led device: rt2800usb-phy2::radio
    [ 547.995039] Registered led device: rt2800usb-phy2::assoc
    [ 547.995086] Registered led device: rt2800usb-phy2::quality
    [ 548.000113] usbcore: registered new interface driver rt2800usb
    [ 548.081207] init: network-interface (wlan0) pre-start process (3092) terminated with status 1
    [ 548.084463] init: network-interface (wlan0) post-stop process (3094) terminated with status 1

    sudo ifconfig wlan0 up

    [ 615.808672] wlan0: authenticate with 00:14:6c:b5:d7:06 (try 1)
    [ 615.810182] wlan0: authenticated
    [ 615.864642] wlan0: associate with 00:14:6c:b5:d7:06 (try 1)
    [ 615.868276] wlan0: RX AssocResp from 00:14:6c:b5:d7:06 (capab=0x431 status=0 aid=1)
    [ 615.868280] wlan0: associated
    [ 615.876358] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    I had to disable and re-enable Wireless networks in the gui applet, for this to work.

    I then tried another speedtest and got 0.8 meg.

    As an aside, is there a way of displaying which wireless modes the usb adapter is using? If I do a iwconfig I get (this is after your commands and no reboot has been done) :

    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11bgn ESSID:"SKY95885"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:14:6C:B57:06
    Bit Rate=18 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thrff Fragment thrff
    Power Managementn
    Link Quality=41/70 Signal level=-69 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:93 Invalid misc:2 Missed beacon:0
    While an ifconfig gives:
    eth0 Link encap:Ethernet HWaddr 00:19:66:8b:14:7c
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:21 Base address:0x4000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:50 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3588 (3.5 KB) TX bytes:3588 (3.5 KB)

    wlan0 Link encap:Ethernet HWaddr 00:26:18:c5:04:cf
    inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1836 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1892 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1701484 (1.7 MB) TX bytes:872175 (872.1 KB)
    Which differs from the output when I boot up with kernel version 2.6.38-11-generic:
    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 Ralink STA ESSID:"SKY95885" Nickname:"RT2870STA"
    Mode:Managed Frequency=2.462 GHz Access Point: 00:14:6C:B57:06
    Bit Rate=54 Mb/s
    RTS thrff Fragment thrff
    Link Quality=100/100 Signal level:-55 dBm Noise level:-63 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    and
    eth0 Link encap:Ethernet HWaddr 00:19:66:8b:14:7c
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:21

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 B) TX bytes:100 (100.0 B)

    wlan0 Link encap:Ethernet HWaddr 00:26:18:c5:04:cf
    inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:9064 errors:0 dropped:0 overruns:0 frame:0
    TX packets:350 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1629716 (1.6 MB) TX bytes:77729 (77.7 KB)
    Last edited by nerderello; October 17th, 2011 at 02:24 PM.

  5. #35
    Join Date
    Mar 2011
    Beans
    2

    Re: 11.10 fresh install, wireless is very slow.

    I have an Acer Timeline X with an Atheros wireless card and chipset that uses the ath9k driver. I was getting terrible speeds when using WPA2 Enterprise encryption and having to use my institutions guest network. I tried this from a previous post and now I'm getting proper speeds on WPA2 Enterprise.

    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f ath9k
    sudo modprobe ath9k nohwcrypt=1
    sudo ifconfig wlan0 up
    But my question now is what exactly does adding nohwcrypt=1 do and how do I make it permanent?

    Thanks for your help wildmanne39.

  6. #36
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    25,230
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: 11.10 fresh install, wireless is very slow.

    Hi nerderello, letś try this please if it works we will need to make it permanent.
    Code:
    sudo iwconfig wlan0 power off
    Do not restart your computer after you run that command.
    Thank you

  7. #37
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    25,230
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: 11.10 fresh install, wireless is very slow.

    Hi Lexworth, that command makes your card use software encryption instead of hardware.

    This is how you make it permanent.

    Please do:
    Code:
    gksudo gedit /etc/modprobe.d/ath9k.conf
    Add a single line:
    Code:
    options ath9k nohwcrypt=1
    Proofread carefully, save and close gedit. Reboot.
    Thank you

  8. #38
    Join Date
    Apr 2006
    Beans
    35

    Re: 11.10 fresh install, wireless is very slow.

    Hi wildmanne39,
    thanks for the suggestion.

    Sadly the same result.

    Not sure why we're trying to turn off hardware encryption, as my hardware set up works quite happily with earlier versions of the kernel / driver.

    But I open to any suggestions.

    thanks
    Nerderello

  9. #39
    Join Date
    Apr 2006
    Beans
    35

    Re: 11.10 fresh install, wireless is very slow.

    RESOLVED!
    Found it.

    I use an ASUS N13 USB Wireless dongle, and to get this to work with earlier versions of the kernel/driver, I (like any other user of this adapter) had to add a couple of rules to get it accepted (thanks to forum member Chili555 for that information).

    One of the files that had to be created was /etc/modprobe.d/network_drivers.conf . In this file was the single line
    install rt2870sta /sbin/modprobe --ignore-install rt2870sta $CMDLINE_OPTS; /bin/echo "0b05 1784" > /sys/bus/usb/drivers/rt2870/new_id
    I've put a hash (#) at the beginning of that line (ie. made it into a comment) and rebooted my PC (for good measure, I also pulled the ASUS N13 out and plugged it back in, to make sure that there was nothing loaded into it).

    I now get "normal" internet speeds.

    I have tried this with and without the 'no hardware encrypt' and it makes no difference.

    Many thanks wildmanne39 for your help, but this one has turned out to be down to some sort of driver clash (strange, but the rt2780sta module didn't show up in a lsmod).

    But a heads up for all other ASUS N13 users who upgrade.

  10. #40
    Join Date
    Apr 2011
    Beans
    6

    Re: 11.10 fresh install, wireless is very slow.

    HP DV7 2185DX.. Going back to 11.04 till resolved. Fresh install works on b/g wireless with older linksys routers but on wrt120n & my older home n router wireless stalls.
    I need my n.

Page 4 of 8 FirstFirst ... 23456 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •