Results 1 to 2 of 2

Thread: file not in PATH, gem executables will not run

  1. #1
    Join Date
    Oct 2009

    file not in PATH, gem executables will not run

    Hello, I am having issues installing Ruby Gems. On a stock 11.04 Ubuntu I ran the following commands to prep my installation:

    $ sudo apt-get install libcurl3 libcurl3-dev
    $ sudo apt-get install rubygems
    Ubuntu worked out the correct curl and ruby for my install and installed it.

    The problem happens when I try to install any gem, I get the following error:

    $ sudo gem install --user-install [gem_name]
    WARNING: You don't have /home/giac0m0/.gem/ruby/1.8/bin in your PATH,
                     Gem executables will not run.
    Sucessufully installed [gem_name]
    So, I have tried:

    $ export PATH=/home/giac0m0/.gem/ruby/1.8/bin:$PATH
    and using the instructions from Taurus on this thread:

    editing the .bashrc file to add the line (at the bottom of the file):

    export PATH
    and run the script with:

    source ~/.bashrc
    I get no confirmation that I have updated my path and even after a power cycle I still get the gem errors when trying to install the gems. Any thoughts?
    Last edited by giac0m0; October 5th, 2011 at 11:20 AM. Reason: edited home path to be consistent

  2. #2
    Join Date
    Oct 2009

    Re: file not in PATH, gem executables will not run


Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts