Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: 11.04 won't start X without a monitor attached

  1. #11
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 11.04 won't start X without a monitor attached

    Quote Originally Posted by unruhschuh View Post
    Hello,

    I installed Ubuntu 11.04 on my new HTPC to run XBMC. Everything works fine except, that X won't start during boot with the monitor switched off. When I switch on the TV the screen stays black. If I ssh into the machine and do
    sudo service gdm stop
    sudo service gdm start
    X will start and everything is back to normal. X starts perfectly fine if the TV is on during boot.

    The reason why I want to be able to start the system with X but but without the TV being on, is that I want to use it as a music player, remote controlled by my android phone, but as soon as I switch on the TV I want to see the XBMC menu and be able to play videos.

    Hardware:
    Zotac ZBox ID 41 with Nvidia ION2
    Yes, during boot of X, after it inits the card, then it looks for connected devices on the card's ports. If it doesn't see any devices on a port, it disables the port.

    I know 2 ways to get around it this. One way is to force output to a port such as this:
    From NVidia Readme Appendix G

    Add / apply to the Device section of your X Config file:

    ConnectedMonitor

    Example:
    Code:
        Option       "ConnectedMonitor"               "<list of connected display devices>"
    With this option you can override what the NVIDIA kernel module detects is connected to your video card. This may be useful, for example, if any of your display devices do not support detection using Display Data Channel (DDC) protocols. Valid values are a comma-separated list of display device names; for example:

    "CRT-0, CRT-1"
    "CRT"
    "CRT-0"
    "CRT-1, DFP-0" # <etc...>

    WARNING: this option overrides what display devices are detected by the NVIDIA kernel module, and is very seldom needed. You really only need this if a display device is not detected, either because it does not provide DDC information, or because it is on the other side of a KVM (Keyboard-Video-Mouse) switch. In most other cases, it is best not to specify this option.

    Just as in all X config entries, spaces are ignored and all entries are case insensitive.
    Another way is to say a monitor is connected to a port {just like above, but then) and then give a custom edid file to look at from your hard disk (because the montior is turned off) to find the data it would otherwise see if the montior was turned on...
    Code:
    ## Appply / add to the Device section of xorg,conf.
    Option "ConnectedMonitor" "CRT-0" 
    Option "CustomEDID" "DFP-0:/etc/X11/crt0.edid,bin"
    Of course for that one you would have to generate an EDID binary file, like from nvidia-settings.

    To acquire the EDID, start nvidia-settings. It will show some information in tree format, ignore the rest of the settings for now and select the GPU (the corresponding entry should be titled "GPU-0" or similar), click the "CRT" section (again, "CRT-0" or similar), click on the "Acquire Edid" Button and store it somewhere, for example, /etc/X11/crt0.edid.bin
    Last edited by MAFoElffen; September 30th, 2011 at 03:15 AM.
    Concurrent coexistance of Windows, Linux and Unix...
    Ubuntu user # 33563, Linux user # 533637
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot

  2. #12
    Join Date
    Sep 2011
    Beans
    7

    Re: 11.04 won't start X without a monitor attached

    @MAFoElffen
    I works!

    I just added these two lines to the Device section of xorg.conf:

    Code:
        Option         "ConnectedMonitor" "DFP-1"
        Option         "CustomEDID" "DFP-1:/etc/X11/toshiba.edid"
    The option ConnectedMonitor alone only forces X to look at the specified Port, but if there's nothing connected it can't aquire the EDID information. So providing the edid file is the solution.

    Thanks very much.
    Last edited by unruhschuh; September 30th, 2011 at 10:41 AM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •