Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: enable password request after hibernation

  1. #1
    Join Date
    Aug 2009
    Beans
    121

    enable password request after hibernation

    I would like to enable password protection when i exit hibernation in lubuntu. There is also an issue with the mouse not showing after hibernation.

    I have found some information on the issue:
    http://ubuntuforums.org/showpost.php...47&postcount=5
    https://bugs.launchpad.net/ubuntu/+s...ger/+bug/42052

    but I would like to know if anybody has successfully done this before I try to install kdm over gdm and lxdm.
    Last edited by doru001; May 7th, 2012 at 06:44 AM.

  2. #2
    Join Date
    Aug 2009
    Beans
    121

    Re: enable password request after hibernation

    On second thought, I will not install kdm over gdm and lxdm, because I understand that it would continue running in the background and slow down the system, defeating the very purpose of lubuntu.

    Plus, nobody answered my post. Bump!

    P.S. Use xscreensaver-command -lock to lock the screen in lubuntu.

  3. #3
    Join Date
    Sep 2009
    Beans
    31

    Re: enable password request after hibernation

    In the power manager you can tick "Lock screen when going for suspend/hibernate" in extended tab.

  4. #4
    Join Date
    Aug 2009
    Beans
    121

    Re: enable password request after hibernation

    Quote Originally Posted by Neosano View Post
    In the power manager you can tick "Lock screen when going for suspend/hibernate" in extended tab.
    I am sorry that I did not mention this clearly in the title, but I am talking about lunbuntu, not about gnome. I have gnome installed in parallel with lubuntu, and everything works well in gnome. In lubuntu, I did not find "Power Manager", but it could be hidden somewhere.

  5. #5
    Join Date
    Sep 2009
    Beans
    31

    Re: enable password request after hibernation

    Yes, I was talking about lubuntu. Lubuntu uses xfce power manager by default.

  6. #6
    Join Date
    Aug 2009
    Beans
    121

    Re: enable password request after hibernation

    Quote Originally Posted by Neosano View Post
    Yes, I was talking about lubuntu. Lubuntu uses xfce power manager by default.
    I installed xfce4-power-manager. It is not running by default.

    I killed gnome-power-manager and started xfce4-power-manager. xfce4-power-manager-settings showed that password is required. I tested and it is not required.

    To make xfce4-power-manager to run by default, I tried to mv /etc/xdg/autostart/gnome-power-manager.desktop but still only gnome-power-manager is started.

    If you have any ideas, shoot.
    Last edited by doru001; October 26th, 2011 at 11:34 AM. Reason: big correction ... :)

  7. #7
    Join Date
    Aug 2009
    Beans
    121

    Re: enable password request after hibernation

    Just in case you did not see the edit.

  8. #8
    Join Date
    Nov 2008
    Location
    Sussex, England
    Beans
    871
    Distro
    Lubuntu

    Smile Re: enable password request after hibernation

    Quote Originally Posted by doru001 View Post
    I installed xfce4-power-manager. It is not running by default....
    Lubuntu 11.10 uses xfce4-power-manager as the default manager, but Lubuntu 11.04 uses gnome-power-manager.

    After installing xfce version, go to Synaptic Package Manager and remove the gnome version. Then go to Desktop Sessions Settings and enable Power Manager which should now reference the xfce version.

    Reboot and the battery icon should appear on your panel. Right-click the battery and select preferences

    Originally Posted by Neosano View Post
    In the power manager you can tick "Lock screen when going for suspend/hibernate" in extended tab.
    ...it works for me.

  9. #9
    Join Date
    Aug 2009
    Beans
    121

    Re: enable password request after hibernation

    Quote Originally Posted by SteveDee View Post
    Lubuntu 11.10 uses xfce4-power-manager as the default manager, but Lubuntu 11.04 uses gnome-power-manager.

    After installing xfce version, go to Synaptic Package Manager and remove the gnome version. Then go to Desktop Sessions Settings and enable Power Manager which should now reference the xfce version.

    Reboot and the battery icon should appear on your panel. Right-click the battery and select preferences



    ...it works for me.
    Thank you for your answer.

    When I try to remove gnome-power-manager it will also remove ubuntu-desktop, which is necessary for gnome and maybe for lubuntu. Since I am not sure what will happen if I remove this package and I would like to be able to use gnome when I need it, I have postponed this action.

  10. #10
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: enable password request after hibernation

    Quote Originally Posted by doru001 View Post
    Thank you for your answer.

    When I try to remove gnome-power-manager it will also remove ubuntu-desktop, which is necessary for gnome and maybe for lubuntu. Since I am not sure what will happen if I remove this package and I would like to be able to use gnome when I need it, I have postponed this action.
    The "ubuntu-desktop"-package is perfectly safe to remove, no desktop and no program depends on it.

    It's an empty metapackage, with all the packages used on default Ubuntu setup marked as it's dependencies. No package has it as their dependency, and as dependencies are one-way mechanic removing ubuntu-desktop won't remove anything else.

    The only thing you should pay attention with when dealing metapackages like this is that you should reinstall them before you try to upgrade to next Ubuntu release version, as the metapackage will make sure you get all the new features during the release upgrade.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •