Results 1 to 4 of 4

Thread: How to change permission on entire ntfs partition

  1. #1
    Join Date
    Apr 2011
    Beans
    13

    How to change permission on entire ntfs partition

    Hi,

    On me laptop I have tree partitions: two ntfs and one ext4. In one of ntfs partition I'm keeping all windows applications. On linux I have installed wine, but then I'm trying to load one or other windows application it shows me error that execute bit is not set. So I tried set it, but I can't. When application is in ext4 partition, I easily can set that bit and wine is working. So, how I can change ntfs permission, that allow me to set exetuce bit?

    Thanks for your help

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: How to change permission on entire ntfs partition

    NTFS does not support Linux permissions & ownership so there is no bit to set. Not sure if you set everything to executable, which is not recommended anyway, if it would work. If you set everything to executable you open up to virus' and other issues. Big part of why Linux is more secure than NTFS.

    I just copied Windows version of Saving Bond Wizard into Wine programs and installed it there. Then it worked and I was able to load my data files from my shared NTFS partition without issue.

    Ownership and permissions of vfat / ntfs are set at the time of mounting. This is often a source of confusion.
    http://www.psychocats.net/ubuntu/mountwindowsfstab
    HOWTO: Mount NTFS partitions with specific ownership/permissions - WorMzy
    http://ubuntuforums.org/showthread.php?t=1604251
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Dec 2009
    Beans
    6,786

    Re: How to change permission on entire ntfs partition

    On linux I have installed wine, but then I'm trying to load one or other windows application it shows me error that execute bit is not set.
    The irony of it all is that there is no way Wine can determine or even cares if a given *.exe file has a Linux executable bit set. The problem is something called "cautious launcher".

    Here's three ways to fix it:
    [1] Run it from the terminal:
    Code:
    wine "/path/to/exe/file"
    [2] Fix the file association:
    Right click an *.exe file and select Properties -> Open With -> Add -> Use a custom command > type in: wine

    In the "Open With" tab mark the "wine" you added as the default ( from the Wine that's already selected) and every time you run an exe it should select the wine without the cautious launcher script.

    [3] Fix it at it's source:
    Open up as root "Properties" on /usr/share/applications/wine.

    What you will see is this:
    cautious-launcher %f wine start /unix
    Change it to this:
    Code:
    wine start /unix
    I would go with option [2] myself. I don't like messing with system files unless I really have to.

  4. #4
    Join Date
    Apr 2011
    Beans
    13

    Re: How to change permission on entire ntfs partition

    Nice I have tried this

    [2] Fix the file association:
    Right click an *.exe file and select Properties -> Open With -> Add -> Use a custom command > type in: wine

    In the "Open With" tab mark the "wine" you added as the default ( from the Wine that's already selected) and every time you run an exe it should select the wine without the cautious launcher script.
    and it works for me

    Thanks

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •