Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't Start Install

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Beans
    18

    Can't Start Install

    Hi,

    I've got an machine that I want to use Ubuntu on but I just can't get the install to start.

    Debian installs and works fine.

    I've tried Ubuntu 10.10 and 11.04 - same problem.
    I've tried 32-bit and 64-bit - same problem.

    When I try the normal CD, it boots from the CD, shows a screen with a symbol on the bottom (looks like a keyboard = little man) and then goes to a black screen with a flashing cursor at the top left and stays like that forever.

    When I try the alternate CD (which I believe is a text based install?), it boots to a graphical screen to pick the language, I hit enter and it goes to a black screen and sits there forever.

    It's an AMD Sempron 3400+ in a Gigabyte GA-MA69VM-S2 motherboard with an onboard ATI X1500 graphics card.

    Here is the motherboard spec:
    http://uk.gigabyte.com/products/prod...px?pid=2500#sp

    I've also tried a PCI graphics card and that didn't help.

    Any ideas?

    Thanks,

    Ian

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    13,647
    Distro
    Xubuntu

    Re: Can't Start Install

    It sounds like you need boot options. There are links explaining how in this post:

    http://ubuntuforums.org/showthread.php?t=1580857
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  3. #3
    Join Date
    Jan 2009
    Beans
    18

    Re: Can't Start Install

    Hi,

    Thanks for that - I played with the various boot options and setting the "acpi=off" made it boot into the install normally and the install completed successfully.

    Any idea why that would be?

    However, now it's finished the install and tried to boot, I get a similar problem to the install but I dont really want to use acpi=off all the time as I want it to be as power efficient as possible.

    Any ideas?

    Thanks,

    Ian

  4. #4
    Join Date
    Dec 2008
    Location
    W-slp-Sierra Nevada usa
    Beans
    1,401
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Start Install

    Quote Originally Posted by ichilton View Post
    Hi,

    Thanks for that - I played with the various boot options and setting the "acpi=off" made it boot into the install normally and the install completed successfully.

    Any idea why that would be?

    However, now it's finished the install and tried to boot, I get a similar problem to the install but I dont really want to use acpi=off all the time as I want it to be as power efficient as possible.

    Any ideas?

    Thanks,

    Ian
    Check to see if there are any Additional drivers or Hardware drivers waiting to be downloaded. System > Administration > Additional drivers and often the icon for additional drivers appears upper right hand corner by the clock if they are available.
    boot_info_script by meierfra & Gert Hulselmans
    unetbootin to burn liveCD/USB
    Repair Windows7 Boot
    Partitioning

  5. #5
    Join Date
    Jan 2009
    Beans
    18

    Re: Can't Start Install

    Hi,

    I booted with acpi=off but there are no additional drivers to install. I also did a dist-upgrade while I was in there but it still won't boot without acpi=off.

    I found this page: https://wiki.ubuntu.com/DebuggingACPI
    So I started going through the list of paramters and the 3rd one down is the one which makes it boot - pci=noacpi.

    If I use pci=noacpi then it consistently boots.

    Is there a disadvantage to booting with that? - will it affect the power saving/consumption? will it impair the use of PCI cards?

    Any ideas how I can get it to boot without it?

    I've had a look through the BIOS settings and tried changing a few but it doesn't seem to have an effect.

    Thanks,

    Ian

  6. #6
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't Start Install

    you said "i've got a machine", well its not very usefull
    look at synaptic to install custom acpi if your "machine" is acer or asus (google around: ubuntu+yourmodel /acpi+yourmodel)

    but sadly there is a bunch of acpi issues related to linux. If you dont have such trouble with debian, then look at ubuntu custom settings (blacklist, ...) and watch your logs of course.

    maybe add acpi:debug to the boot line, then watch the log. Maybe your bios have several acpi settings to tweak.

  7. #7
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Can't Start Install

    Quote Originally Posted by ichilton View Post
    Hi,

    I booted with acpi=off but there are no additional drivers to install. I also did a dist-upgrade while I was in there but it still won't boot without acpi=off.

    I found this page: https://wiki.ubuntu.com/DebuggingACPI
    So I started going through the list of paramters and the 3rd one down is the one which makes it boot - pci=noacpi.

    If I use pci=noacpi then it consistently boots.

    Is there a disadvantage to booting with that? - will it affect the power saving/consumption? will it impair the use of PCI cards?

    Any ideas how I can get it to boot without it?

    I've had a look through the BIOS settings and tried changing a few but it doesn't seem to have an effect.

    Thanks,

    Ian
    Yes there "are" disadvantages.

    I'll give you the workaround for this here... Use this sticky, post 1 for reference:
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot

    but I'll sumarrize everything tailored for your problem right here.

    1. Boot temporarily using a "acpi=off" or "nopci" or yours mentioned above... all those "are" the same option.

    2. Go to a terminal session.

    3. Install hwinfo (small graphics utility)
    Code:
    sudo apt-get install hwinfo
    4. Find the modes of your video card:
    Code:
    sudo hwinfo --framebuffer
    It should have ouput simlar to this
    Code:
    02: None 00.0: 11001 VESA Framebuffer                           
      [Created at bios.464]
      Unique ID: rdCR.WzmqMIsndrA
      Hardware Class: framebuffer
      Model: "NVIDIA G92 Board - 03920051"
      Vendor: "NVIDIA Corporation"
      Device: "G92 Board - 03920051"
      SubVendor: "NVIDIA"
      SubDevice: 
      Revision: "Chip Rev"
      Memory Size: 14 MB
      Memory Range: 0xd5000000-0xd5dfffff (rw)
      Mode 0x0300: 640x400 (+640), 8 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+800), 8 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0307: 1280x1024 (+1280), 8 bits
      Mode 0x030e: 320x200 (+640), 16 bits
      Mode 0x030f: 320x200 (+1280), 24 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
      Mode 0x0312: 640x480 (+2560), 24 bits
      Mode 0x0314: 800x600 (+1600), 16 bits
      Mode 0x0315: 800x600 (+3200), 24 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0318: 1024x768 (+4096), 24 bits
      Mode 0x031a: 1280x1024 (+2560), 16 bits
      Mode 0x031b: 1280x1024 (+5120), 24 bits
      Mode 0x0330: 320x200 (+320), 8 bits
      Mode 0x0331: 320x400 (+320), 8 bits
      Mode 0x0332: 320x400 (+640), 16 bits
      Mode 0x0333: 320x400 (+1280), 24 bits
      Mode 0x0334: 320x240 (+320), 8 bits
      Mode 0x0335: 320x240 (+640), 16 bits
      Mode 0x0336: 320x240 (+1280), 24 bits
      Mode 0x033d: 640x400 (+1280), 16 bits
      Mode 0x033e: 640x400 (+2560), 24 bits
      Mode 0x0345: 1600x1200 (+1600), 8 bits
      Mode 0x0346: 1600x1200 (+3200), 16 bits
      Mode 0x0347: 1400x1050 (+1400), 8 bits
      Mode 0x0348: 1400x1050 (+2800), 16 bits
      Mode 0x0349: 1400x1050 (+5600), 24 bits
      Mode 0x034a: 1600x1200 (+6400), 24 bits
      Mode 0x0352: 2048x1536 (+8192), 24 bits
      Mode 0x0360: 1280x800 (+1280), 8 bits
      Mode 0x0361: 1280x800 (+5120), 24 bits
      Mode 0x0362: 768x480 (+768), 8 bits
      Mode 0x0364: 1440x900 (+1440), 8 bits
      Mode 0x0365: 1440x900 (+5760), 24 bits
      Mode 0x0368: 1680x1050 (+1680), 8 bits
      Mode 0x0369: 1680x1050 (+6720), 24 bits
      Mode 0x037b: 1280x720 (+5120), 24 bits
      Mode 0x037c: 1920x1200 (+1920), 8 bits
      Mode 0x037d: 1920x1200 (+7680), 24 bits
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    Its pretty safe to assume that most monitors in the last 5 years have 1024x798 at 24bit color. So if I look at this line:
    Code:
      Mode 0x0318: 1024x768 (+4096), 24 bits
    
    I copy down the hex number "0x0318"...

    5. Open /etc/default/grub for edit with previledges:
    Code:
    gksudo gedit /etc/default/grub
    6. First Line you are looking for says:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=7"
    Change it to this
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=0x0318 vt.handoff=7"
    7. Next line you looking for in this file is
    Code:
    #GFXMODE=640x480
    Change it to match the resoltuion your picked above
    Code:
    #GFXMODE=1024x798x24
    8. Save and close the file.

    9. Update your grub files.
    Code:
    sudo update-grub
    10. reboot and test.

    Tell me how it goes for you... or if you need more info.

    Note- You can pick any mode both your card, your monitor and you can handle. Remember that text in a 1920x1200 screen is pretty small! Just ensure you are consistant in where you change it in those 2 places of that file. What this does is preps the card into a mode at Grub, the kernel... passes that mode through KMS to the X-Session.

    Edit- I know that driver is supported by the xorg "radeon" driver. If you edit your sources file (/etc/apt/sources.list) and uncomment the Conical Partners repo (2 lines in there) then an additional driver may show up or not, depending if that card is still supported by ATI. More work if you have ATI, that repo is not a default setting, so the fglrx packages (ATI Drivers) don't show as a default in 11.10. (argh!)
    Last edited by MAFoElffen; October 28th, 2011 at 09:10 PM. Reason: Color coordinated for clarity...

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  8. #8
    Join Date
    Oct 2008
    Beans
    9

    Re: Can't Start Install

    Quote Originally Posted by ichilton View Post
    Hi,

    I've got an machine that I want to use Ubuntu on but I just can't get the install to start.

    Debian installs and works fine.

    I've tried Ubuntu 10.10 and 11.04 - same problem.
    I've tried 32-bit and 64-bit - same problem.

    When I try the normal CD, it boots from the CD, shows a screen with a symbol on the bottom (looks like a keyboard = little man) and then goes to a black screen with a flashing cursor at the top left and stays like that forever.

    When I try the alternate CD (which I believe is a text based install?), it boots to a graphical screen to pick the language, I hit enter and it goes to a black screen and sits there forever.

    It's an AMD Sempron 3400+ in a Gigabyte GA-MA69VM-S2 motherboard with an onboard ATI X1500 graphics card.

    Here is the motherboard spec:
    http://uk.gigabyte.com/products/prod...px?pid=2500#sp

    I've also tried a PCI graphics card and that didn't help.

    Any ideas?

    Thanks,

    Ian
    Hi,

    I have exactly the same problems with my PC which has GA GA-MA69VM-S2 F8 mother board. I tested various distributions - only Ubuntu 8.04 works. Can't install any other newer distribution doesn't matter 32 or 64 bits. Same results with Fedora 15. Any ideas?

  9. #9
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Can't Start Install

    Quote Originally Posted by leodan View Post
    Hi,

    I have exactly the same problems with my PC which has GA GA-MA69VM-S2 F8 mother board. I tested various distributions - only Ubuntu 8.04 works. Can't install any other newer distribution doesn't matter 32 or 64 bits. Same results with Fedora 15. Any ideas?

    also have you tried debian (or if you like more stuff preconfigured like in Ubuntu try Chrunchbang)? as OP suggested Debian worked well.

    It seems newer ubuntu lost the ability to boot on soem a bit older systems. I am also not sure why this happened. I see that my CPU is compatible but the boot just doesn't happen. funny thing is that upon using the PLOP boot manager it all booted normally. (ok this might be a different issue).
    Read the easy to understand, lots of pics Ubuntu manual.
    Do i need antivirus/firewall in linux?
    Full disk backup (newer kernel -> suitable for newer PC): Clonezilla
    User friendly full disk backup: Rescuezilla

  10. #10
    Join Date
    Oct 2008
    Beans
    9

    Re: Can't Start Install

    Hi,

    Yepp, It works with Debian 6.0.3 without any problems. Tried Mint 11 - fails. So rule of thumb would before attempting to install or more importantly to upgrade your Linux machine try live CD or USB first - if fails to run most likely you will have a problem during installation or the upgrade.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •