Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Can't Start Install

  1. #11
    Join Date
    Oct 2008

    Re: Can't Start Install


    Yepp, It works with Debian 6.0.3 without any problems. Tried Mint 11 - fails. So rule of thumb would before attempting to install or more importantly to upgrade your Linux machine try live CD or USB first - if fails to run most likely you will have a problem during installation or the upgrade.

  2. #12
    Join Date
    Dec 2008
    W-slp-Sierra Nevada usa
    Ubuntu 14.04 Trusty Tahr

    Re: Can't Start Install

    Quote Originally Posted by leodan View Post

    Yepp, It works with Debian 6.0.3 without any problems. Tried Mint 11 - fails. So rule of thumb would before attempting to install or more importantly to upgrade your Linux machine try live CD or USB first - if fails to run most likely you will have a problem during installation or the upgrade.
    Your methodology would seem sound at first glance, but the way I understand the problem your 'rule of thumb' is not foolproof because the liveCD/USB graphics drivers/setup is different from an installed Ubuntu system's method of setting up the graphics drivers. Often times, lately at least, the liveCD/USB graphics might work fine, but when booting for the first time from the HD, new installation, graphics fails as a different set of video parameters are loaded trying to use properly whatever graphics chipset your hardware uses. So there is to my knowledge, no sure way of knowing in advance whether or not there will be graphics issues after the system is installed to hard disk.
    It's not exactly easy or apparent always, that the problem one might experience on first boot after install, is a Grub/bootloader problem or a graphics problem. Messing around with the boot parameters (if a graphics problem is suspected - like blinking cursor upper left hand corner on a black background (nomodeset, acpi=off, etc.)) or a Grub/bootloader problem, must be sussed first. If you suspect a graphics problem, change boot line, add parameters, if one suspects a Grub/bootloader problem, run the bash shell program and post the RESULTSx.txt file it produces.

    EDIT: If you're willing to 'play around' a little bit, do me a favor and execute the "" file: It's not dangerous, it's nothing more than a really, really, simple script file that:
    • downloads,
    • extracts,
    • and runs the file named "".
    • It generates the RESULTS.txt file in a directory named ~/Downloads/bootinfoscriptfiles.
    • It copies the RESULTS.txt file to the Desktop, and then opens it with Gnome's gedit program.


    Using whatever directory you download the script file to execute it with following command:
    sudo bash directory/
    I'm a real novice at writing scripts, as you will see if you edit the "" file. But if you do run it, and it works for you, once you are in gedit, editing the RESULTS.txt file: then highlight and copy the entire text of the file into a fresh reply, enclosed in code tags,click on the #icon to enclose the entire pasted, highlighted, text with code tags.
    Attached Files Attached Files
    Last edited by Hakunka-Matata; October 29th, 2011 at 09:46 PM.
    boot_info_script by meierfra & Gert Hulselmans
    unetbootin to burn liveCD/USB
    Repair Windows7 Boot

  3. #13
    Join Date
    Mar 2010
    Ubuntu Development Release

    Re: Can't Start Install

    Quote Originally Posted by ichilton View Post

    I booted with acpi=off but there are no additional drivers to install. I also did a dist-upgrade while I was in there but it still won't boot without acpi=off.

    I found this page:
    So I started going through the list of paramters and the 3rd one down is the one which makes it boot - pci=noacpi.

    If I use pci=noacpi then it consistently boots.

    Is there a disadvantage to booting with that? - will it affect the power saving/consumption? will it impair the use of PCI cards?

    Any ideas how I can get it to boot without it?

    I've had a look through the BIOS settings and tried changing a few but it doesn't seem to have an effect.


    Yes there "are" disadvantages.

    I'll give you the workaround for this here... Use this sticky, post 1 for reference:
    Sticky: [all variants] Graphics Resolution- Upgrade /Blank Screen after reboot

    but I'll sumarrize everything tailored for your problem right here.

    1. Boot temporarily using a "acpi=off" or "nopci" or yours mentioned above... all those "are" the same option.

    2. Go to a terminal session.

    3. Install hwinfo (small graphics utility)
    sudo apt-get install hwinfo
    4. Find the modes of your video card:
    sudo hwinfo --framebuffer
    It should have ouput simlar to this
    02: None 00.0: 11001 VESA Framebuffer                           
      [Created at bios.464]
      Unique ID: rdCR.WzmqMIsndrA
      Hardware Class: framebuffer
      Model: "NVIDIA G92 Board - 03920051"
      Vendor: "NVIDIA Corporation"
      Device: "G92 Board - 03920051"
      SubVendor: "NVIDIA"
      Revision: "Chip Rev"
      Memory Size: 14 MB
      Memory Range: 0xd5000000-0xd5dfffff (rw)
      Mode 0x0300: 640x400 (+640), 8 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+800), 8 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0307: 1280x1024 (+1280), 8 bits
      Mode 0x030e: 320x200 (+640), 16 bits
      Mode 0x030f: 320x200 (+1280), 24 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
      Mode 0x0312: 640x480 (+2560), 24 bits
      Mode 0x0314: 800x600 (+1600), 16 bits
      Mode 0x0315: 800x600 (+3200), 24 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0318: 1024x768 (+4096), 24 bits
      Mode 0x031a: 1280x1024 (+2560), 16 bits
      Mode 0x031b: 1280x1024 (+5120), 24 bits
      Mode 0x0330: 320x200 (+320), 8 bits
      Mode 0x0331: 320x400 (+320), 8 bits
      Mode 0x0332: 320x400 (+640), 16 bits
      Mode 0x0333: 320x400 (+1280), 24 bits
      Mode 0x0334: 320x240 (+320), 8 bits
      Mode 0x0335: 320x240 (+640), 16 bits
      Mode 0x0336: 320x240 (+1280), 24 bits
      Mode 0x033d: 640x400 (+1280), 16 bits
      Mode 0x033e: 640x400 (+2560), 24 bits
      Mode 0x0345: 1600x1200 (+1600), 8 bits
      Mode 0x0346: 1600x1200 (+3200), 16 bits
      Mode 0x0347: 1400x1050 (+1400), 8 bits
      Mode 0x0348: 1400x1050 (+2800), 16 bits
      Mode 0x0349: 1400x1050 (+5600), 24 bits
      Mode 0x034a: 1600x1200 (+6400), 24 bits
      Mode 0x0352: 2048x1536 (+8192), 24 bits
      Mode 0x0360: 1280x800 (+1280), 8 bits
      Mode 0x0361: 1280x800 (+5120), 24 bits
      Mode 0x0362: 768x480 (+768), 8 bits
      Mode 0x0364: 1440x900 (+1440), 8 bits
      Mode 0x0365: 1440x900 (+5760), 24 bits
      Mode 0x0368: 1680x1050 (+1680), 8 bits
      Mode 0x0369: 1680x1050 (+6720), 24 bits
      Mode 0x037b: 1280x720 (+5120), 24 bits
      Mode 0x037c: 1920x1200 (+1920), 8 bits
      Mode 0x037d: 1920x1200 (+7680), 24 bits
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    Its pretty safe to assume that most monitors in the last 5 years have 1024x798 at 24bit color. So if I look at this line:
      Mode 0x0318: 1024x768 (+4096), 24 bits
    I copy down the hex number "0x0318"...

    5. Open /etc/default/grub for edit with previledges:
    gksudo gedit /etc/default/grub
    6. First Line you are looking for says:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=7"
    Change it to this
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=0x0318 vt.handoff=7"
    7. Next line you looking for in this file is
    Change it to match the resoltuion your picked above
    8. Save and close the file.

    9. Update your grub files.
    sudo update-grub
    10. reboot and test.

    Tell me how it goes for you... or if you need more info.

    Note- You can pick any mode both your card, your monitor and you can handle. Remember that text in a 1920x1200 screen is pretty small! Just ensure you are consistant in where you change it in those 2 places of that file. What this does is preps the card into a mode at Grub, the kernel... passes that mode through KMS to the X-Session.

    Edit- I know that driver is supported by the xorg "radeon" driver. If you edit your sources file (/etc/apt/sources.list) and uncomment the Conical Partners repo (2 lines in there) then an additional driver may show up or not, depending if that card is still supported by ATI. More work if you have ATI, that repo is not a default setting, so the fglrx packages (ATI Drivers) don't show as a default in 11.10. (argh!)
    Last edited by MAFoElffen; October 28th, 2011 at 09:10 PM. Reason: Color coordinated for clarity...

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  4. #14
    Join Date
    Oct 2008

    Re: Can't Start Install

    All right, at last found a remedy to my problem - I have disabled HPET support in BIOS power settings. I tested Ubuntu 11.10 , 12.04 beta 2 and Fedora 16 all boot and work without any problems . Just to remind my motherboard is ga-ma69vm-s2 f10e. Was not able to run most of the linux distros newer than Ubuntu 8.04.

Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts