Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: firmware-b43-installer error!!!

  1. #1
    Join Date
    Sep 2011
    Beans
    22

    Question firmware-b43-installer error!!!

    Here's the problem:

    I'm new to Ubuntu and my wi-fi wasn't working, so I tried to install firmware-b43-lpphy-installer using Synaptic Package Manger. It didn't install and exited with error status 1. So I tried to uninstall the partial package and re-install the firmware-b43-installer, but it won't install now either.

    It tries to connect to a remote mirror and exits with error status 4 after multiple unsuccessful attempts at connecting.

    Also, now each time I boot up my system, a message window pops up saying that there's an error with the system files and points to firmware-b43-installer.

    Please help, and also tell if I really do need to install it????

    Details:

    Laptop: Toshiba L650
    OS: Ubuntu 11.04(Natty)
    Card: Broadcom BCM4313

    Please help!!!

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: firmware-b43-installer error!!!

    I've closed your other thread here:

    http://ubuntuforums.org/showthread.php?t=1841982

    Since you have complicated the situation with the firmware-b43-installer I haven't merged the two threads, but in future please do not create more than one thread on the same problem. It dilutes community effort.

    But to your technical problem. The firmware-b43-installer package is not appropriate to your bcm4313 chipset. From your previous thread I see that there was evidence for both the open source driver and the proprietary STA driver being installed, and either of these should have worked, and you need to focus on those.

    For now, post the complete and exact error that appears concerning the firmware-b43-installer. That may give a clue as to what needs to be done to purge it.

    EDIT: also, I've moved the thread to Networking and Wireless. I can understand why you chose the Installation and Upgrade forum, but N&W is more appropriate and more likely to find you the help you need.
    Last edited by coffeecat; September 11th, 2011 at 02:28 PM. Reason: Explanation for thread move.
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Sep 2011
    Beans
    22

    Re: firmware-b43-installer error!!!

    Sorry for the hassle. I see your point.

    After submitting an error report, after being prompted by the system, the error message on startup has vanished.

    The problem of connecting to Internet using wi-fi persists. On boot-up the hardware doesn't scan/show wireless connections despite their availability.

    Right now there is no firmware-b43-installer or firmware-b43-lpphy-installer installed on the system. Apart from that I've blacklisted brcm80211.


    Can someone help me establish the connection from scratch?

    Help appreciated.

  4. #4
    Join Date
    Sep 2011
    Beans
    22

    Re: firmware-b43-installer error!!!

    The system generated error message related to firmware-b43-installer:

    Code:
    ProblemType: Package
    DistroRelease: Ubuntu 11.04
    Package: firmware-b43-installer (not installed)
    ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
    Uname: Linux 2.6.38-11-generic i686
    NonfreeKernelModules: wl
    AptOrdering:
     firmware-b43-lpphy-installer: Remove
     firmware-b43-installer: Install
     firmware-b43-installer: Configure
    Architecture: i386
    Date: Sun Sep 11 16:24:43 2011
    ErrorMessage: subprocess installed post-installation script returned error exit status 4
    InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
    SourcePackage: b43-fwcutter
    Title: package firmware-b43-installer (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 4
    UpgradeStatus: No upgrade log present (probably fresh install)

  5. #5
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: firmware-b43-installer error!!!

    Quote Originally Posted by divyansh.sachdeva View Post
    Apart from that I've blacklisted brcm80211.
    I know that was suggested in the previous thread, but I'm not convinced that was a good idea. I have the bcm4313 wireless in a netbook and it works out of the box in Natty with the inbuilt brcm80211 driver. And I've recently helped someone install Natty on a different make netbook with the bcm4313 wireless, and that too worked out of the box.

    I've got to go off-line for an hour or two now. When I get back I will read through your previous thread more closely and post back.
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  6. #6
    Join Date
    Sep 2011
    Beans
    22

    Re: firmware-b43-installer error!!!

    Thanks. Really appreciate it.

    I understand that in some cases wireless connection doesn't give any trouble. Thing is I might've made some changes to my system unknowingly as I was trying various things to make the connection work.

    I'd appreciate it if you could check out my system's current configuration and then we might find a solution. Tell me the commands I need to execute to get the current status of the system.

  7. #7
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: firmware-b43-installer error!!!

    OK, I've had a chance to read through your other thread. There were some side issues but the essence of it (if I read the thread correctly) is that:

    1 - You had already installed the STA driver:
    Code:
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: Askey Computer Corp. Device [144f:7175]
    Kernel driver in use: wl
    2 - You were not able to see wireless networks in Network Manager.

    3 - When you blacklisted the brcm80211 driver, you were able to see wireless networks after the first reboot, but not after a second reboot.

    Before we try to untangle all this, I suggest a simple experiment. Based on my experience of a HP netbook and a Samsung netbook, the bcm4313 card *should* just work out of the box with Natty. However, this is not necessarily so with your Toshiba, a make I have no experience of. Unfortunately, there can sometimes be all sorts of weird and wonderful conflicts between wireless drivers and hardware specifics. I remember a thread where (another) wireless chipset was disabled every time the OP used the screen brightness key combinations. I think that comes under the weird category.

    Boot up with the live 11.04 CD or USB - whichever you used to install Ubuntu Natty. Choose "try Ubuntu" to get to the live desktop - you do not want the installer. Click on the network manager icon (near top right). Can you see any wireless networks? If you can see yours, can you connect to it? Don't worry about the issue you raised in the other thread about connecting to your ISP. There are two steps in the chain: connecting the modem-router to your ISP and connecting your computer wirelessly to the wireless router. Obviously you want to do both, but we need to see if you can connect the computer to the router wirelessly in the live session with the default brcm80211 driver.

    Post back with what you find, and we'll take it from there.
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  8. #8
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    19,228
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: firmware-b43-installer error!!!

    Hi, please post the results of these commands:
    Code:
    rfkill list all
    Code:
    sudo lshw -C network
    Code:
    iwconfig
    Code:
    lsmod
    Code:
    cat /etc/modprobe.d/blacklist.conf
    by clicking on new reply and click # and paste the information between the brackets.
    Thank you

  9. #9
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: firmware-b43-installer error!!!

    Quote Originally Posted by wildmanne39 View Post
    Hi, please post the results of these commands:
    Code:
    cat /etc/modprobe.d/blacklist.conf
    Hi there, wildmanne39. Good to see you joining in. I can help you with that one. If you look at the OP's previous thread (I've linked it in post #2) you'll see that they were asked to do this:

    Blacklist the following module:

    Code:
    echo "blacklist brcm80211" | sudo tee /etc/modprobe.d/blacklist-brcm80211.conf
    Just for the record I've now had a chance to look in my Natty system installed in a machine with the same wireless chipset as the OP. It had previously run OK with the brcm80211 driver, but out of interest I installed the STA driver (which the OP had done) and the STA driver produced the file /etc/modprobe.d/blacklist-bcm43.conf which contains:

    Code:
    blacklist b43
    blacklist b43legacy
    blacklist ssb
    blacklist bcm43xx
    blacklist brcm80211
    Which means that the OP now has brcm80211 blacklisted twice over! And that's why I asked the OP to run 11.04 live to see how the brcm80211 driver behaves in a default system.

    My blacklist.conf (which will almost certainly be the same as the OP's) only lists the bcm43xx out of the Broadcom set as blacklisted
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  10. #10
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    19,228
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: firmware-b43-installer error!!!

    Hi coffeecat, this is a card that I have only started to see recently and it has been problematic for me to get working, where as most broadcom cards are not. I appreciate all they help I can get.
    Thank you

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •